1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Hacking your Series 2 DTivo just got a WHOLE lot easier...

Discussion in 'TiVo Underground' started by Gunnyman, Oct 16, 2005.

  1. Dec 23, 2005 #2041 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    No, I was referring to the image that comes with the 3.1.5f Instantcake download, which is also linked in the Zipper site. The PTV 4.01 CD contains the hacked kernels, not the actual software.
     
  2. Dec 23, 2005 #2042 of 11850
    GAM

    GAM Niiiice!

    232
    0
    Oct 13, 2003

    I need a little help in changing the crontab from safereboot to forced reboot.
    How does the file need to be changed for this to take effect?
    Thanks in advance!
     
  3. Dec 23, 2005 #2043 of 11850
    Diana Collins

    Diana Collins Well-Known Member TCF Club

    2,651
    41
    Aug 21, 2002
    New York...
    Change...

    25 9 * * 1,4 tivosh /enhancements/safereboot.tcl; echo "`date` SCHEDULED REBOOT" >> /var/spool/cron/cronlogs/CRONLOG-MAIN

    to....

    25 9 * * 1,4 echo "`date` SCHEDULED REBOOT" >> /var/spool/cron/cronlogs/CRONLOG-MAIN; reboot
     
  4. Dec 23, 2005 #2044 of 11850
    GAM

    GAM Niiiice!

    232
    0
    Oct 13, 2003
    Thank you sir!

    Everyone have a happy holiday and a healthy new year!!!
     
  5. Dec 23, 2005 #2045 of 11850
    hawkeye1991

    hawkeye1991 New Member

    58
    0
    Nov 29, 2005

    Yup,

    Even after rebooting, I can't see the tivo. My router seems fine. I'm able to ping the router. I can't ping the tivo and ipscan doesn't show the tivo Ip address as being active.

    Does CDE mess with the zipper?

    Does the tivo need to be connected to the dish when I try to telnet to it.

    My router and my acces to the dish are too far off to be connected at the same time

    So after did the CDE, I did the guided set up and powered it down. Connected it to my router in my office (note: no dish connection at this point!) and rebooted it. Still no go.

    At this point, If I want to start all over again, do I need to reformat the disk? or can I just restore the image, run the zipper and move on?



    Thanks for you help.

    Hawk.
     
  6. Dec 23, 2005 #2046 of 11850
    Diana Collins

    Diana Collins Well-Known Member TCF Club

    2,651
    41
    Aug 21, 2002
    New York...
    I don't know what a CDE does in terms of Zipper enhancements. It might have blown away the rc.sysinit.author file, where things like telnet and ftp are started.

    You probably can just rerun the Zipper, and just skip the image install step.

    You do NOT need a satellite connection to do ANYTHING, except watch live TV of course.
     
  7. Dec 23, 2005 #2047 of 11850
    Gunnyman

    Gunnyman Just a boring dude

    30,798
    12
    Jul 10, 2003
    !Texas
    since Network settings are stored in MFS, and MFS gets wiped with a C&DE they're gone.
    Author file is intact though.
     
  8. Dec 23, 2005 #2048 of 11850
    dsmturbo

    dsmturbo New Member

    63
    0
    Dec 30, 2003
    Alberta Canada
    Yes, MY Bad Russ, downloaded Instant Cake for HR10-250, so I assume I can just use the Image from there. Would I boot computer with instant cake CD or the one I already have (PTV Upgrade 4.01)...shouldn't matter which one I would think.
    I copied the new HR10-250 image from IC to my Zipper CD, so I should be good to go now.

    Thank you for figuring it out for me, I would have never known. The image I was using is supposedly a Virgin HR10-250 image but must be older.

    I supposed I could have just made a backup of the image on the Tivo already, the factory drive. I never thought of doing that...I feel so stupid.

    All my best wishes for a safe, healthy, holiday season to you and Gunnyman, and all other Community members here. I love this place
     
  9. Dec 23, 2005 #2049 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Or....read the directions.
     

    Attached Files:

    • cde.zip
      File size:
      23.8 KB
      Views:
      28
  10. Dec 23, 2005 #2050 of 11850
    jspencer

    jspencer New Member

    65
    0
    Dec 23, 2001
    Orlando FL
    Rbautch I am about to zipper my HD10-250. I just previously upgraded it to two 300 gig drives. Do ya see any issues with it having the two large drives? Thanks
     
  11. Dec 23, 2005 #2051 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Thanks. Looks like your all set. Copy that image to your tools disk and boot the PTV 4.01 CD.
     
  12. Dec 23, 2005 #2052 of 11850
    Diana Collins

    Diana Collins Well-Known Member TCF Club

    2,651
    41
    Aug 21, 2002
    New York...
    But....wouldn't that mean that the TiVo would just revert to DHCP? I seem to remember my 6.2 TiVos asking for IP address as soon as I plugged in a dongle, and before any hacks had been applied. Maybe I was hallucinating (wouldn't be the first time). :)
     
  13. Dec 23, 2005 #2053 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I recently changed the block allocation size in the Zipper's restore command to handle large drives. This won't affect you since you've already upgraded your drives. Just run the Zipper on the master drive and you'll be set. Confirm that the Zipper recognizes your drive as an HR10-250 and tailors the hacks accordingly.
     
  14. Dec 23, 2005 #2054 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I believe you are correct, Dan.
     
  15. Dec 23, 2005 #2055 of 11850
    dsmturbo

    dsmturbo New Member

    63
    0
    Dec 30, 2003
    Alberta Canada
    Just one more ? before Holidays...BTW, you and Gunnyman can take a break...on me LOL

    I get this when I run Zipper:
    Checking Tools Disk...
    zipper.sh : [/cdrom/superpatch-67all-NutKase-1.1.tcl : binary operator expected

    I don't know what it is trying to tell me?
     
  16. Dec 23, 2005 #2056 of 11850
    SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Hey guys, I noticed there is a new update to The Zipper today. Is this just for the HR10-250 stuff?

    Is there a revision history log that you are keeping that we could look at to make sure we are not missing anything? If a log does not exist, I will ask Santa for it for Christmas.;)
     
  17. Dec 23, 2005 #2057 of 11850
    jsmyth40

    jsmyth40 New Member

    11
    0
    Feb 20, 2005
    I used Instantcake to add a second 400GB drive to my HR10-250 that has been running with one hacked 3.1.5e 400GB drive for about one year. I've been using Enhancements for the past two months to add functionality to the unit.

    I chose the Expand option for Instantcake, thinking that would marry the two drives and update the kernel to 3.1.5f before running the Zipper. I did not need to keep any shows from the first drive.

    It appeared that Zipper successfully, but I did respond No to the prompt to restore the detected 6.2 image, thinking that I already had the correct image from Instantcake. Everything else appeared to proceed normally except for the following message (also reported in post #1974):
    zipper.sh: [/cdrom/superpatch-67all-NutKase-1.1.tcl: binary operator expected]

    After installing the drives in the TiVo it gets stuck in a reboot loop with the GSOD.

    I can connect with a serial connection, but I will wait to post any excerpts of the log file until I receive directions on the pertinent lines.

    Thanks for your assistance.
     
  18. Dec 23, 2005 #2058 of 11850
    teberly

    teberly New Member

    11
    0
    Dec 23, 2005
    Ok - I tried to run the Zipper on my factory installed 40 gig DTIVO drive. Zipper went smoothly. I ran Tweaks, chose express. All seemed fine. I was networked. But I had no Tivoweb (i had installed it). So I decided to run tweak_unistall - all has gone to hell since then.

    After uninstall I couldn't reinstall - errors about missing files and directories. So I reran the Zipper - all went fine, but when I reboot the Tivo it does not connect to my network. The lights on the USB NIC blink, but the IP does not show up on my router and I cannot telnet it.

    I decided to install a new drive image, but it won't let me - says there is not enough room.

    Any ideas? Is there a quick way to wipe the drive so that I can start from scratch?

    I wanted to add that I succesfully hacked my 80gig DTIVO with the zipper this weekend - so have gotten through this before.
     
  19. Dec 23, 2005 #2059 of 11850
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I don't know either, but since this is just a check of your CD to make sure you have the right files on it, you can ignore it or remove that line from zipper.sh.
     
  20. Dec 23, 2005 #2060 of 11850
    bnm81002

    bnm81002 New Member

    1,799
    0
    Oct 2, 2004



    my exact thoughts as well, the old Zipper showed what changes and additions were made on the date that it was made on, now there's no listing of such just the version # and updated date :(
     

Share This Page