1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Failed S2 6.4a slice upgrade, best way to recover now?

Discussion in 'TiVo Underground' started by markis, Apr 19, 2012.

  1. markis

    markis Member

    Mar 1, 2005
    I was following notes from my old post to manually upgrade my HR10-250 from 6.3e to 6.4a with the DVRUpgrade slices from here. I double-checked that installSw.itcl had reboot changed to exit, but I must have been looking at or running the wrong one, because it decided to reboot anyway.

    So, my TiVo restarted and it did boot to the main menu, but I hadn't swapped kernels (with dd from hda6 to hda3), I hadn't copied over any of my hack directories or rc.sysinit.author and I had not made any of the tivoapp patches. So, I've lost all my hacks and telnet on the booting system.

    I hooked the drive up to a PC and booted the MFSLive CD. The first thing I tried was to switch the bootpage back to the old working system (root=/dev/hda7 ...) and tried to power on, but the power on message just stayed on screen for a long time without moving to the next boot screen.

    So, I took the drive out and looked at it with MFSLive. I made dd backups of each kernel /dev/hda6 and /dev/hda3, then copied 6 over 3. I was going to try to manually copy all my hack folders from /dev/hda7 to /dev/hda4, but looking at the /dev/hda7 files and folders, I noticed many of the files are missing or not visible (even with ls -a). For example the old /busybox is empty. Most of the old folders and subfolders are there, like /enhancements, but the files seem to be missing.

    I wonder if the files are possibly still there, but just not visible to MFSLive? Would starting up with the bootpage pointing to the old root /dev/hda7 have caused the files to be deleted?

    What is the best way to proceed? The current state of things is that an unpatched 6.4a system is on /dev/hda4 with the hacked kernel on /dev/hda3. Telnet is not working, so I have the drive connected to a PC with MFSLive.

    Can I rollback and get my 6.3e system working on /dev/hda7 again (even though switching the bootpage back didn't work)? Then I would be able to telnet in and could try to copy all my hack folders over and patch the 6.4a system on /dev/hda4 from the old system with telnet.

    Or would it be possible to use MFSLive or another CD to run Superpatch on the 6.4a system on /dev/hda and get telnet working from scratch?

    I'd like to keep all my recordings if possible.

    Please let me know the best way to proceed without getting into more trouble.
  2. markis

    markis Member

    Mar 1, 2005
    I hope someone can help.

    I tried again with no luck to switch the bootpage back to the old working partition from the MFSLive CD.

    bootpage -P "root=/dev/hda7 dsscon=true console=2,115200 upgradesoftware=false" -C /dev/hda
    bootpage -B 6 /dev/hda
    bootpage -A 3 /dev/hda

    With this, the TiVo is stuck on the "Powering up..." screen.

    I have now looked through the old /dev/hda7 hack directories with both MFSLive and an old ptvlba CD and I can't see any of the hack files at all, even though the directories are intact. Would running installSw.itcl and rebooting into an unpatched 6.4a have deleted those files? Or are those files invisible to MFSLive and only visible over a telnet connection?

    EDIT: I have reverted all my attempts to restore my old /dev/hda7 and so now the TiVo does boot and I can watch TV on 6.4a /dev/hda4, but it's completely unpatched and I have no telnet connection.

    Since I'm beginning to think my old 6.3e system hack files are gone from /dev/hda7, will it work to follow Gunnyman's old Unguide to manually hack the 6.4a running on /dev/hda4? I'd like to at least get telnet working, so I can proceed.

    I should already have the right kernel, so I think I mainly need to set up /busybox, change netfilter, then create a new rc.sysinit.author. Are there any steps I'm missing?

    Once that's working I found an updated patch for 6.4a on DDB.

    Does that sound like it should work?

    (I also have an old zipper CD I made in 2008, but I'm not sure that will work with all the changes in 6.4a.)
  3. markis

    markis Member

    Mar 1, 2005
    Well, I followed some old guides and notes, patched 6.4a and put most of my old hacks back in. Things seem to be working ok now.
  4. Soapm

    Soapm New Member

    May 9, 2007
    So close,...
    Good job, I was going to suggest zipper but I know Gunny has an easy guide to follow so I kept silent.
  5. kenr

    kenr New Member

    Dec 26, 1999
    I hacked my Tivo using a kernel that had killhdinitrd run on it. It was a 3.1.1c kernel. I did this the manual way before these automated scripts came into being. Used things like bootpage, editing /etc scripts etc. It's now running 6.2a but I suspect I'll need to go to 6.4a because I've lost a local channel.

    I'm looking for advice on a way to upgrade this hacked system to 6.4a and still maintain my hacks (except for MRV of course).

  6. texster

    texster New Member

    Mar 10, 2005
    The Slicer from forum sponsor DVR Upgrade has been reported to work in this case. Or, if you are up for doing another manual upgrade, try this guide from dvrpedia.

    Although, if you can live without PBS, and have still have the east coast network channels, then why not wait and see if a workaround restoring the locals can be found before giving up MRV?
  7. Boiler81

    Boiler81 New Member

    Aug 10, 2002
    I am in the same position with lost locals. The Slices are not on my machine despite being in the stream. How do I get them to download?

  8. Boiler81

    Boiler81 New Member

    Aug 10, 2002
    Found out the Slicer will download the slices. I did that and installed them with the Slicer program.

  9. tibo

    tibo New Member

    May 22, 2004
    how did you get the slicer to download...??

    I dont have 6.4a on my box, just 6.2 and 6.2a, but I did buy the slicer and ftp'd to var/tmp as recommended...
    cd /var/tmp
    .slicer 6.4a-01-2-321 .... got the great here we go and then error

    ./slicer: /var/packages/update1: Permission denied
    There are no 6.4a-01-2-321 slices on your Tivo, exiting

    so I have the one large 6.4a slices file unzipped its like 16.73MB, but I dont know where to put it to re-run the script....

    any help in either getting slicer to download or where to manually ftp them would be helpful.

Share This Page