1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Nov 2, 2006 #1861 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    One thing I notice, is that on my HR10 in the crond file it looks for fakecall in /busybox, and you don't want to force a call. You can run fakecall manually from bash with:
    Code:
    tivosh /busybox/fakecall.tcl
    I would look at your cron file since that is what will keep it running over time. If it is using /busybox/fakecall.tcl, you should put it in there. You can look at your cron file by typing root at the bash prompt.
     
  2. Nov 2, 2006 #1862 of 2880
    dayvo

    dayvo New Member

    14
    0
    Nov 1, 2006
    Mound, MN, USA
    Thanks, Finnstang. I'll give it a try this evening and report back.
     
  3. Nov 2, 2006 #1863 of 2880
    dayvo

    dayvo New Member

    14
    0
    Nov 1, 2006
    Mound, MN, USA
    Looks like the updated fakecall.tcl works with 3.1.5f.

    As suggested, ftp'd it into busybox and ran it from telnet. Successful execution reported there. Phone call data in System Information is updated to current time and date and shows call succeeded. Next call scheduled for tomorrow.

    State information in mfs FileSystem updated to:

    PhoneConfig 3194/10 {
    Version = 96
    CallWaitingPrefix = *#
    DialPrefix = *#
    LastSuccessCallDay = 13454
    LastSuccessPgdCallDay = 13454
    LastCallAttemptDay = 13454
    NextCallAttemptDays = 13454
    LastDialInUpdateDate = 13455
    CallStatusInfo = Succeeded
    LastCallStatus = Succeeded
    LastCallAttemptSecInDay = 1162512083
    LastSuccessPgdCallSecInDay = 1162512083
    LastSuccessCallSecInDay = 1162512083
    NextCallAttemptSecInDay = 1162598400
    IndexPath = /State/PhoneConfig
    }

    (whatever that means).

    Thanks very much for your help.
     
  4. Nov 2, 2006 #1864 of 2880
    raddison1971

    raddison1971 New Member

    28
    0
    Nov 2, 2004
    Des Moines,...
    Same here. I ran it manually and it worked fine. However before that I saw the message flash on the screen saying that it was completed successfully and then I checked and it was not. Then rebooted the box and still was not updated. Not sure what to think there. I will let it go about it's business for a few days and check again.

    By the way I got that "sling box" ( ;) ;) ) working (at least seems to be. Pulling one now). Thanks for the instructions.
     
  5. Nov 2, 2006 #1865 of 2880
    raddison1971

    raddison1971 New Member

    28
    0
    Nov 2, 2004
    Des Moines,...
    Okay I was watching "My Name is Earl" (playback) and I saw the Fake Call Successful message. When Earl was finished I was going back to the Now Playing List and the Tivo said that I needed to make a daily call soon. It has changed the date back to 12/31 at 4:48 am. lol I will rerun the fakecall.tcl to fix it and see if I can research why this is not working. Let you know what I find.
     
  6. Nov 3, 2006 #1866 of 2880
    raddison1971

    raddison1971 New Member

    28
    0
    Nov 2, 2004
    Des Moines,...
    I found this location after I placed fakecall.tcl into the /enhacement/fakecall.tcl. Moved it into busybox now. I will see how it works now. I'll let you know.
     
  7. Nov 3, 2006 #1867 of 2880
    raddison1971

    raddison1971 New Member

    28
    0
    Nov 2, 2004
    Des Moines,...
    Actually the rc.sysinit.author file is using just fakecall.tcl. but if you look at the path statement above that you will notice that both busybox and enhancements are in the path. It would use the one in busybox because it is first in the path. Just an FYI for those that would not be able to figure this out.
     
  8. Nov 3, 2006 #1868 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    The fakecall that is run nightly, is run using crond. In crond, it uses /busybox/fakecall.tcl, so in addition to what you said about the author file, this is why I make sure to change and test the one in busybox.
     
  9. Nov 3, 2006 #1869 of 2880
    TomP

    TomP New Member

    79
    0
    Feb 25, 2002
    Rbautch:
    I installed your enhanced script yesterday and everything seems to work great except I set my IP to be static and the tytools will not connect at all no matter what I try. I noticed that in tytools in the perf. that it has an IP of 192.168.0.100 but it will not allow me to change it to .125.
    I can manually start the server and it states its waiting for connection but still tools won't connect.
    I have and Huges DS-HDV40 with the PTVupgrade, PtvNet, and your Enhanments added. Is there any files I can edit to correct this?
    I also tried to remove the Enhancments but I guess I just don't understand how. Still researching.
    Any help would be greeatful.
    Thanks:
    TomP

    :confused:

    I went in an telnet to the dir and started the server manually and then did a refresh with tytools and it worked. It also allowed me to download a .ty file.
    Strange!! Any Ideas??? I'm out!!
    TomP
     
  10. Nov 3, 2006 #1870 of 2880
    bigmikemn

    bigmikemn New Member

    11
    0
    Jul 27, 2005
    Minneapolis, MN
    Hello - Quick question. Does the script no longer Install Hackman? I read earlier in the thread that if in re-install it it will install Hackman, but the current version doesn't seem to be doing that. Is this correct?
     
  11. Nov 3, 2006 #1871 of 2880
    SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Correct, no hackman. Here's the Hackman thread. There's a link to the site in the first post.
    EDIT: It looks like Hackman IS included. See the first post in this thread. I guess I was confusing the Enhancement script with The Zipper. :eek:
     
  12. Nov 3, 2006 #1872 of 2880
    bigmikemn

    bigmikemn New Member

    11
    0
    Jul 27, 2005
    Minneapolis, MN
    Thanks - I tried manually, but it couldn't find/wouldn't create the hackman.cfg file. I will try again, and if I have problems I will bring it over to that thread.
     
  13. Nov 3, 2006 #1873 of 2880
    bigmikemn

    bigmikemn New Member

    11
    0
    Jul 27, 2005
    Minneapolis, MN
    Ok - so I am not Crazy. Hackman is supposed to be part of this distribution. Anyone know how to have it install?
     
  14. Nov 3, 2006 #1874 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    I believe that PortlandPaw put some instructions in the readme on how to install to get people to read it.
     
  15. Nov 3, 2006 #1875 of 2880
    bigmikemn

    bigmikemn New Member

    11
    0
    Jul 27, 2005
    Minneapolis, MN
    Thanks Finnstang - I have read the "Read Me" file in the actual Hackman install.

    I want to know how to have the tweak.sh install Hackman. The first page says it is one of the installed tweaks
     
  16. Nov 3, 2006 #1876 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    If you hack your tivo with the Zipper, Hackman gets removed when you run the enhancement script. I did this because too many newbies were screwing up thier tivos experimenting with Hackman without knowing anything about it. If you hack your tivo manually without your zipper, and then use the enhancement script, Hackman gets installed.
     
  17. Nov 4, 2006 #1877 of 2880
    TABrewer

    TABrewer New Member

    3
    0
    Dec 21, 2001
    After zippering a HR10-250. I get the following message after running sh tweak.sh


    >> bash-2.02# cd /hacks
    bash-2.02# sh tweak.sh

    Downloading latest Enhancement script...
    wget: error while loading shared libraries: cannot
    ot load shared object file: No such file or direct
    Download failed. Adjust DNS and try again? [y/n]:<<
     
  18. Nov 4, 2006 #1878 of 2880
    ttodd1

    ttodd1 Proud Computer Geek

    1,516
    0
    Nov 5, 2003
    SC
    Is it plugged into a network connection? Are your IP, subnet, and dns set correctly on the tivo?
     
  19. Nov 4, 2006 #1879 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Unzip, then copy this file to your /lib directory, then try again.
     

    Attached Files:

  20. Nov 4, 2006 #1880 of 2880
    TABrewer

    TABrewer New Member

    3
    0
    Dec 21, 2001
    That worked...Thanks.

    Another question. I get a DVRUPGRADE with a TiVo character on bootup rather than your splash screen.

    I also have a PTV directory that I don't think I should have, can I remove it & if so How?

    I purchased this drive on Ebay & think these files were already on it.
     

Share This Page