1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Sep 7, 2006 #1661 of 2880
    msommer

    msommer Card's Fan

    86
    0
    Apr 4, 2005
    I actually am using the FA120 with a wireless bridge. I left the wireless settings configured just in case I ever needed them.

    It worked great until the latest upgrade. My throughput values ranged from 9-14. Now they are 4-6.

    EDIT:

    Everything is great again!! I removed the wireless settings and then re ran the script.

    Now if I can just figure out the new folder creation module.... a bit confusing. Episode names keep changing to the group name I create.
     
  2. Sep 7, 2006 #1662 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Start reading here on DDB: /forum/showthread.php?p=252507#post252507
     
  3. Sep 7, 2006 #1663 of 2880
    bman12

    bman12 New Member

    44
    0
    Sep 7, 2003
    I did the uninstall/reinstall on two DTIVOs without a hitch.....I thought. I just noticed that when I click on either todo or suggestions in the tivowebplus user interface I get an internal error message on both TIVOs.
    INTERNAL SERVER ERROR
    --cut here--
    action_ui '/todo' ''
    invalid command name "desc_show"
    while executing
    "desc_show $hovertext"
    ("uplevel" body line 139)
    invoked from within
    "uplevel $body"
    invoked from within
    "ForeachMfsFileTrans fsid name type $path $prefix 15 {
    set rec [db $db openid $fsid]
    set manual 0
    set suggestion 0
    if {$::version >= 3}..."
    (procedure "action_todo" line 121)
    invoked from within
    "action_todo $chan 7 $env"
    (procedure "::action_ui" line 28)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--

    The only thing I didn't do is shut all tivowebplus running items down before uninstall reinstall. Could that be it? Anyone else have this problem?
     
  4. Sep 8, 2006 #1664 of 2880
    eagreer

    eagreer eagreer

    1
    0
    Apr 8, 2005
    Prescott, AZ.
    I get the same internal error for the TODO request.
    I've run Zipper on three different DTivos and really like the results. Great tool...
     
  5. Sep 8, 2006 #1665 of 2880
    msommer

    msommer Card's Fan

    86
    0
    Apr 4, 2005
    I am getting the same errors in the three I upgraded as well.

    --cut here--
    action_ui '/todo' ''
    invalid command name "desc_show"
    while executing
    "desc_show $hovertext"
    ("uplevel" body line 139)
    invoked from within
    "uplevel $body"
    invoked from within
    "ForeachMfsFileTrans fsid name type $path $prefix 15 {
    set rec [db $db openid $fsid]
    set manual 0
    set suggestion 0
    if {$::version >= 3}..."
    (procedure "action_todo" line 121)
    invoked from within
    "action_todo $chan 7 $env"
    (procedure "::action_ui" line 28)
    invoked from within
    "::action_$action $chan $part $env"
    ("eval" body line 1)
    invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--
     
  6. Sep 8, 2006 #1666 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Me too. I'll have lgkahn take a look. If you don't care about manipulating folders in the NPL, you can use the original ui.itcl in the stock 1.3.0 distribution of TWP.
     
  7. Sep 8, 2006 #1667 of 2880
    SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    +1
    I have tried rebooting the box, no go. I have tried a Restart->Quit (from TWP), then the twp command from bash, no go there either.
    Here are some telnet session captures:
    Code:
    Fam Rm-TiVo# Warning: An http server is already running
    /tivowebplus/tivoweb: /tivowebplus/.dist/BlockFailure: Read-only file system
    TivoWebPlus - vFam Rm (1.3.0 (oztivo-060821))
    The program comes with ABSOLUTELY NO WARRANTY.
    This program is licensed under the GPL.
    See the 'docs/copyright' and 'docs/index.html' files
    for copyright and credit information.
    PoolSize=3244032
    couldn't open socket: address already in use
        while executing
    "socket -server ::session $http_port"
        (file "/tivowebplus/httpd-tt.tcl" line 919)
    Code:
    Fam Rm-TiVo# cd /tivowebplus/modules
    Fam Rm-TiVo# rw
    mounting read write
    Fam Rm-TiVo# twp
    starting Tivowebplus
    Fam Rm-TiVo# TivoWebPlus - vFam Rm (1.3.0 (oztivo-060821))
    The program comes with ABSOLUTELY NO WARRANTY.
    This program is licensed under the GPL.
    See the 'docs/copyright' and 'docs/index.html' files
    for copyright and credit information.
    PoolSize=3244032
    Loading modules...
    ChannelMap
    backup
    channelgrid
    channelprefs
    confresManual
    debug
    extract
    favicon
    gallery
    gdchecker
    hackman
    --hackman Version 4.2.1--
    -No problem running mips find -- mips version of find selected.
    -No problem running mips sendkey -- mips sendkey selected.
    -Root directory mounted read-write
    -Friday, September 08, 2006, 08:35 AM, local time
    higuide
    index
    -initializing logo index
    -initializing channel table
    --caching 816 channels for source of type=6 (DirecTV)
    -initializing genre table
    -initializing now showing cache
    -initializing season pass cache
    info
    lj_utils
    logos
    logs
    mail
    manrec
    merge
    mfsbrowser
    mrv
    netconfig
    phone
    resources
    Loaded 0 resource definitions
    rss
    sched
    screen
    search
    sysadmin
    theme
    ui
    update
    webremote
    whatson
    wishlists
    xlist
    xplusz
    {more}
    Accepting Connections
    EDIT: Russ answered while I was typing this.
     
  8. Sep 8, 2006 #1668 of 2880
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,165
    321
    Oct 29, 2000
    How exactly do you go about manipulating folders in the NPL with the new ui.itcl module, anyway? By Editing a show and using that new "Grouping" field? (That's the only thing that seemed to make sense.) I ask because I tried, and it looked like it renamed the recording, too.
     
  9. Sep 8, 2006 #1669 of 2880
    SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Look up^. :D See posts 1652 and 1658. I haven't had any luck with this function. I now have 2 shows in a different folder and can't get them out or into their own folder.
     
  10. Sep 8, 2006 #1670 of 2880
    msommer

    msommer Card's Fan

    86
    0
    Apr 4, 2005
    Had the same problem with the groups. I finally got it to work by doing the following:

    Pick a show and create a folder name, then you select that same show from the drop down list. When you are done you will have a show in the NPL that displays the name of the newly created group. Next, select another show you want to put in your newly created group, and in the drop down box, select the first show that was previously renamed to your group. After this you should have two shows in the new folder. NOW you have to select each show in the new group and rename the title.

    There are instructions that say to pick a show that already resides in a group, and add your show to it. When you do this, the title changes in the NPL and in the now showing list in TWP. Then just rename the shows.

    Sound confusing???? It is, but after about an hour I got the hang of it. You just have to accept the fact that you will be going in and renaming shows in the now showing list in TWP.
     
  11. Sep 8, 2006 #1671 of 2880
    chris22

    chris22 Snowboard Dude

    174
    0
    Aug 31, 2006
    What does Tweak do for TivoServer? (not desktop).

    I cant seem to make it transfer anything but .ty from this tivo on1y.
    -Chris
     
  12. Sep 8, 2006 #1672 of 2880
    SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Hey Russ,
    I'm getting almost the same issue with UserInterface->Scheduled Suggestions:
    Code:
    INTERNAL SERVER ERROR
    --cut here--
    action_ui '/pending' ''
    invalid command name "desc_show"
        while executing
    "desc_show $hovertext"
        ("uplevel" body line 139)
        invoked from within
    "uplevel $body"
        invoked from within
    "ForeachMfsFileTrans fsid name type $path $prefix 15 {
        set rec [db $db openid $fsid]
        set manual 0
        set suggestion 0
        if {$::version >= 3}..."
        (procedure "action_todo" line 121)
        invoked from within
    "action_todo $chan 2 $env"
        (procedure "::action_ui" line 39)
        invoked from within
    "::action_$action $chan $part $env"
        ("eval" body line 1)
        invoked from within
    "eval {::action_$action $chan $part $env}"
    --cut here--
    It's probably obvious that these issues would be related to the gurus but I thought I would pass the info along anyway.
     
  13. Sep 8, 2006 #1673 of 2880
    SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Answered here. (Double post.)
     
  14. Sep 8, 2006 #1674 of 2880
    chris22

    chris22 Snowboard Dude

    174
    0
    Aug 31, 2006
    I was wondering where I posted :p, I 1ost my o1d post.
     
  15. Sep 9, 2006 #1675 of 2880
    Skippy

    Skippy New Member

    13
    0
    Mar 1, 2002
    Walnut...
    Several weeks back, I had to restore a disk image and do the Zipper/Script process due to a failed harddrive. After that, I installed BufferHack 4.1, mfs_ftp and hackman. Things were great for several weeks and then I lost telnet and ftp access. I'm not sure why.

    I recovered by removing the drive and rezippering/rescripting. This time, I've disabled hackman. Was hackman the culprit?

    I'd really like to get hackman configured "correctly" if this was the cause of my problem.

    Any suggestions?

    Thanks!

    -- Skip
     
  16. Sep 9, 2006 #1676 of 2880
    PortlandPaw

    PortlandPaw Woodstock-era Hacker

    1,057
    0
    Jan 11, 2004
    Chebeague...
    hackman was the culprit only if you ignored all the warnings and used it to set up your rc.sysinit.author file without preserving your original settings. hackman completely re-writes this file from scratch, and if you aren't careful, it will wipe out critical startup commands. The readme includes details on how to avoid this as well as how to set up your TiVo to minimize chances of blowouts due to TiVo clearing the /var directory, updates, etc.
     
  17. Sep 9, 2006 #1677 of 2880
    Skippy

    Skippy New Member

    13
    0
    Mar 1, 2002
    Walnut...
    So now on to my 2nd DTivo...

    Again, this unit was zippered/tweaked and all was well. Then I lost telnet and ftp (probably due to a hackman config error). This AM, I pulled the drive, rezippered it and replaced it. Upon first boot, I uninstalled the tweaks so I could reinstall the latest tweaks. When I tried to get a directory listing (ls), it gave me the help screen for something called UnZip 5.50 by Info-ZIP. Not sure what happened here. How do I recover ls?

    My current path is: ./:.:/utils:/bin:/sbin:/tvbin:/tivobin:/busybox

    If I try to run the tweaks, it fails with:
    LR-TiVo# sh tweak.sh
    Downloading latest Enhancement script...
    UnZip 5.50 of 17 February 2002, by Info-ZIP. Maintained by C. Spieler. Send
    bug reports to the authors at Zip-Bugs@lists.wku.edu; see README for details.

    Usage: unzip [-Z] [-opts[modifiers]] file[.zip]

    • [-x xlist] [-d exdir]
      Default action is to extract files in list, except those in xlist, to exdir;
      file[.zip] may be a wildcard. -Z => ZipInfo mode ("unzip -Z" for usage).

      -p extract files to pipe, no messages -l list files (short format)
      -f freshen existing files, create none -t test compressed archive data
      -u update files, create if necessary -z display archive comment
      -x exclude files that follow (in xlist) -d extract files into exdir

      modifiers: -q quiet mode (-qq => quieter)
      -n never overwrite existing files -a auto-convert any text files
      -o overwrite files WITHOUT prompting -aa treat ALL files as text
      -j junk paths (do not make directories) -v be verbose/print version info
      -C match filenames case-insensitively -L make (some) names lowercase
      -X restore UID/GID info -V retain VMS version numbers
      -M pipe through "more" pager
      Examples (see unzip.txt for more info):
      unzip data1 -x joe => extract all files except joe from zipfile data1.zip
      unzip -p foo | more => send contents of foo.zip via pipe into program more
      unzip -fo foo ReadMe => quietly replace existing ReadMe if archive file newer
      Download failed. Adjust DNS and try again? [y/n]: n
      Make sure your Tivo is connected to the internet, and
      your network settings are correct. Exiting...
      rm: /enhancements: No such file or directory
      LR-TiVo#

      Ugh! Any assistance here is greatly appreciated!

      -- Skip
     
  18. Sep 9, 2006 #1678 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    • You might want to just start over at this point. I'd hold off on using Hackman until you research it a little more.
     
  19. Sep 9, 2006 #1679 of 2880
    Skippy

    Skippy New Member

    13
    0
    Mar 1, 2002
    Walnut...
    "start over"...I hope that means simply rezippering. I'd hate to have to wipe all my recordings...
     
  20. Sep 9, 2006 #1680 of 2880
    Skippy

    Skippy New Member

    13
    0
    Mar 1, 2002
    Walnut...
    ...btw I did disable hackman at this point...
     

Share This Page