1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I have no idea on this one, sorry.
     
  2. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    tytool expects to find tserver in /var/hack (unless you changed it to look for it somewhere else). Is that where it is?
     
  3. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    This is a hackman issue. What software are you running? Check for the existence of the file called /dev/router_client. Looks like this is the issue, but only seen it manifested on the HR10-250.
     
  4. cgee

    cgee TiVo Fumbler

    25
    0
    Jul 3, 2002

    I have a HR10-250 running 3.1.5f. I will check out the things you mentioned asap. Perhaps I should just remove Hackman - I really don't need it.
     
  5. pendragn

    pendragn Active Member

    12,088
    7
    Jan 21, 2001
    Ames Iowa
    Check the prompt in TyTool. By default it looks for $ whereas the zipper makes the prompt #. If TyTool doesn't get the prompt it expects, it fails. Also, have you tried firing tserver up manually via telnet and then trying to attach with TyTool?

    tk
     
  6. frickn

    frickn New Member

    6
    0
    Mar 3, 2006
    Thanks for the response guys. I think Pendragon has the solution. I am going to fire off tserver manually tonight and see if I get a response out of it. I haven't moved tserver from it's orginal location, which was /var/hack/ and verified that the file was still there via ftp. Also verified that my tools were set to look for the server in that location.

    Thanks

    Frickn
     
  7. qubit

    qubit New Member

    86
    0
    Jul 15, 2002
    South East US
    I went to run this with
    sh tweak.sh
    and it ran for a bit and prompted to check my telnet? Then it said my telnet was inserting CF's where it shouldn't so the script wouldn't run correctly. I then exited and connected with securecrt instead of windows telent and reran the script. Now it tries to get the latest from a website before running which I don't think it did at first. Does it have to do this? I have it crossover'd up to my laptop cause I don't have it in the location where it will be when I set the valid network settings with the router IP and all from the Zipper script.
    I tried running the uninstall but it still seems like it wants/needs net access?

    Edit: Better yet. Basically during zipper i set the network to the network it WILL be on. But I want to run tweak.sh now on the network I'm on now that would mean the tivo would need a different IP and different router address. Is there a manual process I can take to edit the network settings myself?
     
  8. Carlton Bale

    Carlton Bale New Member

    168
    0
    Dec 17, 2001
    Indianapolis...
    Very well done script! Saved me quite a bit of time modifying my HR10-250; wish it were available for a Series 1 DTivo as well!

    I do have a couple of suggestions for the next version:

    Code:
    Do you want to run the "express" version (for advanced users)? [y/n]:
    I'm not sure what this means because it seems contradictory; express sounds like it is for basic users, so they should answer Y? So express mode is not for advanced users? I'm guess here, but maybe it should state "Do you want to run the "express" version (advanced users select no)? [y/n]:"

    Code:
    Do you want to install netperf network performance tool? [y/n] :y
    Netperf will measure MRV speed between this tivo and another "target" tivo.
    These lines should be switched around, so you know what Netperf is before you answer Y/N. I answered Y and then realized that I couldn't use it.

    Thanks again!
     
  9. bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002

    Express as in quick or nonverbose. The Express version has less prompting than the other route. So, if you have run the script several times in the past, you should answer 'Y', otherwise 'N'
     
  10. SohoTrader

    SohoTrader New Member

    6
    0
    Jan 19, 2006
    This is good stuff people. I ran tweak.sh and it worked like a charm on one my tivo sa boxes. So, I made boooo where I deleted some tweak generated directory and I try to run tweak.sh and it doesn't allow you to run it until tweak-uninstall.sh file. I looked for the uninstall file the whole day and I can't find. Can someone give me a hand here...
     
  11. Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    First, it's tweak_uninstall.sh (underscore not a hyphen) so that may help you find it. It is installed on your TiVo so do this to find it:

    ffind tweak_uninstall.sh
     
  12. goony

    goony New Member

    1,749
    0
    Nov 19, 2003
    No need for that; do this next time:
    Code:
    #prompt> [color=blue]find / -name 'tweak*'[/color]
    This will reveal any files that start with tweak.
     
  13. SohoTrader

    SohoTrader New Member

    6
    0
    Jan 19, 2006
    I assuming that when run tweak.sh script it out uninstall tweak script in somewhere on tivo (probably in enhancement directory). Well, I ran on my tivo but file not found. I mostly deleted the file. Is there any other route I can take. Unless someone can send me the unistall script...
     
  14. Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    I hope this works and I hope it doesn't upset anyone. Here's the uninstall file zipped.
     

    Attached Files:

  15. SohoTrader

    SohoTrader New Member

    6
    0
    Jan 19, 2006
    Thanks bro no luck but I'm going to start from fresh. I'm going to restore from my original drive TIVO to my big drive and rom there I can take on tweak.sh again.. I really love the tweak... I salute the the author of tweak.... JUST Brilliant...
     
  16. rpl

    rpl New Member

    9
    0
    Apr 29, 2003
    LA
    The title of that file is All in one S2. So as rbautch has said a couple of times your using the wrong version.
     
  17. bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002

    That's probably not a good idea since the uninstall file has gone thru several iterations and may not be the same version as the tweak file he used in the first place. Rbautch are they all backward compatible?
     
  18. SohoTrader

    SohoTrader New Member

    6
    0
    Jan 19, 2006
    OK, thanks for the info.... Are you from Bangladesh?

     
  19. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Indeed they are backward compatible.
     
  20. willardcpa

    willardcpa QUASI-OMNISCIENT

    2,686
    0
    Feb 23, 2001
    Eugene, OR USA
    Hmmmm, how would somebody think that from a name of "bengalfreak"??? :rolleyes:
    The spelling is only remotely similar? :cool:
    Oh, I get it, SohoTrader is from Nigeria! :p :D
     

Share This Page