1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Mar 5, 2006 #1341 of 2880
    bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002
    so, hackman is no longer included at all in the script archive?
     
  2. Mar 5, 2006 #1342 of 2880
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    nope it was too easy for newbies to wreak total havoc on their tivos.
    Hackman is a GREAT tool, but installing it by default with the Zipper or this enhance script was a mistake.
     
  3. Mar 5, 2006 #1343 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    To clarify, it's still included in the enhancement script but not the Zipper. The enhacement script looks to see if you just ran the Zipper, and if so, deletes hackman. Experienced users can simply uninstall and reinstall the enhancement script to get hackman back. Inexperienced users can do the same if they want to upset me. ;)
     
  4. Mar 5, 2006 #1344 of 2880
    ktbst

    ktbst New Member

    1
    0
    Feb 28, 2006
    I hope someone can help me out...I have tried to search the forums for an answer but no luck. I upgraded my samsumg 4040 using a new 200gb WD drive and instantcake. After a few weeks I used the enhancement script. Everything works fine except the system periodically freezes but never while watching tv. It seems to freeze in the middle of the night. The system will be totally unresponsive including the remote. I have to pull the plug to reboot. Should I check the logs for errors..If so which ones? I read an earlier post and you recommended shutting processes one at a time. By processes do you mean the hacks I have running? I know this may be an indicater that the drive is bad...if so in which log would I see any disk errors? The problem started after I used the enhancements script so my first thought is that it is not the drive. Any help would be greatly appreciated.
     
  5. Mar 6, 2006 #1345 of 2880
    alert5

    alert5 New Member

    133
    0
    Nov 16, 2003
    Can you use telnet from a box running linux so as to avoid the crlf issues of XP?

    From a Linux environment I would think ftp and file editing with something as simple as 'kwrite' might be less dangerous than from XP as well.

    Would file permissions be maintained or would you suggest chmod 777 on a file like the author, just to be safe from hosing your port 21 and 23 connectivity.

    Any thoughts from other dual booters out there with more than my novice linux capability is appreciated.
     
  6. Mar 6, 2006 #1346 of 2880
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    I accessed my Tivo's under linux all the time and you're correct. kwrite or whatever the gnome equivalent is work fine.
     
  7. Mar 6, 2006 #1347 of 2880
    bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002

    I use teraterm pro under XP and have no cr-lf issue. Its free.
     
  8. Mar 6, 2006 #1348 of 2880
    alert5

    alert5 New Member

    133
    0
    Nov 16, 2003
    Thanks for the comments. The bigger issue that tends to bite the novice (me) is not crlf, but forgetting to reset file permissions or something else equally stupid. I don't want to do that again.

    Oh yes, and would the linux environment avoid the necessity for dos2unix on stuff you ftp.

    I don't know, but as a test I'm about to update both rbautch.tgz and tweak.sh on one of my zippered machines. I'll also edit the author file while I'm at it just to get used to using linux telnet, ftp and an editor in that environment.

    I'm using a fully installed Mandriva 2006 (3 CDs) as the OS.

    Learn by doing and learn from one's mistakes is my attitude.
     
  9. Mar 6, 2006 #1349 of 2880
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    yes it would linux and tivo get along beautifully.
     
  10. Mar 7, 2006 #1350 of 2880
    alert5

    alert5 New Member

    133
    0
    Nov 16, 2003
    I'm sold. Just updated the box I mentioned from linux. 'Gftp' and 'Gtelnet' were a pleasure to use as opposed to XP telnet and Filezilla.
     
  11. Mar 8, 2006 #1351 of 2880
    klaroby

    klaroby New Member

    28
    0
    Sep 3, 2005
    My var file seems to have been wiped. I can still Telnet to the tivo but cannot access via FTP or TWP. Any idea if this can be fixed without pulling the hard drive?

    This is an HR10-250 that was hacked using the hacking guide from the yahoo group before the zipper was available. I have subsequently used several versions of the enhancement script on this unit. Never had the FTP access go down before.

    I also have a standard definition TiVo that had the var file wiped but I was still able to FTP to it, so I just reinstalled the enhancement script and all is well with that unit.
     
  12. Mar 8, 2006 #1352 of 2880
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    start ftp via bash with the command tivoftpd
    as for twp you will have to re-install it if it is no longer in /var.
    a var wipe wouldn't kill tivoftpd by the way, unless you put that file in /var in the 1st place.
     
  13. Mar 8, 2006 #1353 of 2880
    klaroby

    klaroby New Member

    28
    0
    Sep 3, 2005
    Thanks Gunnyman. I will try that. I do not remember where I put tivoftpd. I followed the HDTiVo hacking guide. Could be that it was in var. See my previous post. I added some updated info about the same time that you replied.
     
  14. Mar 8, 2006 #1354 of 2880
    klaroby

    klaroby New Member

    28
    0
    Sep 3, 2005
    Thanks, Gunnyman. That worked. FTP is now working. I will now be able to reinstall the enhancement script. I am an electrical engineer (hardware) but am a novice at linux. Just experienced enough with the TiVo hacking to be a little dangerous.
     
  15. Mar 8, 2006 #1355 of 2880
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    installing the new enhance script is a great idea.
    Also look at your rc.sysinit.author file and make sure the lines starting twp and tivoftpd are still there.
     
  16. Mar 9, 2006 #1356 of 2880
    kschauwe

    kschauwe Member

    505
    0
    Sep 16, 2003
    Bowling...
    How do you turn off "Tivo Colors" Bash Prompt? I can't get tserver to work from Tytools. It's looking for a "proper" prompt string and I think the colors are thowing it off.
     
  17. Mar 9, 2006 #1357 of 2880
    pendragn

    pendragn Active Member

    12,088
    7
    Jan 21, 2001
    Ames Iowa
    Colors aren't throwing it off. The prompt changed. I know I used to have TyTool key off of $. After you Zipper your box, the prompt is changed to #. Verify that you have TyTool looking for the right one. I'm using TyTool with three hacked DTiVos all using colored prompts and all working perfectly.

    tk
     
  18. Mar 9, 2006 #1358 of 2880
    kschauwe

    kschauwe Member

    505
    0
    Sep 16, 2003
    Bowling...
    That did it!
    Thanks!
     
  19. captainjrl

    captainjrl New Member

    22
    0
    Aug 31, 2004
    Where can I go to change the settings for when fakecall runs? Is it in the rc.sysint.author file?

    Thanks
     
  20. Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    It's in the crontab file named 'root'.

    /var/spool/cron/crontabs/root
     

Share This Page