1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Feb 1, 2006 #1201 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Yes, you'll be able to watch them as long as you don't run 51killer.
     
  2. Feb 1, 2006 #1202 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    Which since you are zippering an image for the same unit, you should not get the Error 51 anyway.
     
  3. Feb 1, 2006 #1203 of 2880
    Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    I like the changes that you've made to the Enhancements script and want to reinstall them on my unit. Can I just run uninstall and then immediately re-install and not lose USB 2.0, wireless, etc?
     
  4. Feb 1, 2006 #1204 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The uninstall script will remove usb2.0 drivers, so just make sure you reinstall them with the new script. Wireless settings will remain unchanged.
     
  5. Feb 1, 2006 #1205 of 2880
    Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    Thanks, rbautch! Uninstall/reinstall worked perfectly. :up: To bring Hackman back to life I did this:

    mv /tivowebplus/modules/hackman.cfg.draft /tivowebplus/modules/hackman.cfg

    And then restarted TWP. That should do it, right?

    Jim
     
  6. Feb 1, 2006 #1206 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    Doesn't the hackman.cfg file get created when you open hackman in TiVoWeb? I thought the workaround to get stuff added to the cfg, was to delete it and do twprs and go back into hackman so it would recreate the file.
     
  7. Feb 1, 2006 #1207 of 2880
    astartz

    astartz New Member

    9
    0
    Oct 16, 2003
    I have 4 direct TV tivos, if I install the tivo web plus can I watch a program from teh living room tvio in the bedroom and what not?
     
  8. Feb 1, 2006 #1208 of 2880
    starbiker99

    starbiker99 1 Tivo 2 Tivo 3 Tivo

    86
    0
    Feb 4, 2005
    Parker, CO
    That is an MRV feature not a Tivowebplus feature. You would need to Zipper all Tivo and connect them to your home network. Then you could MRV between all Tivos. :)
     
  9. Feb 1, 2006 #1209 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    No. If you uninstalled and reinstalled, it should be there automatically.
     
  10. Feb 2, 2006 #1210 of 2880
    Tivogre

    Tivogre Active Member

    1,389
    8
    Jul 12, 2002
    Springfield, VA
    First the good news... my HR10-250 upgrade with the ZIPPER is complete!

    I am able to watch all shows (previously recorded AND post-ZIPPER recorded).

    The better news: ALL Extra curricular activities work PERFECTLY.... I had NO IDEA that the tools would work out of the box on SD and HD material!!! I can now watch HD Stuff on my PC.... but MAN is that a LOT of data transfer!

    I was even able to transfer a (SD) show from HR10-250 to PC and (via tivoserver) watch it on another ZIPPERED SD Tivo. It's not QUITE MRV on the 10-250... but it's not far off! AMAZING!

    The bad news:

    There was a problem during the ZIPPERING - specifically during the running of the enhancement script. Near the end of the process, I selected back-up season passes now. The process hung. I waited a god 1/2 hour; no dice. I aborted the script.

    By looking at /enhancements/start.sh, I was able to see what steps remained and MANUALLY EXECUTE them from bash. I also had to add a few of the last profile and author entries to the files.

    After reboot, everything is great.

    Again, you guys ROCK!
     
  11. Feb 2, 2006 #1211 of 2880
    tbeckner

    tbeckner TiVo Fan

    1,352
    0
    Oct 26, 2001
    Bend, OR, USA
    Thanks so very much, for some reason I couldn't find this page again.
     
  12. Feb 2, 2006 #1212 of 2880
    Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    Hmmm, I don't know, when I first started up TWP after the reinstall, Hackman didn't show up in the TWP menu. All the hackman files were in /tivowebplus/modules, including the hackman.cfg.draft file. That file name seemed odd to me (and I had this nagging doubt about hackman getting installed after your post of a few days ago). So I renamed that file to hackman.cfg, restarted TWP and hackman was there. Weird. Maybe I missed something. So I should have just ignored hackman.cfg.draft?

    I guess it doesn't really matter. Hackman is working. Thanks! :)

    I think I'll just re-run the whole process and see if I can repeat it.

    Jim
     
  13. Feb 2, 2006 #1213 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    You seem to like being a guinea pig.
     
  14. Feb 2, 2006 #1214 of 2880
    Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    I learn better this way. :eek:
     
  15. Feb 2, 2006 #1215 of 2880
    Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    Rbautch, I re-did the uninstall/reinstall process and both scripts executed flawlessly except for one error. Uninstall no longer uninstalls TWP because the new install has moved it:

    Deleting Tivowebplus Installation...
    rm: /var/hack/tivowebplus: No such file or directory​

    This is good I suppose if you have no reason to uninstall TWP, but maybe uninstall should look for TWP in both places and/or this should be a choice for the user. Regardless, since I wanted a fresh install of TWP I manually removed the TWP directory.

    After rebooting, Hackman does not show up in TWP the first time it is run and this file is in /tivowebplus/modules:

    -rw-r--r-- 1 root root 6339 Feb 2 15:18 hackman.cfg.draft

    After manually stopping and restarting TWP, hackman is there with this file in /tivowebplus/modules:

    -rw-r--r-- 1 root root 6339 Feb 2 15:34 hackman.cfg

    Guinea pig reporting in...

    Jim
     
  16. Feb 2, 2006 #1216 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell

    From post 1206:


    :D
     
  17. Feb 2, 2006 #1217 of 2880
    Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    I just looked at /.profile and it has the alias listings and other things appended twice. I think somehow I lost the original. What does a virgin /.profile look like before the Enhancement script runs and what does it look like afterwards?
     
  18. Feb 2, 2006 #1218 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    Isn't there a question when running the enhancement script multiple times about whther you want to append the .profile aliases?
     
  19. Feb 2, 2006 #1219 of 2880
    Finnstang

    Finnstang King of the North

    8,666
    0
    Sep 11, 2003
    Winterfell
    Here is my .profile contents: (I added the alias for ll)
    Code:
    export TIVO_ROOT=
    export TIVO_REMOTE=TIVO
    export MFS_DEVICE=/dev/hda10
    TERM=xterm 
    alias rw='echo "mounting read write"; mount -o remount,rw /'
    alias ro='echo "mounting read only"; mount -o remount,ro /'
    alias twp='echo "starting Tivowebplus"; /enhancements/TWPrunc.sh'
    alias ffind='find / -name'
    alias author='vi /etc/rc.d/rc.sysinit.author'
    alias root='vi /var/spool/cron/crontabs/root'
    alias twprs='echo "restarting Tivowebplus"; sh /enhancements/TWPrestart.sh'
    alias ll='ls -l'
    #########################################
    TERM=xterm
    
    #########################################
    TERM=xterm
    
    #########################################
    export PS1="\[\e[33;1m\]LivingRm\[\e[36;1m\]-\[\e[31;1m\]T\[\e[32;1m\]i\[\e[33;1m\]V\[\e[34;1m\]o\[\e[0m\]# \[\e[0m\]"
    alias speed="/busybox/netperf -H 192.168.11.10 -C -c -- -S 65536 -s 65536"
    
     
  20. Feb 2, 2006 #1220 of 2880
    Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    Yes, there is, but the uninstall script also restores the profile back to its original state. So if you do an uninstall/reinstall I think you have to answer yes to that question. My problem is that somehow profile.bak is no longer my original file so when uninstall restored it, it already contained the alias definitions.

    jkTiVo-TiVo# sh /hacks/tweak_uninstall.sh
    Removing directories and files...
    Deleting Tivowebplus Installation...
    rm: /var/hack/tivowebplus: No such file or directory
    Deleting cron Installation...
    Skipping CallerID uninstall...
    Restoring original fakecall...
    Restoring original usb drivers...
    Restoring original profile...
    Restoring original rc.sysinit.author file
    Restoring original splash screen...
    Done!

    Finnstang, any chance you could do a copy/paste for me to show me what an original /.profile looks like? Would appreciate it.

    Thanks!
    Jim
     

Share This Page