1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. blhirsch

    blhirsch Tivo-riffic!

    290
    0
    Mar 1, 2003
    Aggg. I put the ip address of the tivo itself in the field asking for the default gateway. I uninstalled tweak.sh and then reinstalled and it never asked me again and it reports "default gateway" as the ip address I put in (wrong.)

    How do I change it now?
     
  2. dfriedland

    dfriedland New Member

    36
    0
    Apr 6, 2002

    Sorry, I was just bumping to keep this thread up near the top.

    It's helped me immensly!

    Jersey Dave
     
  3. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    No, it will work fine.
     
  4. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Navigate to /enhancements, and run: sh net-launch.sh
     
  5. tbeckner

    tbeckner TiVo Fan

    1,352
    0
    Oct 26, 2001
    Bend, OR, USA
    Any word on "Superpatch67Standby.tcl"?
     
  6. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I'm afraid that's fallen to the back burner while I devote all my spare time to tivoserver and ripping my entire DVD collection. :)
     
  7. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    If you haven't tried to install it, it's very quick and easy. Just ftp the files, run it and reboot. :up:
     
  8. Billy66

    Billy66 Again with shoelaces

    3,273
    0
    Dec 15, 2003
    Hey rbautch,

    I've installed the most recent script and I'm having trouble with this.

    I had to turn them on in Hackman and when I did, I can see them initiate when the unit reboots. The problem is that it is happening too early. The unit seems to be still acquiring sat so the first one fails (I think it's SORT) the second one (30 sec) sometimes works.

    Is there a place where I can add a sleep command or something to prevent this? I have an HR10-250 running 3.15e

    Thanks
     
  9. lee espinoza

    lee espinoza some guy

    2,442
    0
    Aug 21, 2002
    San Antonio,TX
    I have installed it and it works great!!!
    TIVO HACK-bash# cd /busybox
    TIVO HACK-bash#
    TIVO HACK-bash# Superpatch67Standby.tcl
    Applying Superpatch67Standby Mod...
    DIRECTV Central: Adding Standby
    Searching for ui/TivoCentral/TivoCentralDocument.brf IndexPath...
    Messages & Setup: Removing Standby
    Searching for common/ui/Menus/SetupMainMenu/SetupMainMenuDocument.brf IndexPat
    h...
    Programs to Record: Removing Search by Title (Demo)
    Searching for ui/PickPrograms/PickProgramsDocument.brf IndexPath...
    Done!
    TIVO HACK-bash#reboot
     

    Attached Files:

  10. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The script makes permanent patches to your tivoapp, so you should not have to turn anything on with hackman, or wait for anything to come up after the unit boots.
     
  11. Billy66

    Billy66 Again with shoelaces

    3,273
    0
    Dec 15, 2003
    Hmm, that I thought, pointed me in the right direction because I had enabled them previously via Hackman. So what I did was uninstall the script, download the newest one from the first post. Deleted the copy of the .tgz file from the previous install and reinstalled the script. Still no Sort or 30 sec on startup. Any idea what I'm doing incorrectly?

    The script identified it correctly as HR10-250 Software 3.1.5e. It also proclaimed it Phoenix.
     
  12. ebetzler

    ebetzler New Member

    23
    0
    Dec 5, 2005
    I'm confused, does the enhancement script install superpatch?
    If it does, how can I verify that it was done successfully?
    (I have reason to believe it didn't)
    FYI, I used the zipper for doing my upgrades.
     
  13. yazyazoo

    yazyazoo New Member

    51
    0
    Jan 8, 2006
    I just installed the Zipper with a Netgear FA120. I just bought some Airlink ASOHOUSB from Fry's and when I install it, it doesn't light up or seem to work. Does the Zipper already have USB 2.0 and the drivers for the Airlink already. From the begininnig of the thread it seems so. Do I have to activate something. My wireless speed for transferring is only .3 Mbps which is slow. Do I have to do something to activate USB 2.0?
     
  14. Billy66

    Billy66 Again with shoelaces

    3,273
    0
    Dec 15, 2003
    Well, I never could get it to go through the script, but I was able to just patch tivoapp myself after doing some more research. I'm all set , but maybe there's an issue with 3.1.5e. Maybe not, I don't know.

    Thanks for all your work rbautch.
     
  15. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The enhancement script only installs superpatch if it is running for the first time after a Zipper install. If you didn't just run the Zipper, the script assumes you hacked your tivo some other way, and will not run superpatch.
     
  16. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The script only runs the patches if you are running for the first time after a Zipper install. You can also get it to run by creating a dummy file in root called zipper_flag.
     
  17. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The Zipper doesn't install the drivers, but the enhancement script does. Others have gotten the ASOHOUSB to work with these drivers. You'll need to run the enhancement script with your FA120 attached, select the usb2.0 driver install, and then swap out the FA120 for the Airlink.
     
  18. Billy66

    Billy66 Again with shoelaces

    3,273
    0
    Dec 15, 2003
    Ahhh, that explains it. I'm all set now. I was mostly hacked pre-zipper so I didn't use it. Thanks!
     
  19. mskreis

    mskreis New Member

    52
    0
    May 9, 2004
    I zippered my HR10-250 and noted several problems. So I ran tweak_uninstall.sh and reran tweak.sh. This gave me the following:



    HD-TiVo# dos2unix tweak.sh
    HD-TiVo# sh tweak.sh
    mv: //rbautch_files.tgz: No such file or directory
    chmod: /enhancements/rbautch_files.tgz: No such file or directory

    Running rbautch Hacked Tivo Enhancements...
    tar: /enhancements/rbautch_files.tgz: No such file or directory
    Do you want to run the "express" version (for advanced users)? [y/n]: n
    tweak.sh: /enhancements/start.sh: No such file or directory
    Do you want to continue? [y/n]: y

    I need some help please.
     
  20. tbeckner

    tbeckner TiVo Fan

    1,352
    0
    Oct 26, 2001
    Bend, OR, USA
    I have searched this forum and threads, but I thought I had seen it before, but I cannot find the model numbers that can be zippered.

    I just added a new SD-DVR80 to my three HDVR2s and the HDVR2s are hacked, but this SD-DVR80 say RID on the box and on the information screen. Does that mean it cannot be hacked? I thought that all SD-DVR80s could be hacked?
     

Share This Page