1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Breaking News - The sale is back... "Our “once in a lifetime” PLS promotion was such a hit, that we’ve decided to launch it again! The PLS Transfer Sale will be available again for the last 3 days of the month. This will include the BOLT+ 3TB, and 4 refurb units (BOLT 500GB, BOLT 1T, Roamio Pro and the TiVo Mini)." https://www.tivo.com/secondchancelifetimesale#/secondchancelifetimesale

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Dec 5, 2005 #921 of 2880
    shortkud

    shortkud New Member

    24
    0
    Dec 5, 2005
    Im hoping someone can help me. i already have tivowebplus on my tivo location in /cdrom/ I basically want the tweak script for the modified version of tivowebplus. I run it but it says "detected enhancements directory, please run uninstaller." First things first what do i do lol...Im sorta new so bit sorry.

    Also how can that one tweak.sh script install so many things.

    :edit:
    From what i know it has DvrPalooza Hacked Tivo Enhancements installed on it but yet to find out any info on that from google.
     
  2. Dec 6, 2005 #922 of 2880
    crunchpvr

    crunchpvr New Member

    5
    0
    Oct 10, 2005
    Here is what I have in both my resolv.conf and my /etc/hosts:

    bash-2.02# more /etc/hosts
    127.0.0.1 localhost.localdomain localhost
    69.90.236.30 www.mastersav.com

    bash-2.02# more /etc/resolv.conf
    search localdomain
    nameserver 10.0.0.1


    The reason I put the 10.0.0.1 for my nameserver is to intentionally break DNS - it seems to speed up menus and finding my pics and music.

    Sorry for the multiple posts I could not post this last bit without having 5 posts under my belt. Due to URL's and IP's - even though I replaced the dots with dashes - go figure.

    Finally, GREAT JOB on this script! It keeps getting better and better. And thanks for moving the stuff out of /var, I was having to reload everything every couple weeks.
     
  3. Dec 6, 2005 #923 of 2880
    crunchpvr

    crunchpvr New Member

    5
    0
    Oct 10, 2005
    Also I found that the ^M (Control-M) problem is still in the /var/hack/tivowebplus/modules/index.itcl file (really in /hacks/tivowebplus...etc). Starts at line 697 in that file. I removed it using vi, but I guss I could have run dos2unix on it too.
     
  4. Dec 6, 2005 #924 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Go ahead and run the uninstall script. It should be in the same directory as tweak.sh. Run it with "sh tweak-uninstall.sh". The tweak.sh script can install so many hacks because it's not the actual script. It downloads the main script and all the hacks, and then launches the main script, which is called start.sh. You can find it in your /enhancements directory.
     
  5. Dec 6, 2005 #925 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Thanks. I'll fix that.
     
  6. Dec 6, 2005 #926 of 2880
    shortkud

    shortkud New Member

    24
    0
    Dec 5, 2005
    I went ahead and ran the unisntall script and then the install script now all is well except for some things.TWP still doesnt show hackman or the new icons...i checked TWPrun and its pointing to the new installation directory fine. Unless something else is telling the tivo to use the old installation
    :edit: Seems the colors are affecting tytools. Maybe just word of advice for others. Ill be quiet now about tytools
     
  7. Dec 6, 2005 #927 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Sounds like you're still runing your old TWP installation. Is there still a TWP startup command in the author file that points to a different TWP installation? Are any of the other TWP modules present, like manual record or batch record?
     
  8. Dec 6, 2005 #928 of 2880
    shortkud

    shortkud New Member

    24
    0
    Dec 5, 2005
    In the twprun it points to the new one. Thats all i know...sorry im not much of more help. Can u be a bit more specific on where i need to look.
     
  9. Dec 6, 2005 #929 of 2880
    Runch Machine

    Runch Machine New Member

    1,048
    0
    Feb 7, 2002
    Minneapolis
    Any word on getting beta6 out for the HR10-250?
     
  10. Dec 6, 2005 #930 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Beta5 tested successfully, and patches the tivoapp if you use the latest enhancement script. I need to update the enhancement script that's packaged with the Zipper to run the patches. I'll probably get to it this weekend.
     
  11. Dec 6, 2005 #931 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    open up /etc/rc.d/rc.sysinit.author and look for lines that have "tivoweb".
     
  12. Dec 6, 2005 #932 of 2880
    shortkud

    shortkud New Member

    24
    0
    Dec 5, 2005
    AH HA! there is teh wrong path :D I changed it and now restarting the tivo. Will edit and let u know. Thank you VERY MUCh for the help and great script. Might i add if there is anyway to uncolorize the telnet prompt without uninstall and reinstall.

    now i cant FTP or telnet to tivo :( and obviously cant see tivowebplus. Did i tottaly **** something up?

    It gets an ip...
    i can also ping it fine.
     
  13. Dec 6, 2005 #933 of 2880
    Runch Machine

    Runch Machine New Member

    1,048
    0
    Feb 7, 2002
    Minneapolis
    Thanks that's great. I like having permanent 30 second skip. That's not in the current version for the HR10-250 is it?
     
  14. Dec 7, 2005 #934 of 2880
    crunchpvr

    crunchpvr New Member

    5
    0
    Oct 10, 2005
    I am trying to understand the script and have a couple ?'s (pardon me if this was answered earlier):

    Is TWP installed in "/var/hack/tivowebplus"? If it is, then how is it put back if /var is wiped? If not, where is TWP installed?
     
  15. Dec 7, 2005 #935 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    TWP is the only hack I keep in var, and it is not put back if var is wiped. I did it to balance out available disk space between var and root, and because it's simple to FTP the TWP back into var if it gets wiped. In the future, I'll fix it so that if var gets wiped it will automatically download a fresh copy from me.
     
  16. Dec 7, 2005 #936 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Its in there only if you use the latest enhancement script in my sig.
     
  17. Dec 7, 2005 #937 of 2880
    shortkud

    shortkud New Member

    24
    0
    Dec 5, 2005
    now i cant FTP or telnet to tivo :( and obviously cant see tivowebplus. Did i tottaly **** something up?

    It gets an ip...
    i can also ping it fine.
     
  18. Dec 7, 2005 #938 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Try rebooting. Maybe telnet is not running.
     
  19. Dec 7, 2005 #939 of 2880
    shortkud

    shortkud New Member

    24
    0
    Dec 5, 2005
    lol ive tried that a few times. I dont even see what putting the wrong path in tivowebplus would do with telnet or the ftp. If so is it possible to put the hard drive in my PC and correct the path then put it in the tivo again.

    :edit:

    i just pulled the plug and plugged it back in for the restart.
     
  20. Dec 7, 2005 #940 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I added a few checks to automatically detect if your telnet client is adding extra line feeds, and you need to use the "special" telnet instructions.

    Fixed the dos line endings in index.itcl identified here.

    Added patches for the HR10-250 to permanently enable 30-sec skip, disable encryption, enable backdoors, and menu sort.

    Used sed to remove the network startup commands from your author file if you used the Zipper. Previously, every time you rebooted your network settings would revert to those you set with the Zipper.

    More good stuff in the works!
     

Share This Page