1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Nov 21, 2005 #841 of 2880
    ttodd1

    ttodd1 Proud Computer Geek

    1,516
    0
    Nov 5, 2003
    SC
    No it does not work
     
  2. Nov 22, 2005 #842 of 2880
    fredfillis

    fredfillis Linuxly Challenged

    108
    0
    Sep 25, 2002
    DC Area
    Ok, my fakecall runs at 11.20 pm eastern, I see it come up on the screen every night.

    If I look at the root file I see the following:
    Code:
    # Run fakecall every night at 10:20pm cst
    20 4 * * * tivosh /busybox/fakecall.tcl
    Now if I understand that line correctly, fakecall should be running at 4.20am.

    So, wazzup with that? If I want fakecall to run at 2.20am I should change the 4 to a 2, right?

    Am I missing something here? Showing my age maybe?

    Cheers!
     
  3. Nov 22, 2005 #843 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Cron uses GMT, not EST. A search of this thread for GMT should bring some answers.
     
  4. Nov 22, 2005 #844 of 2880
    kramerboy

    kramerboy Jelly Man

    392
    0
    Jul 13, 2001
    Orrville, OH
    I use TWP to check my CID logs. However, every Monday I go into TWP and the cidcall.log is missing from the Logs section of TWP. This happens after the logs are wiped during the Sunday night scheduled reboot. NCID still works like it should, but the log is missing from the TWP list.

    If I FTP in, I can see the cidcall.log in enhancements/varhacks/log. Not in var/log where all the other logs are stored.

    If the enhancement script is uninstalled and then reinstalled, the CID log comes back.

    Any idea why the log doesn't come back after the Sunday reboot?
     
  5. Nov 22, 2005 #845 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Next time it happens, try rebooting manually to see if that brings it back. Also try supressing wipelogs in cron.
     
  6. Nov 23, 2005 #846 of 2880
    fredfillis

    fredfillis Linuxly Challenged

    108
    0
    Sep 25, 2002
    DC Area
    Doh! Of course. Thanks for your patience, apparently suffering from early senility here.
     
  7. Nov 24, 2005 #847 of 2880
    cyklfreak

    cyklfreak New Member

    41
    0
    Jun 9, 2005
    how do we use this if we are unable to connect the tivo to the web (dial up) but still like tivowebplus and want to use your script?
    can you include a non-automated one?
     
  8. Nov 24, 2005 #848 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Just for you... Download this and this, and FTP them to the same directory as tweak.sh. Open tweak.sh with vi and comment out the two lines that stat with "wget". An alternative is to download the Zipper tools disk, and copy out the scripts from there.
     
  9. Nov 26, 2005 #849 of 2880
    Runch Machine

    Runch Machine New Member

    1,048
    0
    Feb 7, 2002
    Minneapolis
    rbautch, thanks for the great scripts. I've been hoping someone would come up with this for a long time. I love having Caller ID on my DirecTivo.

    I am running Tivo Desktop version 2.02, which works fine with my Toshiba DVD burner/Tivo DVR. However, my DirecTivo doesn't see the computer (or any computer) running the Tivo Desk top. Is there another version that I am supposed to have running on the computer instead of 2.02?

    Tivo Desktop also doesn't see the DirecTivo, though I get bash prompt and can run the tweaks script with no problem.
     
  10. Nov 26, 2005 #850 of 2880
    JohnCarver

    JohnCarver New Member

    23
    0
    Aug 28, 2005
    There's a problem as it overwrites rather than appends the rc.sysinit.author,
    and even after fixing that via telnet, ftp doesn't work.
     
  11. Nov 26, 2005 #851 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Not true. It backs up your original to rc.sysinit.author.bak, and then APPENDS the startup commands. Try running the uninstall script, ,which puts everything back excactly the way it was before you ran the script, and then try to FTP. My guess is that you didn't have the proper FTP commands in your author file to begin with.
     
  12. Nov 26, 2005 #852 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Not sure about this. I have ver 2.0 and it works fine. Do you have a firewall?
     
  13. Nov 26, 2005 #853 of 2880
    JohnCarver

    JohnCarver New Member

    23
    0
    Aug 28, 2005
    With all due respect to your great script. It performs repeatedly just like I said. I overwrites my rc.sysinit.author, such that it now only contains the stuff that was supposed to be appended, and ftp stops running. Why would I lie.
     
  14. Nov 26, 2005 #854 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Tell me which line in the script overwrites your author file. Did you have an author file before? If there was no author file in place before, or if it got deleted somehow, you would only see the lines that get appended. If you post your rc.sysinit.author.bak file we'll be able to tell for sure.
     
  15. Nov 26, 2005 #855 of 2880
    Runch Machine

    Runch Machine New Member

    1,048
    0
    Feb 7, 2002
    Minneapolis
    I think that was it. I found version 2.0 here:
    http://www.zatznotfunny.com/ttg.htm#rollback

    I uninstalled Tivo Desktop 2.2, installed 2.0 and it worked, my DirecTivo found my computer.
     
  16. Nov 26, 2005 #856 of 2880
    Runch Machine

    Runch Machine New Member

    1,048
    0
    Feb 7, 2002
    Minneapolis
    rbautch, I see some people are running your script on the HR10-250. All I really want to add is Caller ID. Do you have a script that will do this?

    Will the Caller ID program in your script display on an HR10-250?
     
  17. Nov 27, 2005 #857 of 2880
    JohnCarver

    JohnCarver New Member

    23
    0
    Aug 28, 2005
    Well we're getting closer to finding out why the script doesn't fully work for me. Obviously if I say the script overwrote the rc.sysinit.author file and I had telnet and ftp working, I had such a file. Turns out the script creates an rc.sysinit.author.bak file of ZERO bytes.
     
  18. Nov 27, 2005 #858 of 2880
    bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002

    Not necessarily, you can turn on telnet and ftp from other files than the rc.sysinit.author file. For example from the test.conf file. It sounds to me like your rc.sysinit.author file either was empty or never existed in the first place.

    And, you really need to lose the attitude. The script has worked fine on numerous other DTivos and rbautch has spent an enormous amount of time supporting it. And giving him crap is certainly not going to make it fun for him to continue to do so.
     
  19. Nov 27, 2005 #859 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    It should work fine. If callerID is all you want, just answer no to everything else.
     
  20. Nov 27, 2005 #860 of 2880
    JohnCarver

    JohnCarver New Member

    23
    0
    Aug 28, 2005
    I repeat, I had a fine working rc.sysinit.author. I resent being accused of having an attitude cause I know whether I had an rc.sysinit.author. Certainly rbautch is to be commended for his efforts with zipper.

    LETS START OVER.

    Last year I used "sleeper" on a 4.01b HRVR2, and that was a helpful script. The zipper script had worked perfectly on the HDVR2 now running TiVo OS 6.2, and I get transfer rates of over 2.2 Megs/sec with the machine in standby mode.

    Now I also have an HR10-250. I have 3.1.5f with two 300 Gig HD, started with a legally purchased Instant cake, and had applied changes as suggested by http://www.imbetterthanyou.com/hr10-250 and http://groups.yahoo.com/group/hdtivo/files/HDTIVO_Modification_HOW_TO/. Everything worked fine, Telnet, FTP, TiVoWeb, fakecall, Tserver; but since zipper applied more stuff, and said it worked with an HR10-250, I tried that.

    When I ran the 11/13/05 zipper on the HR10-250, I now realize it created an rc.sysinit.author.bak of zero bytes length, such that when it appended its code to that, it left me with an rc.sysinit.author that didnt turn on the USB ports or Ethernet or ftp or telnet. Luckily I had a backup to my rc.sysinit.author on my PC to restore.

    Is there an outside attribute or some syntax inside of an rc.sysinit.author that would cause the zipper script to fail to properly back it up? Or some option in the script I should have passed on? I am not for a minute suggesting that it isn't possible the fault may be with me. But there is also a greater than zero possibility of something in the script causing this unexpected result.
     

Share This Page