1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Jul 22, 2005 #21 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    It was looking for TWP in root because that's where I had it when Hackman created my ini and cfg files. I forgot to remove those files when I archived the folder.

    Be careful if you edit your splash screen. Tivo is very particular about the format. The size has to be exactly 720x480 pixels, true color (24-bit), with a resolution of 73 pixels per inch. I had to pull my drive a few times when a non-conforming graphic threw my Tivo into a reboot loop. I used Visio to create the graphic, then saved as a .png, then resized in MS PhotoEditor. I'll post the source graphics on the website so you can play around with it. Be sure to post your new splash screen if you come up with something good! The other 2 splash screens are stored in MFS and need a tcl script to change.
     
  2. Jul 22, 2005 #22 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I posted a revised version of the script with the following changes:
    - Prompted yes/no to install crond.
    - Hackman fixed in TWP archive.
    - Fixed a small bug in the .profile to run Tivowebplus with "twp" regardless of where your TWP installation is.

    I also posted my original Visio file, graphics, and a few cool backgrounds if anyone wants to mess with the splash screen.
     
  3. Jul 23, 2005 #23 of 2880
    Gumpman

    Gumpman New Member

    6
    0
    Aug 17, 2003
    Frankfort,...
    Somehow I'm lost over this. I've downloaded, unzipped and I've put the files over to my tivo using SmartFTP. Just can't get the sh tweak.sh file to run. Keeps telling me no such file of directory. I know it's something simple I'm overlooking, but just can't figure it out. I've done a few mods to my systems before without much hassle, Hummmm. Any help would be appreciated, Thanks!
     
  4. Jul 23, 2005 #24 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Try running dos2unix on tweak.sh (and the uninstall script). Just type:
    Code:
    dos2unix tweak*
    from whatever directory you installed the files in. Is your FTP client set up for binary transfers? SmartFTP should not be in "auto-detect" or "ascii" mode, needs to be in "binary" mode. And don't ever open the file in a Windows or dos-based text editor.
     
  5. Jul 23, 2005 #25 of 2880
    Gumpman

    Gumpman New Member

    6
    0
    Aug 17, 2003
    Frankfort,...
    I'm in over my head I suppose. Can't figure out where to run dos2unix from, (that is a separate program I hope). I did find a web site that would convert for me, but that didn't work either. Thanks for the help, I'll hang my head low and give up soon. :(
     
  6. Jul 23, 2005 #26 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Don't give up just yet. dos2unix is already on your tivo. You can run it from anywhere. Just navigate to the directory where you copied tweah.sh, and use the command above to run it.
     
  7. Jul 23, 2005 #27 of 2880
    Gumpman

    Gumpman New Member

    6
    0
    Aug 17, 2003
    Frankfort,...
    Finally had success with it !! Woo Hoo. After several hours of trying different things, I stumbled on my mistake of not knowing the Telnet commands very well. I took a crash course on basic commands for telnet, and got SmartFTP set correctly, and WHAM!, it's game on !! Thanks rbautch for your time in responding so quickly and pointing me in the right direction. :)
     
  8. Jul 23, 2005 #28 of 2880
    markf57

    markf57 New Member

    69
    0
    May 9, 2002
    Longmont, CO
    rbautch:

    Thaks for such a great script. I upgraded one of my units to 6.2, but I wasn't able to get TWP to work for anything. This script fixed my problem.

    Thanks again.
     
  9. Jul 25, 2005 #29 of 2880
    HUGE2U

    HUGE2U New Member

    120
    0
    Jun 28, 2002
    Just installed it - worked like a charm - good stuff. It is worth it just for the TWP enhancements.


    HUGE
     
  10. Jul 25, 2005 #30 of 2880
    bnm81002

    bnm81002 New Member

    1,799
    0
    Oct 2, 2004

    hey Gunny,
    I didn't see you link "Rbautch's script" on your "unguide" ;)
     
  11. Jul 26, 2005 #31 of 2880
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    haven't had the chance yet.
     
  12. Jul 26, 2005 #32 of 2880
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    Thanks to insomnia, DONE.
     
  13. Jul 26, 2005 #33 of 2880
    pearkel

    pearkel New Member

    32
    0
    Jun 4, 2003
    Has anyone had problems uninstalling this script. I installed on 2 machines and It worked like a champ on the 2nd machine but on the 1st RCADVR40 I am having problems with tivoweb. I tried to uninstall but I just get a series of y's on the cmd prompt. It never really uninstalls.
    Any ideas?
    Thanks

    Also thanks for all of the knowledge on this forum I really appreciate it.
     
  14. Jul 26, 2005 #34 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Try running dos2unix on the uninstall script.
     
  15. Jul 26, 2005 #35 of 2880
    pearkel

    pearkel New Member

    32
    0
    Jun 4, 2003
    I tried that once and got the same result. I'll try again later tonight.
    Thanks
     
  16. Jul 26, 2005 #36 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    You might also try opening the file with vi, and looking for dos line endings that look like this: ^M^M You can manually delete them if dos2unix doesn't seem to work.
     
  17. Jul 26, 2005 #37 of 2880
    dmark1867

    dmark1867 Member

    31
    0
    Mar 22, 2005
    rbautch Thanks, this is awesome!

    If possible I would like to keep just my elseed log from being wiped.

    How can I have it wipe all logs but elseed?

    Thanks
     
  18. Jul 26, 2005 #38 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    What's the name of your elseed log, and where is it stored?
     
  19. Jul 26, 2005 #39 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    If it's in var/log/ and it is called elseed.log, then replace the file called "root" in the /var/spool/cron/crontabs/ directory with the attached one. This will copy your elseed log somwhere safe while the logs are being wiped, and then move it back after the wiping is done.
     

    Attached Files:

  20. Jul 26, 2005 #40 of 2880
    pearkel

    pearkel New Member

    32
    0
    Jun 4, 2003
    rbautch I checked this out at lunch today. I vi the script but I didn't see any extra commands. Right after I hit yes I think it says I don't think so then a series of these
    y
    y
    y
    etc

    and it just keeps going. I am at a loss on why it won't uninstall.
    Any other ideas?
     

Share This Page