1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Da Goon

    Da Goon Registered Abuser

    1,396
    0
    Oct 22, 2006
    It probably is.
    Ahh...wireless adapter...it's a driver/kernel issue.
    Check your pm box.
     
  2. kimsan

    kimsan underling

    732
    0
    Jan 23, 2002
    Greenbackvil...
    Odd. I've only had the Slicer fail once and that was due to impatience. I though it had died and ended up rebooting into a clean image so had to Zipper myself back to happiness.

    Since then I've had no issues. Run the Slicer per instructions, followed the prompts, walked away for 15 minutes or so, came back and hit a return (in some cases the process completed without returning the prompt) and finished out to a hacked latest version.

    I also tend to re-Tweak to catch up. Tweaking 6.3f got me onto TWP 2.1beta. I'm glad i did.
     
  3. gbakakos

    gbakakos New Member

    25
    0
    Dec 18, 2004

    Thanks for the help once again. Back up and running better than ever.

    Update: ok I spoke to soon...

    Seems to randomly reboot every once in a while. Have any idea what causes that? Or is there a specific log I can look into to see what may be causing it to happen. everything else sems to be fine, I have ftp, telnet and the wifi seems to be all working fine.

    I guess I could do it all over again but I thought I would ask first.

    My assumption in doing all this is that I must upgrade to 9.1 in order to keep my guide coming in. Is that correct or could I just stay at 7.2 forever?


    Update #2 - Looks like the rebooting issue has gone away for now. After doing it 3 times or so it has ot done it since I wrote this post the first time.


    Thanks
     
  4. cat3rn

    cat3rn cat3rn

    6
    0
    Nov 27, 2007
    Gardnerville...
    I am using PTVnet with the InstantCake 6.2 CD's. Everything worked great. I then applied the Enhancement script. using the enhanced mode. I updated the USB drivers when instructed. Could not connect to the Tivo. I then pulled the harddrive (again sigh) and reinstalled the PTVnet and InstantCake. Again everything worked fine. I then applied the Enhancement Script and decided not to update the USB drivers.

    That is the only change I made. Now the system keeps rebooting right after the AlmostThere.png screen comes up.


    I also created a new AlmostThere.png screen. Bliss with a couple changes. Just remove Bliss from the title and FTP to the correct folder.

    Edit 1: Ok I did the same thing and bypassed the DHCP and the USB installs. Endless reboot gone but now no networking. Is there a way to get networking without the endless rebooting?
     

    Attached Files:

  5. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Tivo is very picky about the format of the splash screen graphic, and if it's not exactly right, your tivo will reboot endlessly. There's some specific information about it earlier in this thread (here). I posted some correctly formated splash screens here.
     
  6. cat3rn

    cat3rn cat3rn

    6
    0
    Nov 27, 2007
    Gardnerville...
    I was able to use your script without the rebooting problem after I decided not to do anything with the USB or network stuff. The rebooting problem started before I changed any PNG files. My AlmostThere,png works fine on my tivo.

    What I would like to do is skip the USB and DHCP network stuff altogether. I have pulled my drive (left the top off the Tivo for now) at least 5 times. Using PTVnet and InstantCake 6.2 it works great but I would like to use 90% of your enhancements. I have tried to install the enhancements several times trying something different each time.

    I cannot get the network to connect. I am using a TrendNet TU2-ET100. I would like to keep the PTVnet with InstantCake USB & Network drivers. Is there a way to make a new script that does not run either of those. Saying no to the questions for network and USB doesn't matter it still won't connect. If you know of any other reason why my network won't connect after I run your script let me know.
     
  7. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I just uploaded a new version that should fix your issue. I don't have time to test it fully right now, but it should work. A few things to note:

    If the script detects that you have PTVnet, it will prompt you for some network information, like static IP or DHCP. You can't skip that, or the script will exit.

    The script sets up networking by inputting network parameters in the MFS database, which is different than how PTVnet does it. It replaces the PTVnet rc.sysinit.author file completely, and removes the /test.conf file in /init directory used by PTVnet to set up networking.
     
  8. cat3rn

    cat3rn cat3rn

    6
    0
    Nov 27, 2007
    Gardnerville...
    I thank you for the update I will check it out. However, I want to stay away from changing how PTVnet sets up the networking because it works. Can you tell me what it is about your script that you think will work? Cause I have no trouble with the way PTVnet does it. Is there a way to just skip the network setup in your script?
     
  9. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    You can't skip it. The way the script does it is the preferred method.
     
  10. cat3rn

    cat3rn cat3rn

    6
    0
    Nov 27, 2007
    Gardnerville...
    If I copy out the rc.sysinit.author from the /etc/rc.d/ folder and the MFS database (if I knew where it was located) run your script and then while I still have a networking connection (Doesn't fail till I install your script & reboot) transfer those files back and then reboot.

    I looked and the test.conf file is already gone anyway.

    Do you think that would work?


    BTW where might I find this new update?

    Also can I just install your version of TWP? and how?
     
  11. gbakakos

    gbakakos New Member

    25
    0
    Dec 18, 2004
    Now that I have my Series 2 back up and running after using SApper and Slicer. Would I have any issues or what should I be aware of if I wanted to now apply Hackman to the box. I thought I recall that SApper moves the hacks around or somethng like that!!
    Any suggestions? Don't do it!! Go ahead.. no problem!! ??

    Thanks
     
  12. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Nothing to worry about if you read the Hackman readme first.
     
  13. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Running tweak.sh again automatically downloads and runs the latest script. After you run it, you shouldn't have to do anything else.
     
  14. idiack

    idiack New Member

    2
    0
    Jan 10, 2008
    Has anybody been successful using clock.sh. My series 2 TCD 240 always return a message when downloading fonts. Here is a copy of my bash window when I run sh clock.sh.

    Sunugal-TiVo[{/enhancements}@(18:17:54)]# sh clock.sh
    What time zone are you in?
    1 Eastern
    2 Central
    3 Mountain
    4 West
    Enter the number corresponding to your time zone:2
    Downloading font...
    --18:18:06-- http://www.webpagepublicity.com/free-fonts/a/Arial%20Narrow Bold
    %20Italic.ttf
    => `/var/hack/share/fonts/Arial Narrow Bold Italic.ttf'
    Resolving www.webpagepublicity.com... 64.202.189.132
    Connecting to www.webpagepublicity.com|64.202.189.132|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    18:18:10 ERROR 404: Not Found.

    Font download failed. Exiting clock.sh.
    Sunugal-TiVo[{/enhancements}@(18:18:10)]#
     
  15. ttodd1

    ttodd1 Proud Computer Geek

    1,516
    0
    Nov 5, 2003
    SC
    And you put this in this thread because???????
     
  16. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    clock.sh is a script I wrote awhile back that is indeed included in the enhancements directory. It relied on a font downloaded from the internet which apparently is no longer available. I haven't had a chance to update it, and it's not high on my priority list. Any takers are welcome to it.
     
  17. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    Never thought to look at the files in that directory to see what toys you gave us. What exactly did it do?
     
  18. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Here is the thread on it.
     
  19. ttodd1

    ttodd1 Proud Computer Geek

    1,516
    0
    Nov 5, 2003
    SC
    My point was - maybe it should have been a separate thread.
     
  20. Carlton Bale

    Carlton Bale New Member

    168
    0
    Dec 17, 2001
    Indianapolis...
    Check the other thread for an updated version. redistribute as appropriate. Note: it's untested.
     

Share This Page