1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. taekwondodo

    taekwondodo New Member

    Mar 9, 2007
    Does anyone have any idea why Tivo Desktop no longer works after loading MRV with the enhancement script?

    I am running an HDVR2 + enhancement script + MRV - MRV works, but Music/Photos no longer finds TivoDesktop (1.3, tried 2.1 as welll) - It used to work, and now it doesn't.

  2. ttodd1

    ttodd1 Proud Computer Geek

    Nov 5, 2003
    Think I read you need version 2.0.
  3. taekwondodo

    taekwondodo New Member

    Mar 9, 2007
    I tried 1.3, 2.1, 2.0 and 2.3 (Deleting tivobeacon.exe each time) - none of them work. Where do I look in the tivo to see if the right application is running?


    - Jeff
  4. Gunnyman

    Gunnyman Just a boring dude

    Jul 10, 2003
    you don't
    everything is on the PC side.
    since MRV works, superpatch has been applied correctly on the tiVo.
    have you tried JavaHMO?
    it's really not that hard to configure?
  5. taekwondodo

    taekwondodo New Member

    Mar 9, 2007
    I had JavaHMO - and had no idea how to configure it... There were no destructions, nothing... nowhere. how do you configure it?


    - Jeff
  6. bengalfreak

    bengalfreak New Member

    Oct 20, 2002
    You double click the JavaHMO configure icon and away you go. A warning is in order, one of the problems with JavaHMO is that development on it has stopped completely. JavaHMO looks for the specific version of Java that comes with the program. If you let Java upgrade to a newer version it will break JavaHMO. And you can't use newer Java based programs, like Limewire with the old version of Java. If you can live with those limitations, JavaHMO works great. I solved the problem by putting JavaHMO on my server PC and running Limewire from a different computer on the network.
  7. rsuchowi

    rsuchowi New Member

    Jan 25, 2007
    Check your default gateway on the Tivo side. When my default GW was not proper it caused all kinds of problems.
  8. fredfillis

    fredfillis Linuxly Challenged

    Sep 25, 2002
    DC Area
    Apologies for not sharing how I fixed this. You need a later version of TivoWebPlus than was installed by tweak.sh. Check out the tivowebplus thread.
  9. thundermustard

    thundermustard New Member

    Jul 22, 2004
    New Hampshire
    I am trying to get the permanent 30 second skip working. I googled it and found this command
    #30-second skip
    echo -ne "\x10\x40\x00\x2b" | dd conv=notrunc of=tivoapp bs=1 seek=6717416
    which I ran from command prompt. In the past the command seems like it was longer than that.
    That didn't do it, then I tried the enhancement script, that didn't do it.
    Is that 30 second command right? Is it supposed to go in the author file for each reboot?
  10. rich47

    rich47 New Member

    Jun 19, 2002
    I have a hdvr2 with ptvnet and 6.3e. Is it possible to get MRV and HMO/HME running with the Enhancement Script?
  11. Markman07

    Markman07 New Member

    Jul 18, 2001
    All your questions will be answered at http://dvrpedia.com or http://dvrpedia.com/Modify_TiVoApp_to_disable_encryption_and_add_other_features
  12. kniederberger

    kniederberger New Member

    Dec 2, 2007
    I ran the tweak script on my DSR7000 6.3f and oddly, I didn't get the channel logos or the replaced splash screen even though I choose these options. Is there a way to manually add the logos? Thanks.
  13. Luv2DrvFst

    Luv2DrvFst New Member

    Nov 7, 2005
    6.3f on a DSR7000? I thought 6.3 was only for HD DTV's. Maybe that's the problem.
  14. kniederberger

    kniederberger New Member

    Dec 2, 2007
    Nope 6.3f is also for the SD DVRs (See this thread). My R10 recieved the 6.3f upgrade on it's own a few weeks ago and I used the slicer to upgrade my DSR7000 to 6.3f a couple of weeks ago.

    I had channel logos after the 6.3f slices were allpied, but lost them after running the tweak script.
  15. Lord Vader

    Lord Vader Dark Lord ofthe Sith

    Aug 29, 2004
    The Galactic Empire
    I have never been able to successfully run tweak or retain all the hacks after Slicer was run, and I've been trying this for 3 years at least. I have no idea as to why this happens, either.
  16. tivoupgrade

    tivoupgrade Sponsor

    Sep 27, 2000
    Chicago, IL USA
    The Slicer has been available for less than a year, so I'm not sure that this is a slicer-related issue so much as it is a problem that might be caused by manually updating to a newer version of the OS without going through the 'normal' process.

    It could be that your channel logos need to be reloaded (there is a channel logo slice floating around out there somewhere) which may or may not help. Or its possible that something about the format has changed in the database that requires it to be repopulated from the satellite or from a different slice file...

    This may work for you:

    cd /var/packages
    wget http://www.dvrupgrade.com/software/update_tool/logo-67.slice.gz
    gzip -d logo-67.slice.gz
    dbload logo-67.slice
  17. rbautch

    rbautch User

    Feb 5, 2004
    Chicago, IL
    As Lou mentioned, some things cannot be retained across a slice upgrade, namely anything that has to do with tivoapp like 30-sec skip, encryption, etc.. This is because tivoapp gets replaced when you upgrade your software to a newer version. The point of the slice upgrade is upgrade without pulling the drive, and then reapply your tivoapp patches.
  18. kniederberger

    kniederberger New Member

    Dec 2, 2007
    Thanks for the help, I tried the above and it didn't work on this DSR7000 with 6.3f. Actually when going to run the above, I found that dbload was no longer present on the system so I had to reload it. I rebooted and tried again with no success. Finally the logos loaded after I ran the command as "tivosh dbload logo-67.slice"

    There seem to be a lot of odd things going on with 6.3f such as missing files and strange occurrences with scripts. A couple of the enhancements installed by the tweak script did not seem to take, the all most there splash screen wasn't replaced and the channel logos??? The unit did do a double reboot when acquiring satellite data when I did the sync, reboot after running the tweak script (unfortunately, I was in telnet, not serial so I didn't capture the error). Has anyone else out there had success with tweak on a SD 6.3f unit? Maybe Lou can run it on the test unit he had on his bench a couple of weeks back:) Thanks.
  19. kniederberger

    kniederberger New Member

    Dec 2, 2007
    Channel logos are missing again:( The logos were there yesterday and are gone today. The system has been up for about 4 days and has had no new hacks or reboots since the logo slice was applied. All I can figure is that there must have been something downloaded from the satellite that is incompatible with the logos on this system? Any ideas?
  20. skinnyjm

    skinnyjm I'm Grumpy???

    Feb 10, 2005
    Milky Way
    EXCELLENT work!
    Why isn't this a sticky???

Share This Page