1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Nov 5, 2007 #2601 of 2880
    Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    Go to the Zipper instruction site and simply make sure that all the files shown on the screen shot are also on your Zipper tools CD, except for an image if you already have that on your drive itself. It sounds like you're missing one of the key things needed, and it's very easy to add it. Once it's in your Zipper folder, you'll then create an ISO that incorporates everything.
     
  2. Nov 5, 2007 #2602 of 2880
    Enrique

    Enrique Active Member

    5,066
    4
    May 15, 2006
    Well i added everything from the zipper.zip, So i am not 100% on anything other then that I need.


    Do I need a image or not to get the zipper working?
     
  3. Nov 5, 2007 #2603 of 2880
    Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    If you already have an image on your disk, you do not need one on your Zipper tools CD. If you are zippering a virgin drive, then you'll need an image, and that can easily be added to your Zipper tools CD. Look for an Instantcake image and add that to your Zipper tools CD.
     
  4. Nov 6, 2007 #2604 of 2880
    Markman07

    Markman07 Active Member

    2,208
    0
    Jul 18, 2001
    Minnesota
    Anyone know what EndpadPlus version is included with the zipper / script ?

    A few nice features have been recently added.

    1.2.0 (September 4, 2007)
    -- added bookmark feature to start playing show after start padding (drnull)
    -- updated & changed DST code to reflect new time changes in the US (falcontx)

    1.1.5 (July 15, 2007)
    -- added back-to-back exemption option (falcontx)
     
  5. Nov 6, 2007 #2605 of 2880
    katiebear00

    katiebear00 New Member

    41
    0
    Dec 26, 2005
    You dont necessarily need an image, but you do need the boot disc that is linked in the instructions.
     
  6. Nov 6, 2007 #2606 of 2880
    Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    Well, he IS going to need an image on either the drive itself or the CD.
     
  7. Nov 7, 2007 #2607 of 2880
    fredfillis

    fredfillis Linuxly Challenged

    108
    0
    Sep 25, 2002
    DC Area
    It has been awhile since I first tweak'ed. Last night I decided to download the latest version.

    Now, Tivoweb is not working. I can start it, but if I click on NPL, this is what I get

    Code:
    action_nowshowing '' ''
    can't read "::multi_delete": no such variable
        while executing
    "if {$::multi_delete} {
    set nstype 6
    } else {
    set nstype 0
    }"
        (procedure "MOD::action_nowshowing" line 5)
        invoked from within
    "$cmd $p1 $p2 $p3"
        (procedure "do_action" line 19)
        invoked from within
    "do_action $action $chan $part $env 1"
    
    Any ideas?

    I recently put NowShowing and dserver into tvbin in order to run TySuiteJ.
     
  8. Nov 7, 2007 #2608 of 2880
    fredfillis

    fredfillis Linuxly Challenged

    108
    0
    Sep 25, 2002
    DC Area
    never mind, fixed it myself
     
  9. Nov 7, 2007 #2609 of 2880
    Fofer

    Fofer XenForo Rocks! TCF Club

    82,080
    286
    Oct 29, 2000
    How did you fix it? Those details might help others who encounter the same problem in the future. :)
     
  10. Nov 8, 2007 #2610 of 2880
    daleykd

    daleykd New Member

    14
    0
    May 1, 2006
    Anna, TX
    I just want to verify that I read this right:

    If I had an HR10-250 at 6.3c (Zippered), let it upgrade to 6.3e via the phone line and DirecTV upgraded it, I lost my hacked TiVo.

    Now, can I use the Zipper again (with rbautch scripts) on 6.3e? Does the Zipper work ok with 6.3e?

    Thanks.
     
  11. Nov 8, 2007 #2611 of 2880
    Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    Yes, Zipper works fine with 6.3e.
     
  12. Nov 9, 2007 #2612 of 2880
    sandpj

    sandpj New Member

    97
    0
    Feb 9, 2004
    Houston
    Can you clarify how you fixed this issue? I have the same issue since the recent upgrade.
     
  13. Nov 9, 2007 #2613 of 2880
    incog-neato

    incog-neato ObamaGuy

    452
    0
    Sep 17, 2007
    The Cold...
    I had a couple problems with 6.3e/HR10. For 1, if you answer yes to ADD CHANNEL LOGOS it totally locks up (rbautch confirmed this but I'm not sure if it has been fixed yet) and the other problem was the TiVoweb wouldn't install. Ultimately I installed both of those items manually.
     
  14. MurrayW

    MurrayW Murray

    207
    0
    Aug 28, 2005
    Austin, TX
    When I was running tweak.sh I had a typo when trying to name my HR10-250 at the customize bash prompt step. I tried using the backspace key and the delete key to correct my mistake, but these keys just added some giberish to the end of my already erroneous name.

    I have 2 questions:

    1. In general, when you are using linix scripts, how can you backspace to correct an error in an entry?

    2. It's not a big deal to run the enhancement script over again, but if I can save a few minutes, I'd prefer to just run the portion that customizes your bash prompt. Is that EASY to do? I am sure that it is possible, but if it takes more time than it would to re-run the entire script, I would rather just re-run the full script -- can you tell I am lazy! ;)

    thanks,
    Murray
     
  15. katiebear00

    katiebear00 New Member

    41
    0
    Dec 26, 2005
    Don't rerun the script, just edit the /.profile file with the correct name for the bash prompt.
     
  16. Lopey

    Lopey New Member

    1,173
    0
    Feb 12, 2004
    Ormond...
    I can't seem to find the twp config file. Were is it put?
     
  17. bhang

    bhang New Member

    25
    0
    Oct 26, 2005
    sorry if its been asked, but I couldn't find it, can this be run on an SA1?

    bhang
     
  18. Da Goon

    Da Goon Registered Abuser

    1,396
    0
    Oct 22, 2006
    There are major differences in the MFS structure of an S1 compared to an S2 as well as processor differences (PPC vs MIPS), so .tcl scripts and binaries aren't backwards compatible. So my best guess would be no, this script won't work. I'm sure it'll run (or try to) since I assume it's a shell script (which is portable) but I'd heavily advise against doing so.
     
  19. eschuckmer

    eschuckmer New Member

    2
    0
    Apr 29, 2005
    I have a Hughes HDVR2 running 6.3e and have been having some problems with TivoWebPlus. Even though the lines are in my author script to start TWP, many times when I try to access TWP through a browser it comes back with the "connection timed out" message. I can get TWP to perform correctly by running the alias twprs that was installed by tweak.sh. But I would love for TWP to remain up for longer than it does.

    I know that tweak.sh used to install a cron entry to automatically restart TivoWebPlus every night at 3AM. However, it now seems that this step is no longer done. Is there any reason, in particular, that this was removed? Would there be any problem with creating a cron entry to do this myself?

    BTW, I've been hacking this Tivo from back in the Sleeper days, and did all my hacking previously without this wonderful script, so I have a pretty good understanding of how things work. I never used to have this problem with TWP periodically becoming unavailable. I understand it may have to do with 6.3e but was wondering if anyone has any ideas.

    Thanks.
     
  20. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Earlier versions of TWP were a bit flaky, and required periodic restarts to get some features working. The current version of TWP is more stable and reliable, so I removed the cron entries. There's no problem with creating a cron entry that periodically starts or restarts TWP.
     

Share This Page