1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. dturturro

    dturturro Member

    192
    0
    Feb 1, 2002
    Long Island
    did that already. posted it in my message. is there a way to just add PERMENANT 30 second skip?
     
  2. Da Goon

    Da Goon Registered Abuser

    1,396
    0
    Oct 22, 2006
    Yes, using a tivoapp patch. Looking thru your previous posts I'm assuming HR10-250 running 6.3d. If it's different, don't do this, the patch locations not may be the same, and the side effects could be bad. If you are running 6.3d, then do:
    Code:
    cd /tvbin
    mount -o remount,rw /
    mv tivoapp tivoapp.orig
    cp tivoapp.orig tivoapp
    echo -ne "\x10\x40\x00\x2b" | dd conv=notrunc of=tivoapp bs=1 seek=6713220
    sync
    mount -o remount,ro /
    reboot
     
  3. dturturro

    dturturro Member

    192
    0
    Feb 1, 2002
    Long Island
    thanks, I'll try that today!

    Ok, I tried it, rebooted and 30 second skip was not enabled. I was able to program it with S-P-S-3-0-S. Any ideas where to go from here?
     
  4. Da Goon

    Da Goon Registered Abuser

    1,396
    0
    Oct 22, 2006
    There's not any reason it should not have worked unless you're running another sw version or made a typo. I'd put my original tivoapp back in place to avoid issues due to a bad patch.
    Try it again. That's the only way to make it permanent.
     
  5. dturturro

    dturturro Member

    192
    0
    Feb 1, 2002
    Long Island
    I've had several problems trying to zipper my drive. I want to start from scratch with a new CD so I redownloaded: lba48, an instant cake 6.3d image, the zipper script and superpatch (I want 30 second skip to stay permenant on my HR10-250). I unzipped everything and put the items in the tools directory but I'm missing vmlinux.px.

    Any thoughts on what I did wrong or how to fix it? Before suggesting 'search' I did that and only saw posts regarding the program not running. Nothing about it missing altogether. ;)
     
  6. incog-neato

    incog-neato ObamaGuy

    452
    0
    Sep 17, 2007
    The Cold...
    2 separate problems:

    #1) HR10-250 6.3D ..... script seems to hang up on "installing channel logos." Tried it twice. About 30 minutes later nothing is happening. It's worked many times with no problems in the past but I just upgraded my HR10 to 6.3D using Slicer so I reran your script. 3rd time I just skipped logos and then had this problem:


    #2) Uninstall then reinstall .... keep getting this error (HR10-250 6.3D):

    Code:
    Do you want to install Tivowebplus? [y/n]: y
    Installing TWP in root directory...
    sed: bad option in substitution expression
    /enhancements/start.sh: line 712:  1046 Broken pipe             cat /TivoWebPlus
    /load.tcl
          1047 Done(1)                 | sed -e "s/TivoWebPlus/TivoWebPlus - $bashna
    me/" >/TivoWebPlus/temp
    Appending your rc.sysinit.author file to run TWP on startup
    I attached the complete dialog as a file copied from the screen
     
  7. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I was able to duplicate the logo hang on my HR10-250, but not any of my other Dtivos. I'll look into that. I was not able to duplicate the TWP error. It looks like it's failing when it tries to edit your load.tcl file to include your bash prompt name. It does this to customize the TWP menus to show "Family Room", "Bedroom", etc., to distinguish one tivo from another.
     
  8. incog-neato

    incog-neato ObamaGuy

    452
    0
    Sep 17, 2007
    The Cold...
    Don't know if it matters, but I have 1 correction. It should read "I just upgrade to 6.3E (not D). Sorry.

    Is there a way I can try using my previous RBAUTCH_FILES.TGZ which worked last time? I have no option other then to download the newest update which might be the problem.

     
  9. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    if you used the Zipper, you can pull it off of there. The TWP distro included with the enhancement script hasn't changed in several months, so I doubt it would make a difference if you rolled back to an earlier version.
     
  10. Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    Gonna use Slicer to go to 6.3e on one of my HR10-250s that's constantly rebooting and had a question. IIRC, someone once said that the instructions in The Slicer weren't exactly correct--something about not having to do the symlinks command or something.

    Does anyone have the step-by-step instructions for using The Slicer after the slices have been installed? I'm basically looking to confirm what's exactly done after The Slicer runs.
     
  11. captainjrl

    captainjrl New Member

    22
    0
    Aug 31, 2004
    I'm looking to do the same thing for the same reason. Any help would be greatly appreciated.
     
  12. Nov 1, 2007 #2552 of 2880
    Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
  13. Nov 1, 2007 #2553 of 2880
    incog-neato

    incog-neato ObamaGuy

    452
    0
    Sep 17, 2007
    The Cold...
    I did that, but every time I run tweak.sh it still insists on downloading the newest update (which was the one previous to the latest one).
     
  14. Nov 1, 2007 #2554 of 2880
    captainjrl

    captainjrl New Member

    22
    0
    Aug 31, 2004
  15. Nov 1, 2007 #2555 of 2880
    richr69

    richr69 New Member

    18
    0
    Aug 9, 2005
    I zippered my R10 using Zipper 1.7b awhile ago. The TWP in that version of the zipper is something like 1.3 or so (I don't remember). How do I update the TWP to the latest version found on the latest Zipper.
     
  16. Nov 1, 2007 #2556 of 2880
    Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    Just out of curiosity, does it matter which version of The Slicer we use? I have Slicer6.3a and wish to slice from 6.3a to 6.3e.
     
  17. Nov 1, 2007 #2557 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    If you put it in the same directory as tweak.sh, it will skip the download.
     
  18. Nov 1, 2007 #2558 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I think you mean version 1.3a. Should work fine if your adapter uses stock drivers, or you copy your backported drivers manually. I don't think they added the feature that automatically copies backported drivers until a later version.
     
  19. Nov 1, 2007 #2559 of 2880
    Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    10-4. Thanks.

    BTW, check your PM. I didn't want to clutter this thread with that question. ;)
     
  20. Nov 1, 2007 #2560 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Running tweak.sh will get you caught up with the latest version from the Zipper. However this is not guaranteed to be latest version of TWP.
     

Share This Page