1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. HellFish

    HellFish I can dress myself.

    217
    0
    Jan 28, 2007
    Go to the TWP site and read the instructions here for details. It's easy... Make sure your tivo is in RW mode, then use the update link in TWP. When you update, you'll be uploading the file you download from the TWP site, no untarring is needed. You don't need to FTP the file to the Tivo, TWP can upload it from your Windows machine. If you have further questions, maybe you should try the TWP 2.0 thread for answers.

    See this post for the updated patches. Since the patches are in different locations, I don't think the superpatch will work with 6.3e, until someone modifies it.
     
  2. MurrayW

    MurrayW Murray

    207
    0
    Aug 28, 2005
    Austin, TX
    Can't start TWP so can't use the update link there. :p

    I have to do it the "old fashioned" way.

    Murray
     
  3. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The latest version of the script now has patch locations for 6.3e. Since the the script is usually run right after running the Zipper, it expects to find a /zipper_flag file before it will patch your tivoapp. So if you choose to run the script strictly to patch your tivoapp, run this command first to create the flag:
    Code:
     touch /zipper_flag
     
  4. falstaffpac

    falstaffpac New Member

    83
    0
    Nov 12, 2003
    I just sliced my HDTivo up to 6.3e, ran the enhancement script and received the following error:

    /enhancements/start-e.sh: line 232: syntax error near unexpected token 'else'
    /enhancements/start-e.sh: line 232: ' else'

    The script then ends. I'm going to try and bypass the start-e.sh and patch tivoapp manually, I just wanted you to be aware of the error I'm getting on my end.

    Aaron
     
  5. jmw86069

    jmw86069 New Member

    7
    0
    Jan 1, 2006
    I have the same issue as falstaffpac.

    I got stuck in the middle, trying to apply the patch manually and screwed something up in the copy/paste. (For some reason didn't just edit and create a new sub-script.)

    Will try to rezipper then reinstall.

    General symptom seems like some extra returns are added (dos2unix could fix it.) But since the script itself does the download, it shouldn't be introduced on our end.

    So I guess two ways to get around the issue?
    1) Update start-e.sh so it ignores that whole TiVo version section (just apply the patches you need without all the if's)
    2) Update tweak.sh so it runs dos2unix before it runs.

    Will report back.
     
  6. jmw86069

    jmw86069 New Member

    7
    0
    Jan 1, 2006
    Sorry, dropping out of the troubleshooting on this one, I rebooted after manually applying start-e.sh lines, and it works... :up:

    So I'm not going to rezipper and re-run unless I have other issues. Other TiVo issues I mean -- I got plenty of issues otherwise!

    rbautch, you the man. Thanks for all the effort, and for the continued support.
     
  7. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Sorry guys, I introduced a typo right before I uploaded the new file. Should be fixed now. You don't have to pull your drive, just rerun the script.
     
  8. MurrayW

    MurrayW Murray

    207
    0
    Aug 28, 2005
    Austin, TX
    I FTP'd the latest TWP into my TiVo then untarred it
    Code:
    tar -zvxf tivowebplus-v2.0.0-070804.tgz
    and TWP is now working.

    Thanks for the help technojunkie!

    Murray
     
  9. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    This is the same thing I had to do. For some reason either SApper or Tweak makes the TivoWebPlus directory unaccessible. I tried every command I could find and it always said it was not a directory. I just take a fresh download and unzip it over the top and presto, everything works.
     
  10. bmerri19

    bmerri19 Member

    53
    0
    Oct 9, 2002
    Colorado...
    Hi,

    I seem to be having some issue with fakecall working. DTV says my one of my two hacked Tivos hasn't called in.

    I checked both rc.sysinit.author files (I have the file listed in two places on both Tivo's: /etc/rc.d/rc.sysinit.author
    and /enhancements/rc.sysinit.author) and both have the two "route add" statements, but they are not commented out. Should they be?

    Both Tivo's are non-zippered (old school hacked), and using tweak.sh for upgrades. Would re-running tweak.sh get a new version that fixes the rc.sysinit.author file?

    Thanks,
    Brian
     
  11. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I just ran a fresh install of tweak.sh and couldn't duplicate this issue. If you can, try to replicate it and do an ls -l to see what the properties of the TWP directory are.
     
  12. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    It will be a few days before I can, I am on the road this week.
     
  13. bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002

    At some point last week, two of my DTivos stopped "calling in", one of them hadn't make a succesful fake call in almost a month. I had to uninstall/reinstall the script to get it working.
     
  14. Redrocker5150

    Redrocker5150 New Member

    1
    0
    Oct 15, 2006
    I've searched everywhere and can't fig out how to get usb200m v2.1 to work. Have installed script and answered yes to usb 2.0. Running latest script.

    Help please.
     
  15. dcstager

    dcstager 1st Gen Tivo Owner

    573
    2
    Feb 16, 2002
    Skagit...
    Where is the latest version of the script? Is this the tweak.sh script, the zipper (4.0), or a newSuperpatch diff file?

    I'm probably going to upgrade to 6.3e when I get the slices with slicer. I then want to rerun the superpatch. Where is the latest version of superpatch that works with 6.3e? Or should I just rerun tweak.sh to patch the new software when slicer finishes?
     
  16. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Running tweak.sh will download the latest script and patches. Superpatch does not support 6.3e yet.
     
  17. dcstager

    dcstager 1st Gen Tivo Owner

    573
    2
    Feb 16, 2002
    Skagit...
    Just to be clear, if I run tweak.sh after upgrading to 6.3e will my system be patched the same way the superpatch would patch it if it did support 6.3e? Or do I have to wait until a new superpatch is released to get things to work as before?

    I realize some features are missing from 6.3e. I'm just not clear on what all I need to do to upgrade properly. I gather I can just run tweak.sh again and all is good. Or are the patches in tweak.sh different than the patches in superpatch?
     
  18. tivoupgrade

    tivoupgrade Sponsor

    2,494
    0
    Sep 27, 2000
    Chicago, IL...
    Not sure if you guys are talking about the HR10-250 or an SD dtivo; if you are talking about the HR10-250, you may want to try the script mentioned in this article and report your results.

    Lou
     
  19. Soapm

    Soapm Active Member

    1,564
    0
    May 9, 2007
    So close,...
    Didn't do it this time. When I rebooted TWP started the first time. I knew those drugs from the 70's would come back to haunt me :)
     
  20. JWThiers

    JWThiers Smartypants

    2,611
    0
    Apr 12, 2005
    Cocoa, Florida
    I didn't think superpatch was needed for the HR10-250's (6.3x series)? or did I miss something? Since I don't have an HDTV (YET!!!) I don't pay that close attention to the HR10-250 stuff.
     

Share This Page