1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. Aug 28, 2005 #221 of 2880
    Human123

    Human123 DTivo TakeitOrLeavo

    165
    0
    Jun 9, 2003
    I just installed your script on one of my Tivos' and it went flawlessly. Very nice job. As the above poster indicated I also only have a few logos. Will is take time for them to come in or should they be there right away?

    I had a question on TWP. I understand that the script auto installs and starts it. My question is that in the past when I manually start it, one of the lines says that it is making the root read/write. Does yours do this? I know it installs in var so it shouldn't need to make the root read/write and I understand there are dangers by leaving your root read/write when it does not need to be.
    Thanks
     
  2. Aug 28, 2005 #222 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    After a reboot, the logos should be there right away.

    When my script lauches, it mounts the root file system as read-write. It only installs TWP, but does not start it (well, not directly anyway). Instead, it appends your author file with a line that calls a newly created short script called TWPrun.sh, which actually starts TWP when you reboot. When my script finishes, it mounts your directory read-only again, so it's safe to reboot. I think the line you see is Hackman mounting read-write so it can create some config files. Remember, you can use your new profile aliases to switch between read-only and read-write, just by typing "ro" or "rw" from bash.
     
  3. Aug 28, 2005 #223 of 2880
    Human123

    Human123 DTivo TakeitOrLeavo

    165
    0
    Jun 9, 2003
    Thanks,
    I am going to try your slice suggestion above to get the logos, but wanted to know where I should ftp the two files? To the enhancements directory? Or /hacks where tweaks.sh resides?
    The reason for the question is I want to stay as close as possible to your original script so the uninstall would still get everything.
    Thanks
     
  4. Aug 28, 2005 #224 of 2880
    bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002
    I did as you said and got exactly the error shown above. But even after a reboot, I still have no logos whatsoever.


    Edit: Actually, there was one small difference in the error I got. After ntpdate, the number in the brackets is 861 instead of 22583.
     
  5. Aug 28, 2005 #225 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The only other think I can think of is to try the old logo slice (logo-67.slice). If you still have an old rbautch-files.tgz you can get it from there, or else download it from DDB. One more obvious thing, but I have to ask....logos don't show up next to folders in NP, you have to open the folders to see the actual listing.
     
  6. Aug 28, 2005 #226 of 2880
    Human123

    Human123 DTivo TakeitOrLeavo

    165
    0
    Jun 9, 2003
    Doh!!!

    I can't believe everything was in a folder...

    Thanks again
     
  7. Aug 29, 2005 #227 of 2880
    bengalfreak

    bengalfreak Active Member

    2,101
    0
    Oct 20, 2002

    Geez, what a freakin' idiot I am. I was checking the Now Playing list and the guide. Everything in NP was in a folder and of course the logos show up on the info screen, not the guide. I apologize profusely for wasting your time. I thought I knew alot about the workings of my TiVo. Guess not. Thanks again Rbautch. I'll just sit over here and keep my mouth shut for a while. :eek:
     
  8. Aug 29, 2005 #228 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    No problem. My own stupidity has occasionally caused a drive pull or a complete Tivo meltdown.
     
  9. Aug 29, 2005 #229 of 2880
    marklyn

    marklyn New Member

    448
    0
    Jan 21, 2002
    Austin
    I have recently purchased the PTVnet CD for my HDVR2 system with the TivoWebPlus PTVupgrade - v1.1-pre2 with mods.

    Am I safe in upgrading or is it not worth upgrading to this version?

    One more question... if I do upgrade do I need to edit the file that has my local network settings first so that I can 'talk' to my HDVR2 after the files are upgraded and run?
     
  10. Aug 29, 2005 #230 of 2880
    regicat

    regicat New Member

    55
    0
    Dec 19, 2002
    California
    First, a big THANKS to rbautch! For Marklyn: I did the same thing. Right after I used pvtnet (which made USB2/telnet/ftp very easy) rbautch came out with his brilliant script. Here is what you need to do:

    1. If you did not install ptvnet, then install it but do not install tivoweb when asked. Make sure to NOT allow ptvnet to change phone setting. In other words, only use it for USB2/telnet/ftp.

    If you already installed ptvnet with tivoweb then do these steps:

    2. Telnet into tivo and make sure FLAG_SWAP PHONE is ON. You do this by typing "FLAG_SWAP PHONE" and looking at the results. Each time you enter it it will swap ON/OFF. If it's OFF then cron will be started twice from rc_sysinit_author.

    3. Make SURE FLAG_SWAP TIVOWEB is OFF. Otherwise, the PRE2 will start BEFORE the new one (which is newer and has more modules).

    You can see the flags in /init/ptv_flags.

    After that follow the install for tweak.sh, that's it. It worked everytime for me on 2 HDVR2s. BTW, if you upgrade tweak.sh make sure you uninstall before ftping the new files. The uninstall moves the old files from /enhancements to /. I did that after I ftp'd the new tweak files and they were overlaid with the old ones.

    If you have more than 1 tivo you can then add the mrv patch which was the reason I did all this in the first place. Before ftping I edited out the 2 extra patches (30 second skip, etc). That was my preference.

    Once ptvnet gets your networking working there is nothing to do, these patches do not affect network settings.
     
  11. Aug 29, 2005 #231 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Marklyn, I'm having trouble understanding what you're trying to accomplish. Have you already hacked your Tivo to accesss to it over your network, or is that what you're trying to accomplish now? Or are you just trying to add Tivowebplus to an already hacked Tivo?
     
  12. Aug 29, 2005 #232 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Now I get it (I think). Thanks regicat. I gather the ptv disk is a pre-hacked image with TWP already installed. If you run my script, I would suggest deleting the old Tivowebplus installation to save on space, and manually editing your rc.sysinit.author file to remove any reference to calling it up. I don't know where PTV puts the TWP installation, but after running my script, you can find it by typing "find tivoweb" at bash. If they put it in var, and var gets too full, your Tivo will wipe the var directory and destroy any hacks you have stored there, including the Tivowebplus installation installed by the script.
     
  13. Aug 29, 2005 #233 of 2880
    marklyn

    marklyn New Member

    448
    0
    Jan 21, 2002
    Austin
    What I think I'm doing is 'upgrading' what I already have (hacked). I guess I'm assuming that the tivowebplus version I use (v1.1-pre2 with mods) is not as current as your version. I am particularly interested in the season passes backup module that is in your version and that's one of the reasons why I am interested in 'upgrading' what I already have.

    I just wanted to be sure that since I already have a hacked 6.2 version on my HDVR2 that I didn't need to de-install what I have in favor of putting your version on.

    Forgive me for not using the correct terms. I'm new at this and I'm reading as much as I can but it still escapes me in understanding the differences between tivoweb, tivowebplus and apparantly different flavors of these programs. It sounds to me like your current version of software is very similar to what I have except there appears to be more features there than what I have now.

    thanks
     
  14. Aug 29, 2005 #234 of 2880
    regicat

    regicat New Member

    55
    0
    Dec 19, 2002
    California
    rbautch, thanks so much for you effort and this great script! As you see from my post above:

    "if you upgrade tweak.sh make sure you uninstall before ftping the new files. The uninstall moves the old files from /enhancements to /. I did that after I ftp'd the new tweak files and they were overlaid with the old ones."

    Just an idea: to make things more idiot-proof, the uninstall script could issue a message if it is about to overlay a file in /. It would have saved some time trying to figure out why nothing happened after the upgrade to 2.2. Yes it it my fault but thought you should know... I installed the pre 2.2 and upgraded to 2.2 and both worked flawlessly for me.

    Thanks again!
     
  15. Aug 29, 2005 #235 of 2880
    regicat

    regicat New Member

    55
    0
    Dec 19, 2002
    California
    Marklyn, the rbautch script has not only more modules but many fixes. I had trouble with the pre2 from ptvnet. As for where ptvnet puts tivoweb, it goes to /pvtupgrade. Yes, I forgot to mention I deleted the tivowebplus and tivowebplus-pre2 directories from there. As for stopping tivowebpre2 from starting, as long as the flags are set as I mentioned above there is no problem.
     
  16. Aug 29, 2005 #236 of 2880
    marklyn

    marklyn New Member

    448
    0
    Jan 21, 2002
    Austin
    regicat, since you've already done this, hope you can answer a few questions.

    1) Sound like I just need to delete the ptvupgrade folder and then follow rbautch's install script?
    2) are there any screen shots available (i searched and didn't find any).
    3) How long have you had this version running, do you feel it's stable and worth the effort (I'm guessing yes).
    4) I have another HDVR2 coming in a few days. I assume if I want to run this script I'd put a new 6.2 image on the drive I'm going to use and then run rbautch's install script.

    I guess I'm sligtly apprehensive in removing that folder and running the new install script. Doesn't the functionality to 'connect' (ftp/telnet) to my HDVR2 exist in that folder, so if I delete it, won't I be removing the ability to talk to my HDVR2?

    Sorry for the dumb questions. Hope I can repay someone else one day with any knowledge gained here.
     
  17. Aug 29, 2005 #237 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Great idea. My original intention was to move the rbautch-files archive back to the root directory before /enhancements got deleted by the uninstall script. Since I keep my tweak.sh script in root, this allows me to uninstall and reinstall the script over and over. I see now that perhaps this is not the best arrangement for casual users.
     
  18. Aug 29, 2005 #238 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    I assume the ptvupgrade folder contains other things, so just delete a subfolder in there called "tivowebplus". Also see if you can find the line in your /etc/rc.d/rc.sysinit.author file that launches this old version of tivowebplus, and delete it. Then run the tweak script. The tweak script makes no changes to your network setup, so that will stay in tact no matter what script options you choose. The tivowebplus archive installed by the script is very stable.
     
  19. Aug 29, 2005 #239 of 2880
    marklyn

    marklyn New Member

    448
    0
    Jan 21, 2002
    Austin
    Should I delete all of these lines listed?
    #start tivowebplus or tivowebplus pre 2

    if [ -f /init/ptv_flags/TIVOWEB_ON ]; then
    mkdir -p /var/hack
    if [ -f /init/ptv_flags/TIVOWEB-PRE2_ON ]; then
    /ptvupgrade/tivowebplus-pre2/tivoweb
    else
    /ptvupgrade/tivowebplus/tivoweb
    fi
    sleep 30
    fi

    Also, what about the tivowebplus-pre2 folder, should I delete that too?

    Thanks
     
  20. Aug 29, 2005 #240 of 2880
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Yes, delete them all, and the pre2 folder. This code looks like it copies two versions of tivowebplus to your Tivo, and then starts the one you select via flags.
     

Share This Page