1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Enhance Your Hacked Tivo With This Script

Discussion in 'TiVo Underground' started by rbautch, Jul 21, 2005.

  1. s_steve

    s_steve New Member

    3
    0
    Jan 12, 2007
    So where is the tweak_uninstall.sh script? It is not in the zip file with tweak.sh.
     
  2. Lord Vader

    Lord Vader Dark Lord ofthe Sith

    1,087
    0
    Aug 29, 2004
    The...
    It's on your TIVO, if you've ever hacked it before using Zipper/tweak. When you run tweak.sh, it will prompt you to uninstall first. Choose "Y" and it will uninstall.
     
  3. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    It is contained in the rbautch_files.tgz archive, which gets unpacked to /enhancements directory when you run tweak.sh.
     
  4. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    If you removed the enhancements directory without running the uninstall script, you'll now have duplicate entries in your author file and profile. If you ran tweak.sh with exactly the same options as the first time you ran it, it should be okay, but you may want edit out the duplicate entries.
     
  5. jim5359

    jim5359 New Member

    12
    0
    Jan 29, 2004
    Excuse me if this has been answered before, but I've been searching and can't find a definitive answer. I'm about to hack a totally clean image using PTVNet, Superpatch & rbautch's tweak script. My question is, should I apply Superpatch before or after the tweak script?

    Thanks!
     
  6. s_steve

    s_steve New Member

    3
    0
    Jan 12, 2007
    Thanks for the help finding the tweak_uninstall script. I finally dug in and opened tweak.sh and looked what you are doing-- very slick!

    I'm having telnet/console problems I think. The script runs, and downloads files, but when it comes to answering questions (the read variables in the scripts), it goes nuts. It must have something to do with passing LF/CR or loopbacks or something.

    When I respond to a question (y CR) its like it receives the LF or CR first, leaving the response blank, then uses the y response to the next question, followed by another LF or C
    R. I've tried just using Cntl-J (linefeed) instead of the enter-key (cntl-m) without much difference.

    Also noted that when I am at the bash prompt, I always get two response lines back using the enter key (or cntrl-m). And if I am in vi, I must use cntl-J or I get two lines. But when responding to the script, cntl-J doesn't help.

    I've tried stock windows telnet, starting it with the telnet -t vt100 192.....
    and I have tried it with PuTTY, with its various options-- no joy on any combos.

    Any ideas??
     
  7. Bluewookie

    Bluewookie New Member

    161
    0
    Sep 24, 2003
    The zipper wiki has info about the 2 consecutive returns at the command line. I don't know how to change it in default windows telnet console, but in PuTTy go to Connection --> Telnet, and then uncheck "return key sends telnet new line instead of ^M"
     
  8. s_steve

    s_steve New Member

    3
    0
    Jan 12, 2007
    Thanks Bluewookie-- that fixed it.... I was running an old version of putty also. Updated that, made the change you recommended, set the term to vt100 and it just ran the script.
     
  9. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    You can also run this batch file to permanently change your windows terminal settings to work with tivo telnet.
     
  10. turkey

    turkey New Member

    2
    0
    Jan 18, 2007
    Can you point to any info for applying the Superpatch to my SA?
     
  11. JWThiers

    JWThiers Smartypants

    2,611
    0
    Apr 12, 2005
    Cocoa, Florida
    Basic information about how to access your can be found at he Steve Jenkins site here.
    You will need to install Superpatch which can be found at the site we can't link to or menetion by name but it is D-E-A-L-D-A-T-A-B-A-S-E-.-C-O-M
     
  12. luder

    luder New Member

    245
    0
    Sep 7, 2006
    Chicago, IL
    I'm not sure if ths is covered but, i notice the tivo etho: mtu is set to 1500 is there a way to change the mtu to 1492 for router configuration?

    Can anyone help?

    PHP:
    Jan 23 04:06:19 (noneHandleDataChanged[3007]: Tmk Fatal ErrorThread HandleDataChanged <3007strayed!
    Jan 23 04:06:19 (noneHandleDataChanged[3007]: pc 0xcd8adc status 0x8001fc13 cause 0x000010 bva 0xdeadbeef hi 0xe0637407 lo 0x8fe8ec18
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R00 0x00000000 R01 0xfefefeff R02 0x00c74774 R03 0x00000000
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R04 0xdeadbeef R05 0x5ed8d2fc R06 0x5ed4eee4 R07 0x00000000
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R08 0x00000000 R09 0x00000000 R10 0x5ec50114 R11 0x00000004
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R12 0x00000000 R13 0x2ae421bc R14 0x40f0800b R15 0x90c88000
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R16 0xdeadbeef R17 0xdeadbeef R18 0x5ed8d2fc R19 0x5ed4ab54
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R20 0x00000000 R21 0x100e4d38 R22 0x00000000 R23 0x5ed8d2fc
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R24 0xc0647a19 R25 0x00cd8ab0 R26 0x000c9be6 R27 0x00000000
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: R28 0x1006d910 R29 0x7b7ff1c8 R30 0x00030021 R31 0x00c747b8
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: bt -/tvbin/tivoapp
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: read 0x2aaa8000 /lib/ld.so.1
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: read 0x2ab04000 /lib/libutil.so.1
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: read 0x2ab48000 /lib/libdl.so.2
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: read 0x2ab8c000 /lib/libpthread.so.0
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: read 0x2abe8000 /lib/libm.so.6
    Jan 23 04
    :06:19 (noneHandleDataChanged[3007]: read 0x2acb0000 /lib/libc.so.6
    Jan 23 04
    :06:20 (noneHandleDataChanged[3007]: 0x00cd8adc 0x00c747b8 0x00c39e24 0x013bbbc0 0x013bb1b8 0x00c388c0 0x00c398d0
    Jan 23 04
    :06:20 (noneHandleDataChanged[3007]: 0x00c350e0 0x00c3105c 0x00c226c4 0x00c337f0 0x00c70e0c 0x00c70910 0x00c72040
    Jan 23 04
    :06:20 (noneHandleDataChanged[3007]: 0x00c71714 0x00c70bc4 0x00c6ffcc 0x00c62d54 0x00c5a634 0x00c613bc 0x00c6dc2c
    Jan 23 04
    :06:20 (noneHandleDataChanged[3007]: 0x00c6d69c 0x00c6c4fc 0x00c6b940 0x00c6b790 0x0123e850 0x013a706c 0x013ce190
    Jan 23 04
    :06:20 (noneHandleDataChanged[3007]:
    Jan 23 04:06:20 (noneHandleDataChanged[3007]: Tmk Fatal ErrorThread HandleDataChanged <3007>: unexpected signal 10
    Jan 23 04
    :06:20 (noneHandleDataChanged[3007]: Tmk Fatal ErrorThread died due to signal 10
    Jan 23 04
    :06:20 (noneHandleDataChanged[3007]: Invoking rule 834rebooting system
    Jan 24 13
    :47:18 (noneTmkAssertionFailure[298]: (DumpArenaAndBlocksAndDieline 1472 ())
    Jan 24 13:47:18 (nonetivosh[298]: Tmk Fatal ErrorThread tivosh <298strayed!
    Jan 24 13:47:18 (nonetivosh[298]: bt -/tvbin/tivoapp
    Jan 24 13
    :47:18 (nonetivosh[298]: read 0x2aaa8000 /lib/ld.so.1
    Jan 24 13
    :47:18 (nonetivosh[298]: read 0x2ab04000 /lib/libutil.so.1
    Jan 24 13
    :47:18 (nonetivosh[298]: read 0x2ab48000 /lib/libdl.so.2
    Jan 24 13
    :47:18 (nonetivosh[298]: read 0x2ab8c000 /lib/libpthread.so.0
    Jan 24 13
    :47:18 (nonetivosh[298]: read 0x2abe8000 /lib/libm.so.6
    Jan 24 13
    :47:18 (nonetivosh[298]: read 0x2acb0000 /lib/libc.so.6
    Jan 24 13
    :47:18 (nonetivosh[298]: 0x013b3e3c 0x013b3c90 0x013b3f84 0x00f58234 0x00f9312c 0x00ff3154 0x00fd7a48
    Jan 24 13
    :47:18 (nonetivosh[298]: 0x00f8da78 0x00fb7a28 0x00f8eb18 0x00fed644 0x00fb7a28 0x00f8eb18 0x00f94628
    Jan 24 13
    :47:18 (nonetivosh[298]: 0x00fb7a28 0x00f8eb18 0x00fed644 0x00fb7a28 0x00f8eb18 0x00f8e770 0x00f911fc
    Jan 24 13
    :47:18 (nonetivosh[298]: 0x00fd84c4 0x00ffdbfc 0x0100127c 0x00fe31c8 0x00fe3714 0x00fb672c 0x00f8da78
    Jan 24 13
    :47:18 (nonetivosh[298]: 0x00fb7a28 0x00f8eb18 0x00fd99ec 0x00fdd23c 0x00f58150 0x00612c48 0x00403090
    Jan 24 13
    :47:18 (nonetivosh[298]: 0x2acc13fc
    Jan 24 13
    :47:18 (nonetivosh[298]: Tmk Fatal ErrorThread tivosh <298>: assertion failure
    Jan 24 13
    :47:18 (nonetivosh[298]: Tmk Fatal ErrorThread died due to signal -2
    Jan 24 13
    :47:18 (nonetivosh[298]: Invoking rule 834rebooting system
    the last line occured after using twp debug with full list then going into hackman


    Kernal reports

    PHP:
    Jan 24 13:48:24 (nonekernelTime set toWed Jan 24 13:48:24 2007
    Jan 24 13
    :48:24 (nonekernelEnabling local route
    Jan 24 13
    :48:24 (nonekernelSetting TCP keepalive parameters
    Jan 24 13
    :48:24 (nonekernelChecking for additional disk
    Jan 24 13
    :48:26 (nonekernelStart fan control
    Jan 24 13
    :48:26 (nonekernelFirst temperature parameters set:
    Jan 24 13:48:26 (nonekernelTerminal temp71
    Jan 24 13
    :48:26 (nonekernelCritical temp62
    Jan 24 13
    :48:26 (nonekernelLogging temp60
    Jan 24 13
    :48:26 (nonekernelTarget temp50
    Jan 24 13
    :48:26 (nonekernelLowest fan speed7
    Jan 24 13
    :48:26 (nonekernel: /tvbin/fancontrol is running in the background.
    Jan 24 13:48:26 (nonekernelStarting TvLauncher
    Jan 24 13
    :48:27 (nonekernelPokeFirewallPortPoking hole through firewall at port 2191protocol tcp
    Jan 24 13
    :48:28 (nonekernelWaiting for launcher to start.
    Jan 24 13:48:28 (nonekernelLauncher is running.
    Jan 24 13:48:30 (nonekernelScanning for phase2 repair scripts
    Jan 24 13
    :48:30 (nonekernelRunning boot Stage E_PreApplication scripts
    Jan 24 13
    :48:31 (nonekernelChecking for database conversions
    Jan 24 13
    :48:32 (nonekernelNo upgrade to load
    Jan 24 13
    :48:32 (nonekernelNot upgrading software
    Jan 24 13
    :48:32 (nonekernelScanning for phase3 repair scripts
    Jan 24 13
    :48:32 (nonekernelRunning boot Stage F_ApplicationLaunch scripts
    Jan 24 13
    :48:32 (nonekernelStarting Services.
    Jan 24 13:48:41 (nonekernelMicrocode version is TiVo!
    Jan 24 13:48:41 (nonekernelFound hpk front panel model 1
    Jan 24 13
    :48:43 (nonekernelusb.cregistered new driver usbdevfs
    Jan 24 13
    :48:43 (nonekernelusb.cregistered new driver hub
    Jan 24 13
    :48:43 (nonekernelusb.cstarting integrated EHCI driver
    Jan 24 13
    :48:43 (nonekernelehci_hcd 00:0d.2PCI device 1033:00e0
    Jan 24 13
    :48:43 (nonekernelehci_hcd 00:0d.2irq 6pci mem b4002000
    Jan 24 13
    :48:43 (nonekernelusb.c: new USB bus registeredassigned bus number 1
    Jan 24 13
    :48:43 (nonekernelPCI00:0d.2 PCI cache line size set incorrectly (0 bytesby BIOS/FWcorrecting to 32
    Jan 24 13
    :48:43 (nonekernelehci_hcd 00:0d.2USB 2.0 enabledEHCI 0.95driver 2003-Dec-29/2.4
    Jan 24 13
    :48:43 (nonekernelhub.cUSB hub found
    Jan 24 13
    :48:43 (nonekernelhub.c5 ports detected
    Jan 24 13
    :48:43 (nonekernelusb.cEHCI initialization succeeded
    Jan 24 13
    :48:43 (nonekernelusb-ohci.cUSB OHCI at membase 0xb4000000IRQ 5
    Jan 24 13
    :48:43 (nonekernelusb-ohci.cusb-00:0d.0PCI device 1033:0035
    Jan 24 13
    :48:43 (nonekernelusb.c: new USB bus registeredassigned bus number 2
    Jan 24 13
    :48:43 (nonekernelhub.cUSB hub found
    Jan 24 13
    :48:43 (nonekernelhub.c3 ports detected
    Jan 24 13
    :48:44 (nonekernelhub.c: new USB device 00:0d.2-1assigned address 2
    Jan 24 13
    :48:44 (nonekernelusb.cUSB device 2 (vend/prod 0xb95/0x7720is not claimed by any active driver.
    Jan 24 13:48:44 (nonekernelusb-ohci.cUSB OHCI at membase 0xb4001000IRQ 3
    Jan 24 13
    :48:44 (nonekernelusb-ohci.cusb-00:0d.1PCI device 1033:0035
    Jan 24 13
    :48:45 (nonekernelusb.c: new USB bus registeredassigned bus number 3
    Jan 24 13
    :48:45 (nonekernelhub.cUSB hub found
    Jan 24 13
    :48:45 (nonekernelhub.c2 ports detected
    Jan 24 13
    :48:45 (nonekernelusb.cregistered new driver usbnet
    Jan 24 13
    :48:46 (nonekerneleth0register usbnet usb-00:0d.2-1ASIX AX88772 USB 2.0 Ethernet
    Jan 24 13
    :48:47 (nonekerneleth0openenable queueing (rx 73tx 73mtu 1500 ASIX framing
    Jan 24 13
    :48:55 (nonekernelPokeFirewallPortPoking hole through firewall at port 2190protocol udp
    Jan 24 13
    :48:56 (nonekernelPokeFirewallPortPoking hole through firewall at port 2190protocol tcp
    Jan 24 13
    :49:09 (nonekernelusing driver frame iter
    Jan 24 13
    :49:09 (nonekernelApgLogFrequency0 sec )
    Jan 24 13:49:09 (nonekernelFinished creating ApgDriverFrameIter
    Jan 24 13
    :49:09 (nonekernelUsing a smartSorter!
    Jan 24 13:49:54 (nonekernelCalling ReadStream()s
    Jan 24 13
    :50:07 (nonekernel: ....started status session
    Jan 24 13
    :50:15 (nonekernelInitialize with 2 live caches
    Jan 24 13
    :50:15 (nonekernelAddInputSection 1
    Jan 24 13
    :50:15 (nonekernelAddInputSection 2
    Jan 24 13
    :50:15 (nonekernelTvMomMediaSwitchSource::DoSetup()
    Jan 24 13:50:15 (nonekernelTvMomMediaSwitchSource::DoSetup()
    Jan 24 13:50:15 (nonekernelAddInputSection 3
    Jan 24 13
    :50:18 (nonekernelApgManager Transition from state INIT to BOOT
    Jan 24 13
    :50:22 (nonekernel: ....started status session
    Jan 24 13
    :50:23 (nonekernel: ....sending Booting event
    Jan 24 13
    :50:23 (nonekernel: ....sending Booting event
    Jan 24 13
    :50:28 (nonekernelScanning for phase4 repair scripts
    Jan 24 13
    :50:28 (nonekernelRunning boot Stage G_PostApplication scripts
    Jan 24 13
    :50:35 (nonekernelFakecall ran successfully!
    Jan 24 13:50:35 (nonekernel:
    Jan 24 13:50:36 (nonekernelCouldn't bind to socket.
    Jan 24 13:50:36 (none) kernel: /etc/rc.d/rc.sysinit.author generated by hackman completed
    Jan 24 13:50:36 (none) kernel: rc.sysinit is complete
    Jan 24 13:50:38 (none) kernel: /TivoWebPlus/tivoweb: /TivoWebPlus/.dist/CrashCount: Read-only file system
    Jan 24 13:50:40 (none) kernel: ApgManager Transition from state BOOT to FAST_LOAD
    Jan 24 13:50:45 (none) kernel: EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
    Jan 24 13:50:49 (none) last message repeated 2 times
    Jan 24 13:50:51 (none) kernel: ApgManager Transition from state FAST_LOAD to FAST_LOAD
    Jan 24 13:51:08 (none) last message repeated 3 times
    Jan 24 13:51:22 (none) kernel: ApgManager Transition from state FAST_LOAD to STEADY_STATE
    Jan 24 13:51:40 (none) kernel: ....sending Done event
    Jan 24 13:51:40 (none) kernel: ....sending Done event
    Jan 24 15:38:57 (none) kernel: EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
    Jan 24 15:39:31 (none) last message repeated 2 times
    Jan 24 15:39:38 (none) kernel: EXT2-fs warning: mounting unchecked fs, running e2fsck is recommended
    Jan 24 15:59:58 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x00cb7121
    Jan 24 15:59:58 (none) kernel: Before = 0x00cb46ee, After = 0x00cb471c
    Jan 24 15:59:58 (none) kernel:
    Jan 24 16:00:00 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x01344293
    Jan 24 16:00:00 (none) kernel: Before = 0x01341b79, After = 0x01341ba7
    Jan 24 16:00:00 (none) kernel:
    Jan 24 16:00:02 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x01762cdb
    Jan 24 16:00:02 (none) kernel: Before = 0x01762d11, After = 0x01762d3f
    Jan 24 16:00:02 (none) kernel:
    Jan 24 16:00:02 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x01a1222b
    Jan 24 16:00:03 (none) kernel: Before = 0x01a12287, After = 0x01a122b4
    Jan 24 16:00:03 (none) kernel:
    Jan 24 16:00:05 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x02578a47
    Jan 24 16:00:05 (none) kernel: Before = 0x0243f4b5, After = 0x0243f4e2
    Jan 24 16:00:06 (none) kernel:
    Jan 24 17:22:21 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x056011cb
    Jan 24 17:22:21 (none) kernel: Before = 0x05601225, After = 0x05601253
    Jan 24 17:22:21 (none) kernel:
    Jan 24 17:26:54 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x01692c37
    Jan 24 17:26:54 (none) kernel: Before = 0x01692c72, After = 0x01692ca0
    Jan 24 17:26:54 (none) kernel:
    Jan 24 17:54:34 (none) kernel: !!!!WARNING: Needed 2 tries to set video STC to 0x03366041
    Jan 24 17:54:34 (none) kernel: Before = 0x033660e4, After = 0x03366112
    Jan 24 17:54:34 (none) kernel:
    Jan 24 19:34:03 (none) kernel: waiting for connections on port 8074
    Jan 24 19:56:28 (none) last message repeated 2 times
    I don't know if if the last two repeats are do to TY but, I'm experiencing problems with streaming to pc I can only watch half of the streaming show. however, I can watch the whole show if i move the status bar back to where it left off. I'm using Windows media to play the streams any ideas?
     
  13. Jimbob_wat

    Jimbob_wat New Member

    12
    0
    Nov 20, 2006
    Ran the newest download of the Zipper last night. Did everything I did before and it worked perfectly this time. I was able to see the drive once installed in TIVO over ethernet and the tweak.sh ran perfectly.

    I have also made the serial cable and was able to run the tweak before this most recent download via serial and yes it worked as well.

    Rbautch and JWthiers thanks for all your help. Thanks to all those who wrote the various modules. I love this setup, in fact I currently have 7 Tivos all with 2 tuners active and running Tivoserver on my network with 100 ripped movies being served up.
     
  14. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Use this to change your MTU:
    Code:
    ifconfig eth0 down; ifconfig eth0 mtu 1492; ifconfig eth0 up
     
  15. Bluewookie

    Bluewookie New Member

    161
    0
    Sep 24, 2003
    Russ,

    Does that command to change MTU persist or is it something you would have to change manually each time?
     
  16. tsunami

    tsunami New Member

    181
    0
    Sep 21, 2003
    New Boston, NH
    OK, I know there are tons of questions relating to Crond not running. But that is the problem, there are tons of questions and finding all of them is tough.
    Let me please explain my situation and hope somebody can help guide me to a reason crond isn't running.
    OK the line /busybox/crond is in the author file like it should be but it doesn't run (checking with PS).
    OK, if I type crond it starts. If I then kill it and type cd /busybox/crond it runs, if I type cd /busybox; crond it runs.
    I can get it to run only by manually starting it.
    I can do that but it is driving me crazy.
    By the way, uninstalled tweak and reran it assuming that would fix it as well.
     
  17. doconeill

    doconeill Unix Guru

    239
    0
    Dec 13, 2002
    West of Boston
    Curious...why do you want to change the MTU? Are you for some reason doing PPPoE with your TiVo?

    The only place you should really be setting the MTU to 1492 is on the router which connects you to the Internet, and only if your Internet connection type is PPPoE (i.e. some Verizon territories, although I hear they are moving away from it). Internally on your own network, 1500 is appropriate.
     
  18. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Agreed. However on a gigabit Ethernet network you achieve significant faster extractions/insertions using jumbo frames, provided your entire network supports it. I set my MTU to 9000 on both my Tivo and PC.
     
  19. rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    No it doesn't stick. I added it to my aliases to make it easy to set. I couldn't get it to run from my author file.
     
  20. luder

    luder New Member

    245
    0
    Sep 7, 2006
    Chicago, IL
    Thanks rbautch, wow I feel honored that you replied my post so far in the past 2 days i talked to to celebrities and one more to go. You guys really inspire me to do more seeking new things each day.. I have to say you guys had me up at zipper it's now burned in my mind so much that i can know run zipper & rbautch's perfectly with out taking the dvr apart anymore :D
    And would do my part in helping as much as i can like the Army commercial say Army of One
     

Share This Page