1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Drive Expansion and Drive Upgrade FAQ

Discussion in 'TiVo Series3 HDTV DVRs' started by bkdtv, Oct 19, 2007.

  1. May 22, 2011 #7621 of 10248
    Kit_C

    Kit_C New Member

    39
    0
    Oct 29, 1999
    Escondido,...
    My upgrade to a WD15EVDS (see original post below) failed, and I'm starting to think my Tivo has other issues.

    After deactivating IntelliPark and restoring an image from the original 320GB drive, I was able to get the Tivo to boot and show the expected storage. But after moving the unit into my entertainment center, I got hung up on the "Welcome. Powering UP" screen. I tried installing my original 320GB drive (which was working last week), and it too is getting hung up at the welcome screen.

    Is it possible for the power supply to fail in a way that I get video out, but the power to the drive is interrupted? If that's the case, I think I may have intermittent or sagging power.

    Kit


     
  2. May 23, 2011 #7622 of 10248
    tchunnui

    tchunnui New Member

    5
    0
    Sep 24, 2007
    As an update, I ran wdidle3 and rebaked my drive over the weekend. Everything works after a little hang up after downloading the latest software. The manufacture date on the drive is March 14, 2011. I'm not sure if rebaking it solved the issue or if disabling intellipark did, but either way, it seems a lot of these newer drives are coming with intellipark that should probably be disabled. Thanks all for the help and suggestions, I'm back to having 2 tivos again! :up:
     
  3. May 23, 2011 #7623 of 10248
    richsadams

    richsadams Active Member

    8,893
    2
    Jan 4, 2003
    Ugh. Well, it appears that whatever happened between last September and more recently, things may be back to square one with respect to having to run wdidle3.exe to extend the timeout or disable the Intellipark feature on Western Digital GP and possibly AV/GP hard drives (of all sizes and manufacture dates) to avoid an initial boot or soft reboot problem. :mad:

    Thanks to everyone for the data points! :up:

    FWIW I have reached out to bkdtv with regard to updating this thread's FAQ (first post), but haven't received a response to date. I'll try once more and if that doesn't work I'll contact one of the moderators for suggestions.
     
  4. May 23, 2011 #7624 of 10248
    leiff

    leiff Member

    513
    1
    Aug 24, 2005
    Is there any downside to having to run wdidle3? Will the WD drive work as well as one a little older that doesn't require wdidle3?
     
  5. May 23, 2011 #7625 of 10248
    richsadams

    richsadams Active Member

    8,893
    2
    Jan 4, 2003
    No known differences with respect to TiVo. However there is some back-and-forth regarding simply adjusting the timeout from the eight second default to 300 seconds (/S300) OR disabling it completely. The discussion revolves around the impact on the lifespan of the drive itself. Both camps seem to have compelling positions with respect to why one or the other is better however neither side have any long-term proof that their position is actually correct. To date drives adjusted either way haven't started to fail en-masse either so the jury is still out.

    FWIW I tend to fall into the 300 seconds camp if only from a gut feeling about the whole thing and knowing that was the original recommendation from others here and on other forums...and that it works perfectly fine in TiVo's case.
     
  6. May 23, 2011 #7626 of 10248
    Stuxnet

    Stuxnet Alien Infidel

    356
    0
    Feb 8, 2011
    +1 on 300 seconds, FWIW
     
  7. May 25, 2011 #7627 of 10248
    mgar

    mgar New Member

    1,779
    0
    Feb 13, 2005
    San Joaquin...
    Update on my WD10EARS Installation on my Tivo HD:

    The drive I installed was manufactured AUG 2010 and does have the intellipark problem. This is the drive that I ordered a couple of weeks ago and received last week.

    The Tivo stalled on the Welcome Screen during a soft reboot.

    I removed the drive and ran wdidle3. I ran into one problem. For some reason if I ran wdidle3 to make sure it would see the drive, and then ran it again with the /s300 option it would hang, and then give an abort retry fail error.

    After retrying on a second computer I found that if I just ran wdidle3 one time with the /s300 it worked just fine.
     
  8. May 25, 2011 #7628 of 10248
    MPSAN

    MPSAN Active Member

    1,190
    1
    Jun 20, 2009
    Portland,...
    I had the same issue a number of months ago. My suggestion was (back then) to just run it, but these threads get lost. What I did was run it with the options and then I did a reboot. When I checked again I found that it did change the settings.
     
  9. May 26, 2011 #7629 of 10248
    aswann

    aswann New Member

    16
    0
    Jan 8, 2007
    Just a quick note to say a big Thank You to all have contributed to this thread. I upgraded my Series 3 last night and it went seamlessly thanks to all the info I got here. I purchased a WD10EVDS from NewEgg. I did run WD3IDLE on it to be safe. Used MFSLIVE with the SuperSize option and am now showing 156 HD hours. Whole thing took 2.5 hours start to finish and I had time to load the dishwasher, do a load of laundry (my wife was very happy when she got home) and watch part of a move on Netflix instant view while the copy was taking place. Feel really good about this solution since the original drive was getting some age on it. Now I have a backup of the OS on my computer and a spare drive on the shelf.
     
  10. May 27, 2011 #7630 of 10248
    larrs

    larrs Movie Fan-Addict

    1,011
    0
    May 2, 2005
    DFW
    I know things have changed since the original FAQ was published and searches return a lot of info, some conflicting.

    Is there still a limit of 1350GB on the S3 OLED (1.5TB Drive) or can one now go 2TB on these?

    I notice a lot of discussion on 2TB for the THD, but I am specifically talking the original model S3. I am looking to eliminate all external drives in the near future.
     
  11. May 27, 2011 #7631 of 10248
    richsadams

    richsadams Active Member

    8,893
    2
    Jan 4, 2003
    Yes, the limit still applies for the DIY method here. However there are a couple of folks (DVRDude and Weaknees) that are selling 2TB drive upgrades for the original Series3.
     
  12. May 27, 2011 #7632 of 10248
    ashu

    ashu User title defunct

    9,158
    0
    Nov 8, 2002
    MD
    New Datapoint : My March 2011 built WD10EVDS (1 TB Green WD) required a wdidle3 /D, otherwise my S3 was stuck in an infinite wait at "Welcome, Powering Up"

    Sadly, my Vantec eSATA enclosure that housed the drive for this tweak/MFS imaging was recognized (chipset issue?) at bootup/Bios/DOS drivers on the wdidle3 disk image on the 4th system on which I tried. And I tried AHCI on/off and various permutations. The system that worked was the oldest I had access to,t hat had an eSATA. Sigh.

    This was two days after the FIOS nistallation, at which time I was forced to accept (an icky, but vastly improved over the Comcast crud) Motorola DVR for the interim.

    As always, thanks to the maintainers of this thread and the nice folks (you know who you are!) who make images available to those of us who can do it themselves. This situation should serve as a great reason to prep your TiV/drive/upgrade early, going the pre-built image route if you must, to ensure installation success by havnig it functional on the day your installer arrives.

    Now I can only regret having to let the FIOS installer walk out with his bevy of M CableCards that he couldn't leave with me, and think about the right way to obtain the cards from Verizon and self-install them (call? write? petition my senator?) rathr than have a truck roll. And get rid of the rather-average VZ FIOS DVR! (mailback? Dropoff?)
     
  13. May 27, 2011 #7633 of 10248
    larrs

    larrs Movie Fan-Addict

    1,011
    0
    May 2, 2005
    DFW
    Thanks.

    I am definitely going DIY. The last time I bought a DVRDude drive, it worked great but ultimately required a $35 truck roll from my cable company to fix cablecard pairing issues- making the total cost nearly $150 for a 1TB upgrade (or double what I can do the 1350GB upgrade for myself). I would much rather copy the info from my own drive...
     
  14. May 27, 2011 #7634 of 10248
    ChinaBull

    ChinaBull New Member

    17
    0
    Aug 11, 2008
    Here's a random list of internal HD experiences in case there is a common thread.

    About 3 years ago, I upgraded the internal 160G to a 1T Seagate ST3100005N1A1AS. Everything worked well until several weeks ago when the "30 second skip" skipped to the end instead of a 30 second skip. I rebooted, and the Tivo stuck in a reboot loop a the "Welcome to Tivo" screen.

    On the assumption that it was a bad hard drive, I got a WD10EARS (Manufacture date 13 Sep 2010) to replace it. Install steps:

    1. Run WDIDLE3 to set Intellipark to 300 Seconds
    2. Use MFSLive to try to copy the old HD to the new HD, in case the drive wouldn't function in a Tivo environment, but possibly MFSLive could succeed. *Fail - at 1%, Seg faults and bad sectors appeared.
    3. Use MFSLive to copy the old 160G HD to the new 1T HD. The copy completed. I put it in the Tivo and tried to boot. *Fail - Gray screen of death.
    4. Giving up on Linux (I admit, I didn't pay my dues; no kernel recompile, no custom driver was written), I switched to WinMFS and copied again. *Failed - "Welcome screen of Death"
    5. Several more tries, finally it boots up all the way. I put the cover back on, only to find that it's stuck in the "Welcome screen of death" again.
    6. Further tries to reprogram seem to indicate success, but the delay is so long that the drive has clearly failed in the write mode. The WDS Diagnostics confirmed problems - many bad, unrepairable sectors.
    7. Switched to a spare 1T WD1001FALS drive, and it works. I don't know anything about how suitable that drive will be in a Tivo environment, but it seems to work at the moment.

    Analysis - clearly the original Seagate has a problem; the Tivo thought there was a problem, which could have been a bum Tivo software update, but the bad sector issue was confirmed in another system. The kicker: I downloaded the Seagate DOS diagnostics to get a trouble code for the warranty - both a quick test and long test found no bad sectors. Hypothesis: The drive can function when read sequentially. And since Seagate will just throw the drive on a system with the same "test program", there's no point in trying to do a warranty return.

    The WD10EARS failure:
    • Did the WDIDLE3 command mess up the drive firmware? I didn't find that model in the official list for the WDIDLE3 program.
    • Infant mortality?
    • Hopefully the use of WDIDLE3 won't void the warranty.
     
  15. May 27, 2011 #7635 of 10248
    dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    As I understand it, any upgrade method that doesn't use a backup image from your TiVo (e.g., DVR_DUDE, Instant Cake, image begged from another TiVo) is going to require re-pairing of the CableCARD(s) unless you happen to be on a cable system that doesn't enforce pairing, e.g., Verizon FIOS.
     
  16. May 28, 2011 #7636 of 10248
    asteinfeld

    asteinfeld New Member

    6
    0
    Mar 29, 2007
    Hello, all. I have an unmodified S3 to which I paired a WD MyDVR Expander a long time ago. I believe the primary drive is now dying (regular freezes and hanging reboots). So, I'm going to swap out the original drive before it gives up the ghost entirely. Can someone confirm that I can (must?) follow the steps as laid out in section IV(11) of the FAQ to install the new drive and pair it to my current WD external drive? Can someone also confirm that there is no way to copy over my current recordings to the new setup? (This last is no big deal, since I've been copying archived shows to the PC with Tivo Desktop, but I'd like to be sure I'm not missing an option).

    Thanks much for your help.
     
  17. May 28, 2011 #7637 of 10248
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,719
    7
    Apr 6, 2000
    SF Bay Area
    Its more likely your expander is failing, but in either case, if either drive fails, you have problems.

    You would have to disconnect/divorce the expander drive before you can change a drive. You will lose any recordings since the expander was attached.

    You would be better to change to a single drive setup with a 1 TB or larger drive than to rely on a 2 drive setup.
     
  18. May 28, 2011 #7638 of 10248
    unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    You might want to make sure it's the internal drive and not the external that's going bad.
     
  19. May 29, 2011 #7639 of 10248
    lrhorer

    lrhorer New Member

    6,922
    0
    Aug 31, 2003
    San...
    This is not true, at all. First of all, dd_rescue can copy the failing drive to a similar or larger drive in an effort to effect repairs. Secondly, depending on drive sizes, WinMFS or MFS_Tools may be able to not only copy the information from the drives, but also merge them into one.

    True.
     
  20. May 29, 2011 #7640 of 10248
    richsadams

    richsadams Active Member

    8,893
    2
    Jan 4, 2003
    Unfortunately that's been tried (many times) and it's not possible.
     

Share This Page