1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Drive died, need help!

Discussion in 'TiVo Series3 HDTV DVRs' started by sAe23, Aug 8, 2012.

  1. Aug 8, 2012 #1 of 29

    sAe23 New Member

    Aug 8, 2012
    I hope this is an appropriate forum to post this to.
    I have read through various threads but would like an opportunity to present my specific situation.

    I have a S3 HD (652160).
    The hard drive died.
    I read various posts about using 2TB drives but decided to try.
    I am using a Hitachi Deskstar (I can't find a "model" number on it).
    I downloaded "652_gset.tbk" from a link in a thread on this forum, and got WinMFS.

    DURING the process, I told it NOT to limit the partition size.
    I also supersized it.

    I'm in TWC country, and have a multi cable card and tuning adapter.

    When first powered up, it seemed happy.
    It got as far as asking my zip code, and downloading guide info.
    It then rebooted when I pressed select to move on.

    After several attempts, it finally stated there was a hardware problem (this was in a "messages and settings" menu section.

    I tried rebooting with the cable card removed but it just kept restarting during the "just a few more minutes" phase.

    I tried kickstart codes 54, 57 and 58.
    54 did the SMART test and the drive passed (good thing as it's brand new!).
    58 installed an update (not sure if it actually finished).
    57 did a GSOD and said it was going to try to fix the hardware issue.
    I walked away since it said it might take several hours, but after about one hour, it was in a reboot cycle again.

    So, to make a long inquiry short, should I have limited the partition size? Did I use the wrong backup file? Or is there something else I need to look into?


  2. Aug 8, 2012 #2 of 29

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    Is that a 2TB Hitachi?

    The model number should be on the sticker on the top of the drive.
  3. Aug 8, 2012 #3 of 29

    sbourgeo Hepcat Daddio

    Nov 10, 2000
    New England
    Did you do a "Clear & delete everything" at some point? That's required when using an image from one TiVo HD on a different TiVo HD.
  4. Aug 8, 2012 #4 of 29

    sAe23 New Member

    Aug 8, 2012
    OK, the model appears to be HDS723020BLA642

    As for performing a "clear and delete everything", if that is in "messages and settings" I never got that far. The reboots started during the initial setup. And the image seems to be for an HD, unless other models started with 652xxx?

  5. Aug 8, 2012 #5 of 29

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    That image should start you out in Guided Setup (said the guy who created it).

    It could be that particular drive and the TiVo are destined not to get along.

    There is no official TiVo tested and approved replacement hard drive list, because they never intended for anyone to be replacing their own hard drives.

    Do you have another hard drive you could use temporarily? One say about 750Gb to 1TB in size?

    I have a "middleman" technique for putting a 2TB in an HD with the final expansion done by jmfs.

    In the meantime hook that drive back up to the computer, open WinMFS again, and copy and paste (to here) the partition table from mfsinfo.
  6. Aug 9, 2012 #6 of 29

    sAe23 New Member

    Aug 8, 2012
    Here is the WinMFS info.
    I am still looking for a spare drive to test with.
    I'm also considering running the "Fix" utils in WinMFS, but will wait for your feedback...

    Mfsinfo (Drive 1)

    Boot Page
    Boot Page: root=/dev/hda4
    Active Boot Partition: 3 Active Root Partition: 4
    Backup Boot Partition: 6 Backup Root Partition: 7

    MFS Super Header
    state=0 magic=ebbafeed
    devlist=/dev/hda10 /dev/hda11 /dev/hda12 /dev/hda13 /dev/hda14 /dev/hda15
    zonemap_ptr=1121 total_secs=3905175552

    Zone Maps
    Z0: type=0
    map_start=1121 map_size=1 backup_map_start=589822
    next_map_start=263266 next_map_size=6 next_backup_map_start=589816
    zone_first=1122 zone_last=263265 zone_size=262144 min(chunk)=262144
    free=262144 checksum=dac4bba1 logstamp=8681169 num_bitmap=1
    Z1: type=2
    map_start=263266 map_size=6 backup_map_start=589816
    next_map_start=263272 next_map_size=34 next_backup_map_start=589782
    zone_first=589824 zone_last=138215423 zone_size=137625600 min(chunk)=20480
    free=134225920 checksum=3da83da4 logstamp=8681175 num_bitmap=14
    Z2: type=1
    map_start=263272 map_size=34 backup_map_start=589782
    next_map_start=138219520 next_map_size=1 next_backup_map_start=138809343
    zone_first=263306 zone_last=589777 zone_size=326472 min(chunk)=8
    free=227056 checksum=bb089678 logstamp=8681169 num_bitmap=17
    Z3: type=0
    map_start=138219520 map_size=1 backup_map_start=138809343
    next_map_start=138481665 next_map_size=10 next_backup_map_start=138809333
    zone_first=138219521 zone_last=138481664 zone_size=262144 min(chunk)=262144
    free=262144 checksum=fe815561 logstamp=8681169 num_bitmap=1
    Z4: type=2
    map_start=138481665 map_size=10 backup_map_start=138809333
    next_map_start=138481675 next_map_size=34 next_backup_map_start=138809299
    zone_first=138809344 zone_last=310718463 zone_size=171909120 min(chunk)=20480
    free=170352640 checksum=b6e82ca1 logstamp=8681175 num_bitmap=15
    Z5: type=1
    map_start=138481675 map_size=34 backup_map_start=138809299
    next_map_start=310728704 next_map_size=131 next_backup_map_start=310730621
    zone_first=138481709 zone_last=138809292 zone_size=327584 min(chunk)=8
    free=320112 checksum=e75e639c logstamp=8681169 num_bitmap=17
    Z6: type=2
    map_start=310728704 map_size=131 backup_map_start=310730621
    next_map_start=0 next_map_size=0 next_backup_map_start=0
    zone_first=310730752 zone_last=3905175551 zone_size=3594444800 min(chunk)=20480
    free=3594280960 checksum=e674ed20 logstamp=8681169 num_bitmap=19

    Partition Maps
    #: type name length base ( size )
    1 Apple_partition_map Apple 63@1 ( 31.5K)
    2 Image Bootstrap 1 1@309550766 ( 512.0 )
    3 Image Kernel 1 8192@309550767 ( 4.0M)
    4 Ext2 Root 1 524288@309558959 ( 256.0M)
    5 Image Bootstrap 2 1@310083247 ( 512.0 )
    6 Image Kernel 2 8192@310083248 ( 4.0M)
    7 Ext2 Root 2 524288@310091440 ( 256.0M)
    8 Swap Linux swap 262144@310615728 ( 128.0M)
    9 Ext2 /var 524288@310877872 ( 256.0M)
    10 MFS MFS application region 589824@311402160 ( 288.0M)
    11 MFS MFS media region 137630712@171920054 ( 65.6G)
    12 MFS MFS application region 2 589824@311991984 ( 288.0M)
    13 MFS MFS media region 2 171919990@64 ( 82.0G)
    14 MFS MFS App by Winmfs 2048@312581808 ( 1.0M)
    15 MFS MFS Media by Winmfs 3594444800@312583856 ( 1.7T)

    Total SA SD Hours: 2083 Total DTV SD Hours: 1818 100 % Free
    Software: 11.0k-01-2-652 Tivo Model: TCD652160
  7. Aug 9, 2012 #7 of 29

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    It may be choking on the size of partition 15.

    But here's something you can try.

    No guarantees.

    Using that same 652_gset.tbk file, use WinMFS to restore it to the 2TB drive.

    It'll overwrite what's on there now.

    Just restore, do not expand.

    That should put 13 partitions on there, plus a 14th "Apple Free" partition.

    You should get a dialog box that offers something about whether you want the advanced partition layout or not.

    I forget how it's worded so accept the option that does give you the advanced layout (it might be the default).

    In that same box, there will be something about the swap partition size.

    Let's go ahead and waste an entire 15 minutes of video worth of space on it, just to be on the safe side.

    Enter 1000 or 1024, your choice.

    When it finishes, your partition map should say that partition 8 is 1GB or 1000MB in size.

    And don't bother with supersizing at this time.

    When it finishes, click on mfsinfo, and you should have a big Apple Free partition (#14) on the end.

    Take it out, see if it'll work in the TiVo.

    If it does, let it contact the TiVo servers and update the software version.

    You want 11.0.k

    You'll have to go through Guided Setup again and let it reboot a lot, and somewhere in that process it should update the software.

    It might take a day or 3.

    When that's taken care of and the dust has settled and the drive is working properly (if it is, we still don't know if that model is compatible or not), then you can use WinMFS and click on mfsadd to see if it'll let you use the rest of the drive without having to do any special tricks.

    Report back.

    I'm basing this on something a guy did with an original S3, which wasn't supposed to be able to use a 2TB drive under any circumstances, but apparently with the latest version of the software it can.
  8. Aug 9, 2012 #8 of 29

    sAe23 New Member

    Aug 8, 2012
    I re-did the restore as per your directions.
    The MFS info looks like you described.

    Tivo still reboots endlessly after finishing the guided setup.

    I am in the process of freeing up a 1TB drive (don't know make/model yet as it's inside an external case).

    Meanwhile, I found an MFS file for a 648250B.
    Would this work for an HD?
    Also, a friend has the image file from an instantcake CD for an HD.
    Would I need to boot linux and type arcane magic to use it? <g>

    Regardless, I'll wait and see if the 1TB drive works before trying the other files.

  9. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    That Hitachi goes all the way through GS?

    But then gives trouble?

    Anyway you need a TCD652160 image for a TCD6521260.

    Go here:


    Further re-reading shows you already did but I'll leave that link there anyway.

    Just for grins, run WinMFS on it again and select fix boot or boot fix or whatever it's called, it'll present you with option 1 and option 2.

    You're already set at what option 1 would do for you, so choose option 2 and then put it back in the TiVo and try again.

    According to the Hitachi spec sheet this thing uses the old non-advanced format 512 bytes per sector, or at least that's what it tells whatever's talking to it, so that part shouldn't be a problem.

    Go here:


    and download the cd image for the

    Drive Fitness Test

    and the one for the

    Feature Tool

    just in case you wind up needing either one.

    I looked to see if you needed to jumper it down from 6Gb/s to 3, or 1.5, but apparently that model is supposed to autonegotiate and any jumper block it has is for a different purpose.

    As for that 1TB drive, if we're going to just use it as a middleman on the way to 2TB, you can leave it in the enclosure and not worry about what brand or model it is because it'll never actually go into the TiVo.

    Here's the middleman technique.

    Although I recommend that you go to mfslive.org and download the image for the MFS Live cd v1.4 and burn yourself a copy as an image onto a cd-r just to have it handy even if you don't own a TiVo, for this we're going to use WinMFS, because it doesn't seem to leave a small Apple Free partition the way MFS Live sometimes does, and that Apple Free partition, no matter how small, screws up what the jmfs 1.04 cd does.

    So, restore the image to the 1TB using WinMFS, accepting the advanced partition layout and setting the swap partition size to 1GB (1000 or 1024, your choice, in the dialog box).

    If it offers to expand when it finishes, let it.

    Otherwise you can run mfsadd afterwards.

    Check the partition map via mfsinfo, and make sure you only have a total of 15 partitions, and that 10-15 are MFS pairs.

    Then get out of Windows, hook up both the 1TB and the 2TB (and if you have to unhook the Windows drive temporarily, that's not a problem at all if it isn't a GigaByte brand motherboard).

    Then boot from the jmfs cd, and tell it to copy the 1TB to the 2TB, and be sure you know which drive is which and only specify the right ones.

    When it finishes the copy, tell it to expand the 2TB.

    That should do it.

    Stick it in the TiVo which you're sure has no power supply problems, and boot it up and see if that model Hitachi works in TiVos.
  10. sAe23

    sAe23 New Member

    Aug 8, 2012
    I've decided that if the 1TB drive works, it will stay in the TIVO and the 2TB drive will go into the external case or my readyNAS.
    I just have to wait for the 500+ gigs of data to move off of the 1TB before I can start (it's down to 300 gig to go and 18+ hours in Windoze time).

    Frustratingly enough, I tried to do the "fix boot" option but for some reason WinMFS no longer sees the drive. Once the data copies off the 1TB I'll reboot the PC and try again.

    This is all cutting it very close as TWC is supposed to be here between noon and 2pm to deal with the cable cards... Had to wait 4 days for this appointment, don't want to have to wait another week :(
  11. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    Good luck!
  12. sAe23

    sAe23 New Member

    Aug 8, 2012

    I got the 1TB drive (samsung hd103uj) to work, but only after using the MFSlive boot CD. WinMFS kept giving me inode errors. I tested the drive with the samsung app and it passed smart and short tests.

    I have had one spontaneous reboot so far :(
    (Was changing channels to a time-sliced channel and while it was trying to acquire it, poof! Reboot!)
    I plan on retesting the drive using the kickstart code to see if it passes.

    I created a 512m swap and did not do anything to expand the capacity of the drive.
    How many hours would I gain ??

    I hindsight, I should have tested the 2TB drive with the live cd, if only to report the results here but it's serving a higher purpose now ;)
    Thanks for providing all of the helpful info!
  13. sAe23

    sAe23 New Member

    Aug 8, 2012
    So, the 1TB drive gave up the ghost :(
    (Hope it's OK to update an old thread...)
    Are the WD AV drives the ONLY 2TB drives that work?
    What about non AV WD drives, or any other brand?
    Is there a way to determine what Tivo update I'm on if I can't get to the UI?
    (I was getting symptoms that the drive might be on it's way out, but the "death" came when the summer update tried to load.)
    Should I upgrade to the latest MFSLive or is the CD I made two years ago still valid?

  14. HomieG

    HomieG Nowhere Man...

    Feb 17, 2003
    Are the WD AV drives the ONLY 2TB drives that work? - According to what I've read, other drives work as well. I just ordered this drive for $69 plus tax, free shipping, for my S3 OLED. Supposedly has the WD20EZRX drive in the box, which was listed as working for the Series 3 units in another thread.


    What about non AV WD drives, or any other brand? - See above. I think others have had success with Seagate, Toshiba and Hitachi drives. Personally I went with the WD drive note above based on excellent overall reviews.

    Is there a way to determine what Tivo update I'm on if I can't get to the UI? - Can't answer specifically, but I believe if you don't install v11.0k or later from an image, then you won't get the full 2TB if that's the size drive you upgrade to.

    Should I upgrade to the latest MFSLive or is the CD I made two years ago still valid? - I did this recently to a 1TB. Drive. When I was done, I had an old version running on my S3 when I put the good 1TB drive back in the TiVo. it updated to the current version after a couple of days connected back to the TiVo service. Then I made a truncated backup of that which I plan on installing on my 2TB drive when it arrived. For grins I also put my original 250GB drive back in the TiVo and it too, after a couple of days connected to the TiVo services, updated to the latest TiVo version.

    Hope this helps, and hope I got it correct!
  15. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC
    The WD20EURS and WD20EURX are known to work, have a 3 year warranty, and are usually available from newegg or Amazon for under $100 with free shipping.

    The only reason I can think of to use something else is if you already have it or can get it at a much better price.

    But you'd need to find someone else who had success with the same drive to know for sure it would work.

    A 5400RPM drive will work just as well, and as quickly, in a TiVo as a 7200PRM drive, so the extra RPM just means extra heat and power consumption, and the S3 HD is going to talk to the drive at SATA I speed (1.5Gb/s) and not SATA II or III, so there's nothing to be gained there, either.

    The most recent version of the MFS Live cd is v1.4, and that's likely what you have if you got the latest image anywhere in the last 2 or 3 years.


    and the latest WinMFS is here:


    and instructions are here:


    Here are images of the latest version of the 652 software:

    MFS Live version:


    WinMFS version:


    With either, do not do the expansion as part of the restoration.

    Do it later as a separate process using


    When not done separately, sometimes it appears to have worked, but didn't.

    If using MFS Live, instead of adding the options


    on the command line, just use


    My personal preference, just to be on the safe side, is to use a 1000MB swap partition on a 2TB drive, so that would be

    -s 1000

    I don't know whether or not MFS Live will let you make a partition larger than 1.2TB when time comes to do the expansion, but WinMFS will. It'll ask you if you're sure, but it'll do it.

    I've pretty much switched over to using WinMFS for everything except making .bak backup images.
  16. unitron

    unitron Active Member

    Apr 28, 2006
    semi-coastal NC

    That would be a good price on that drive if there were a Fry's nearby, since it's available in-store only, but the picture they use and their description of it as a Caviar Blue are incorrect if it's actually the EXRX, which is a "green" and I don't know if it would be necessary to use


    to disable Intellipark (which causes TiVos to hang when warm booting), or not, but the only way to find out would probably be to run it to see whether it's enabled or not.
  17. HomieG

    HomieG Nowhere Man...

    Feb 17, 2003
    The Frys WD 2TB hard drive intermittently shows available with free Ulta Saver shipping. Just need to keep checking back at that link. Hth.

    I plan on running wdidle3 when it arrives.
  18. HerronScott

    HerronScott Well-Known Member

    Jan 1, 2002
    Staunton, VA
    $89.99 for the WD20EURX right now from Amazon or Newegg. Since I'm running low on space with my 6 year old 1TB drives, I think I'm going to take the plunge and upgrade both S3 OLED's to 2TB.

  19. sAe23

    sAe23 New Member

    Aug 8, 2012
    Can you link that thread?
    I went to frys and got a EZRX drive.
    I used WINmfs to create the drive, doing the ADD after the restore, and I supersized it.
    I've made it through guided setup ONCE.
    Then after doing the clear/delete it will hang in guided setup, usually while confirming what station is on which channel.
    It is still doing this after redoing the restore without adding or supersizing (but each time I have told it to make a 1Gb swap).

    Now I'm trying the MFSLive CD, and the dang this won't boot past some section listing various input ports. The prompt is "[mfslive:/]" and nothing I type makes it continue :(

    Anyone have experience with mfslive?
    Should I try Winmfs again, with the default swap size?
    Is it possible not ALL Tivos like 2 TB drives??


    EDIT: Is it possible I'm just dumb and it FINISHED booting and is waiting for commands? DOH!
  20. HomieG

    HomieG Nowhere Man...

    Feb 17, 2003
    I'm confused...are you up and running?

    If not, did you run wdidle3.exe on the drive first to check the drive idle timer and modify if needed? What TiVo software version did you put on the new drive and are you sure it's of your exact model?

    Others have used the EZRX on S3 units. A few comments on this page:

Share This Page