1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Downloading from Roamio to iPad fails

Discussion in 'TiVo Roamio DVRs' started by GotATiVoToo, Jun 26, 2014.

  1. GotATiVoToo

    GotATiVoToo New Member

    37
    0
    Apr 20, 2002
    Northern...
    Greetings,

    I recently replaced my Premiere XL4 with a Roamio Pro. I wanted to copy a bunch of recorded shows from the Roamio onto my iPad Mini Retina, and the behavior has been very flaky. Here's what I've seen.

    I was at home, on my local Wi-Fi network with the iPad. The TiVo is connected to gigabit Ethernet. My router/WAP is the latest-generation Apple AirPort Extreme. AirPort and iPad are fully updated.

    I chose about 10 shows to copy over. I chose "Best" quality for all of these. (Aside: why do I have to make this choice every time? I never want medium.)

    The estimate was that it would take roughly 30 minutes for the first show to download, so I left the iPad awake and plugged in to power when I went to sleep.

    When I got up the next morning, it had not downloaded a single show! There was a message saying that the TiVo (not the iPad) had lost connection to the Internet. Who cares about the Internet? This was a copy over the LAN. It had made progress on one show, but had apparently bailed due to the connection problem.

    I quit the iPad app (dragged it out of the app switching view to force a true restart), then resumed the downloads. I left for work. Again, the iPad was plugged in to power and awake.

    Got home, and a couple of shows had downloaded, but it had failed again. Two shows were marked as having failed, and I guess at that point it gave up, and the iPad went to sleep.

    Upon waking the app up again, I noticed that the remote control icon at the top of the screen was greyed out, the way it would be if you were outside of your house and therefore unable to control the TiVo's on-screen display. I force-quit and relaunched the app, and this time the remote showed up as active again.

    I resumed the downloads once again.

    Some time later, I came back to find the iPad asleep again. All but two of the downloads had finished, but it was again showing the crossed-out remote as though it thought it was not at my house.

    So, I did the force-quit dance again, and the remaining shows downloaded.

    This is a really crappy experience. With my Premiere and the separate Stream box, I did similar downloads to the iPad on several occasions, and it was always reliable. I searched the forums and found a few reports of problems with the Roamio in this regard, but they seem isolated.

    Have others had this problem? Were you able to find a solution? Why does the iPad app keep thinking that it is not on my LAN, and disabling the controls? The iPad was only about 15 feet from the access point with strong signal, etc...

    Thanks!
     
  2. tasi

    tasi TiVoing since 2000

    20
    0
    May 10, 2002
    SF/Bay Area...
    Yes, have always had this problem, downloading is a terrible experience. Streaming works for the most part, but downloading for later viewing, even in the lowest quality setting is a miserable experience.

    It fails, doesn't retry, and then when you finally do get the entire show downloaded (by manually retrying), you end up with only half the show and errors playing it back.

    I hope TiVo fixes this or we can find a workaround.
     
  3. jenz

    jenz New Member

    43
    0
    Sep 19, 2009
    my solution, works every time plug your ipad into power and change settings to never sleep/lock, all your shows should dl then, far from ideal but works
     
  4. moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Just another data point. Getting ready to go on a trip, so setup iOS app to download 10 shows @medium quality to my iPad Air last night while it was plugged in. This morning the iPad was off and all 10 shows properly downloaded as expected. So at least for me this seems to be working OK. (I've downloaded individual shows before but never tried queuing up a whole bunch of downloads at once).
     
  5. berkshires

    berkshires New Member

    463
    0
    Feb 22, 2007
    I'm experiencing the same problems with a premiere...will try the never sleep suggestion.
     
  6. nycityuser

    nycityuser Member

    269
    0
    Dec 30, 2004
    New York, NY
    I experience the same problem as the OP whenever I queue several shows to download. Very annoying. If I download one or two shows at a time it seems to work fine.

    I'll try the never sleep/lock solution as well.

    I had another issue in April. I was away from home for 3 weeks. Every few days the TiVo app would lose connection to home base and I'd have to re-establish everything. That worked until my last day away when no amount of tinkering would allow me to connect. When I got home I thought I'd have to restart my Roamio Pro to get a connection but I did not have to - everything worked fine. Does anyone know what I could have done on that last day away? Or was the TiVo app just homesick and rebelling? :)
     

Share This Page