1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Does Premier XL have less re-boot issues than the Elite/XL4?

Discussion in 'TiVo Premiere DVRs' started by joe1515, Jun 5, 2012.

  1. Jun 5, 2012 #1 of 13
    joe1515

    joe1515 New Member

    38
    0
    Jul 21, 2009
    Bayport, NY
    Are the premier XL's just as succeptable to the re-boot problem as the Elite/XL4?

    I need to upgrade my HD unit which just died, the power won't turn on. I wanted to get another premier or elite. So this a good time. I am just concerned about the issues I keep reading about Elite/XL4 units.

    Am I way off base thinking the premier XL is more stable than the Elite/XL4?

    Thanks
    Joe
     
  2. Jun 5, 2012 #2 of 13
    dianebrat

    dianebrat I refuse to accept your reality TCF Club

    10,114
    73
    Jul 6, 2002
    boston'ish
    My Premiere XL was a flaky beast with reboot problems, my Elite has never rebooted unless requested, in fact my Elite has been the most reliable and best performing Tivo I have had since I came to the flock in 2000
     
  3. Jun 5, 2012 #3 of 13
    UCLABB

    UCLABB Active Member

    1,122
    8
    May 29, 2012
    Riverside, CA
    You know it would be helpful if people that respond provide some info on their set up. In reading about this issue it seems that the tuning adapter seems to be in the mix and a system like FIOS without an adapter seems to be problem free. So it would helpful if people indicated the system and whether they have a tuning adapter.

     
  4. Jun 5, 2012 #4 of 13
    DeWitt

    DeWitt New Member

    424
    0
    Jun 30, 2004
    Summit, NJ
    My Fios based (No adapter) Premeire XL has been problem free. All HDMI connections for output. It was a significant improvement in stability over the HD it replaced.
     
  5. Jun 6, 2012 #5 of 13
    lessd

    lessd Active Member

    7,695
    5
    Jan 23, 2005
    CT
    My Comcast connected TPXL has also been problem free and i have a 2Tb drive upgrade installed. I should note that I only use the SDUI and that may make a difference in anybody's re-boot problems. (no tuneing adapter)
     
  6. Jun 6, 2012 #6 of 13
    joe1515

    joe1515 New Member

    38
    0
    Jul 21, 2009
    Bayport, NY
    I am running Fios with no adapter and I do not use any of the online or streaming features I have a Roku for Netflix, HBO Go, etc...

    Thank for the replies. Keep them coming.

    Joe
     
  7. Jun 6, 2012 #7 of 13
    Ed_Hunt

    Ed_Hunt Pokerpro

    249
    0
    Jan 2, 2004
    Patterson,...
    I have two Premiers using Comcast (for another month) and over the air. Never had a reboot with either.
     
  8. Jun 6, 2012 #8 of 13
    DonaldBurns65144

    DonaldBurns65144 New Member

    123
    0
    Jan 10, 2011
    USA
    Our FIOS connected TPXL has had very few reboots over the 18 mts (more or less) that we've owned it.
     
  9. Jun 6, 2012 #9 of 13
    stlbluesfan74

    stlbluesfan74 Mike

    50
    0
    May 2, 2012
    St. Louis
    I have two Premiere XLs with Charter cable and a tuning adapater. So far no reboots. However I've only had them for a couple of months.
     
  10. jaredmwright

    jaredmwright New Member

    215
    0
    Sep 5, 2004
    Bay Area
    I have two TiVo Premiere units, one upgrade to 1TB and the other upgraded to 2TB drives with M-cards on Comcast in the Bay Area with no SVD. I have had zero problems with either one. I received the first Premiere right when they came out and the second about 9 months ago. No complaints here.

    I just purchased a TiVo XL4 (Elite) this weekend on sale; couldn't resist.

    I also have two TiVo HDs and previously had a Series3. When I did have problems in the past, one ended up being RMA'd and that fixed the flaky issues. The others have all been rock solid. I haven't owned a TiVo that I didn't uprade the hard disk in, maybe that helps in some way? I do know I have had low signal which caused problems like pixelation and hanging that appeared TiVo related, but ultimately weren't. I agree with others, have your signals checked and make sure they are clean across the range.

    I will be selling my two Tivo Lifetime Series3 HDs (500GB and 1TB upgraded drives) now and going all in on Premiere and hoping the streaming box works out.
     
  11. dcstager

    dcstager 1st Gen Tivo Owner

    573
    2
    Feb 16, 2002
    Skagit...
    Is anyone getting Elite reboots who does not have MoCA internet connection? Mine reboots when you change or add or backup season passes at the Tivo.com site, and I'm thinking it is Internet related. I've had two spontaneous reboots while just watching something too and don't know what kind of background activitiy might have been going on.
     
  12. atmuscarella

    atmuscarella Active Member

    5,710
    11
    Oct 11, 2005
    Rochester NY
    No rebooting issues with my Premiere. 2TB upgrade drive used for OTA only, connected via Frontier DSL, using HD UI, auto download many pod casts, use Pandora allot, YouTube a little but not Netflix or Hulu+.
     
  13. brianfuchs

    brianfuchs New Member

    83
    0
    Apr 24, 2003
    I had 3XLs and an Elite. FiOS. Not a single problem with any of the XLs, but the Elite was a nightmare. Pixellation, reboots, freezing, constant complaining about signal strength. I returned the Elite at 29 days and bought a 4th XL.

    3 months later, and not a single spurious reboot on any of the XLs. I have had a freeze happen 4 times in that period of time, across 3 different machines. I'll live with that until the fix all of the problems that Elite has.
     

Share This Page