1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Disable Wireless?

Discussion in 'TiVo Roamio DVRs' started by rgr, Feb 15, 2014.

  1. rgr

    rgr Member

    582
    6
    Feb 21, 2003
    Just noticed that my roamio is using two ip addresses on my router. Since I have it hardwired and do not use the streaming feature (nor can I until TiVo gets their act together and produces an android app), I can only surmise that the second ip is being grabbed by the wireless adapter.

    Is there any way to disable the wireless adapter? Or at least make it unreachable by potentially malicious folks in the area? Any security settings?

    And how is it grabbing an ip address off of my router, which I have setup with wpa2/aes security and a hidden ssid?
     
  2. moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Roamio Plus or Pro take a 2nd IP for the built in Stream.
     
  3. rgr

    rgr Member

    582
    6
    Feb 21, 2003
    Any way to disable stream? Or at a minimum change the ip address so it's assigned, rather than grab one from dhcp? I can't find anything regarding stream setup in the settings.

    Thanks
     
  4. moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    Nope, TiVo didn't provide any way to disable or provide static IP for the Stream. Standalone Stream also doesn't have any way to manually assign static IP.
     
  5. rgr

    rgr Member

    582
    6
    Feb 21, 2003
    Well at least I now know I'm not missing something or going crazy.

    Thanks for the info. Now if only TiVo would allow for such setup or enable/disable.
     
  6. jcthorne

    jcthorne Active Member

    2,721
    3
    Jan 28, 2002
    Houston
    You can configure your router to assign a specific IP address to the MAC address of the stream. Effectively makes it a static route.
     
  7. HDRyder9

    HDRyder9 Member

    196
    0
    Aug 2, 2007
    Many routers have the ability to force specific IP addresses to various devices based on MAC address. That's how I handled the two IP addresses in my Roamio.
     
  8. rgr

    rgr Member

    582
    6
    Feb 21, 2003
    Thanks. Hadn't thought to handle it on that side, and it worked fine.

    Still seems odd that TiVo provided zero setup options for Stream. Not everybody uses it, so why leave it on?
     
  9. moyekj

    moyekj Well-Known Member

    11,142
    31
    Jan 23, 2006
    Mission...
    They don't provide an off switch for wireless either. If you use setup wireless and then later connect ethernet, your router still shows wireless connection as active. I tried wireless briefly just as part of testing things out. I had to resort to connecting to a neighbor's SSID with wrong password to get it off my wireless network which shows it's still active when ethernet is being used.
    One poster resorted to disconnecting the wireless chip from the MB.
     
  10. arthuryang42

    arthuryang42 New Member

    5
    0
    Jan 3, 2005
    Moyekj -- I had the exact same setup as you did. Out of the box I tried wireless, and later decided to go wired and got the C133 error all the time. Many times it would resolve itself after a minute or three, but it was still incredibly frustrating.

    I tried your workaround by intentionally attaching to a neighbor's network (with an incorrect password) and it gave me an error (understandably). So I then left that menu and confirmed that my hardwired network connection was still working correctly -- and ever since I've had NO problems.

    Thanks for the advice!!
     

Share This Page