1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Comcast On-Demand Problems

Discussion in 'TiVo Premiere DVRs' started by UpAndDown, Oct 8, 2012.

  1. Oct 8, 2012 #1 of 18
    UpAndDown

    UpAndDown New Member

    17
    0
    Aug 16, 2012
    I have a Premier 4 that is a few weeks old and I have just now started to really get the time to watch some shows from Comcast On Demand. The problem is, about 80% of the time, I get some sort of error saying to try again or contact Comcast and I cannot access the show that I am trying to watch even though it is from a channel that I have access to. There is no consistency as to specific channels or shows. Usually it does not work but sometimes it does. Naturally, I contacted Comcast about his three times and all 3 times I was given the run around and told that the M card is provisioned correctly and that it must be a problem with the TiVo. If anyone has any information on this issue, or has had a similar problem and found a solution, please post back. I remember reading a thread a while back about people having their On Demand not work at all and a Comcast rep here on the forum fixing the issue, but I cannot find the thread and my issue isn't the same as it works sporadically.
     
  2. Oct 9, 2012 #2 of 18
    button1066

    button1066 New Member

    140
    0
    Sep 4, 2012
    I'm in Colorado and the on demand stopped working for me a while ago. It's not a good implementation even when it is working anyway.
     
  3. UpAndDown

    UpAndDown New Member

    17
    0
    Aug 16, 2012
    An update to my original post. After calling Comcast 3 times and spending way too much time on the phone only to have them send refresh signals over and over again with no solution, what I have discovered on my own is that On Demand actually is working, but the TiVo interface is not. Here is what is going on. If I do a search for a show or an actor through TiVo and try to play it On Demand right through the search results, it will not work and I will get the ERR-2 or CL-14 or some other error. However, if I manually go into On Demand through the TiVo Xfinity app through the icon on my TiVo, and locate that exact same show through that route, it will play fine. I tried this with many different shows last night including S1 E1 of Dexter, S1 E1 of Homeland, and some episodes of Weeds. Can someone please do me a favor and do a search for any of these shows through TiVo directly and see if you are able to play them, in HD, directly from the search results under "episodes"? It will be much appreciated. Do you think that this is a TiVo problem or a Comcast problem? Would swapping out my Cable Card for a new one possibly fix this issue? Thanks in advance for any help and any replies.
     
  4. UpAndDown

    UpAndDown New Member

    17
    0
    Aug 16, 2012
    If I could get a few people with Comcast/Xfinity On Demand to try this on their TiVo Premiere I would very much appreciate it. I am on my last day now of my 30 day trial period and I would like to know if this is an issue with my particular TiVo, the Premier 4 in general, TiVo itself, or Comcast/Xfinity so that I can do what I have to do while my options are still available to me. Any and all help is requested and appreciated. Thank you in advance.
     
  5. UpAndDown

    UpAndDown New Member

    17
    0
    Aug 16, 2012
    Bumping this up for some help...please!
     
  6. seakurt

    seakurt New Member

    13
    0
    Aug 4, 2007
    Seattle, WA
    Just noticed yesterday the Xfinity menu option so gave it a spin. Not sure how long it's been there. So far it's been a bust. I can navigate through all the menus fine but every show I tried to play (about 6) the first few seconds would play and then the video would freeze. Oddly, the counter at the bottom continues to show progress, but the video never moves again. FF or Reverse has no effect. Going out, coming back in no effect. I didn't get the typical notice from TiVo that it was available, just saw the Xfinity icon, so maybe it's not "really" available in Seattle yet.

    Premier Elite model.
     
  7. Chris Grant

    Chris Grant New Member

    18
    0
    Oct 3, 2001
    Bellevue, WA
    I had the exact same symptoms as Seakurt. I have two premieres and the behavior was the same. The problem is that Comcast needs to set a flag in your cable card(s) to make it work. I just got off the phone with them and after hitting my cards with the update...it works!

    So make your phone call and enjoy! :up:
     
  8. Robert2413

    Robert2413 New Member

    18
    0
    Feb 1, 2008
    I had the "Comcast on-demand plays for one second and then freezes" problem. Had both a tech and a supervisor at my house trying to resolve the problem. No amount of resetting or reprovisioning from the headend made any difference. Solving the problem finally required swapping out the cablecard.
     
  9. morac

    morac Cat God

    8,948
    22
    Mar 14, 2003
    NJ
    On Demand showed up for me on Friday in NJ. From my limited testing of it, it works fine. I searched for a program and played it and it worked fine. I also played a few programs from the On Demand menu itself.

    I've seen some minor glitches such as CC toggling not always working and skip to end getting stuck, but haven't had any playback problems as of yet.

    It might depend on what show you are searching for though. I've seen search problems with Amazon and Netflix for some shows, so it wouldn't surprise me that there would be some for Comcast On Demand.
     
  10. qaseattle

    qaseattle New Member

    2
    0
    Dec 27, 2012
    I'm having the same problem. Hours on the phone with comcast tech support, more hours with an in person tech. Told them that the online forums indicate that a code is needed to allow the cable card to access VOD. This was supposedly done as part of the in person visit but no luck. I have also restarted multiple times, followed all the instructions from the TIVO support page on this topic, and sent in the form with the cable card information to TIVO. The comcast tech said they have received no training at all on this and so are not able to troubleshoot problems.
     
  11. morac

    morac Cat God

    8,948
    22
    Mar 14, 2003
    NJ
    Any (billing) codes would need to be by a phone support person. A tech at your house can't input the code, so unless he called someone nothing he did would help.
     
  12. qaseattle

    qaseattle New Member

    2
    0
    Dec 27, 2012
    Yes, sorry. He did a number of checks then called in to have the code input.
     
  13. Ted19111

    Ted19111 New Member

    2
    0
    Oct 5, 2007
    I had the same problem with Comcast Xfinity on Demand freezing on my Tivo Premiere 4 after 1-2 seconds yesterday. This was the first time I had tried Xfinity on Demand. The fix was someone in Comcast Billing department needed to add the Tivo Premiere 4 billing code for Xfinity on Demand to my Comcast account.

    I spoke to 1-800-COMCAST on three different calls last night and each said your codes look fine and they sent signals to the TiVo box, etc. and nothing worked. I finally decided to call the Comcast cable card dept phone number and the guy there knew exactly what was needed and he transferred me to the Billing dept and the guy in Billing added the code to my Comcast account and Xfinity on Demand programs instantly played wonderfully.
     
  14. justincmarks

    justincmarks New Member

    1
    0
    Jan 9, 2012
    I just got this done by Xfinity customer care. It's called "Tivo Premier" and it's under the Bolt-On Section, not in the standard cable card section
     
  15. jakiah

    jakiah New Member

    1
    0
    Feb 26, 2013
    When I called, the lady no idea what the bolt on section was. Instead saying I already had all the correct billing codes for TiVo service. She would have to send a tech out. After pleading with her to check with someone else she came back and said she found it... Works now.
     
  16. annatmc

    annatmc New Member

    1
    0
    Aug 25, 2013
    I too have called Comcast several times and never been able to get any Xfinity on-Demand program to work for more than 2 seconds without freezing. They sent the signals to my cards, added the on-demand codes and wanted to send a tech too. I called again just now and read the solution of adding the code to the billing and it worked in seconds. I had a tech that was going to try that anyway and seemed knowledgeable. But others are not, they needed to add a code that lets them know you are using a premiere. I asked him to educate the other techs I spoke to. But thanks for your posts. It was literally a 2 minute call and it worked...unheard of with Comcast.
     
  17. sieglinde

    sieglinde New Member

    5,375
    0
    Aug 11, 2002
    Sebastopol, CA
    I have had good luck. Sometimes they have had to reset something but it eventually works.
     
  18. u1drwhy

    u1drwhy New Member

    5
    0
    Jul 7, 2014
    Hey y'all: search the forums for my post: " Xfinity On Demand: GSM-11 and CL-14 Service Errors ", see if this answers your question.
     

Share This Page