1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Capturing Slingbox 350/500 video

Discussion in 'TiVo Coffee House - TiVo Discussion' started by moyekj, May 25, 2013.

  1. Dec 1, 2013 #101 of 155
    dbtom

    dbtom Member

    165
    0
    Feb 14, 2002
    New York City
    Thanks for this awesome program! It works so well I just bought a 350 to replace my Solo.

    Does anyone have a recommendation for a good way to split the video files? I'd like to queue up a bunch of videos on my Tivo. I'd then have one big video file that I'd like to split into 30 minute or 1 hour chunks. Any suggestions would be greatly appreciated.

    I've been processing the .ts files using handbrake to put on my iPad after downloading. I have VideoRedo but not the newest version.
     
  2. Dec 1, 2013 #102 of 155
    Kamakzie

    Kamakzie Are you serious bro?

    4,998
    0
    Jan 7, 2004
    MI
    Hey guys, just discovered kmttg with my Sling 350. Works great. However under video resolutions I have 1920x1080 or 640x480. Is there anyway to add 1280x720? Thanks!
     
  3. mikez104

    mikez104 New Member

    1
    0
    Jan 17, 2014
    Hi. I'm trying to use this but am getting a error when trying to run the script. Can someone point me in the right direction? Thanks
    C:\>perl -w rec350b.pl
    cmd: 103 err: 2 8 at rec350b.pl line 43.
     
  4. dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    Moyekj,
    I'm trying out the new slingbox mkv capture feature(v1p0l), and it appears to be building the mkv stream with a listed framerate of 1000. This is causing errors in VideoReDo(TVSuite x264 v 4.21.6.674) even when I have VRD's x264 config set to read the frame rate from the stream rather than container/auto. The current fix is to run the mkv through mkvMerge and manually set the framerate just like it's necessary to do when using the MPEGTS container option on the slingbox tab. Is there a reason the mkv container is setting the framerate so high?

    I don't think it saves any steps over the mpegts option at this point without a valid frame rate value, unless I'm missing something. Is there even a constant frame rate possible from the SlingBox (I have a Pro-HD)?

    Other than that, I can capture video just fine, run it through MkvMerge, and edit/encode in VRD. This is fantastic, and I feel guilty asking for even more. However, do you think it's possible to add an automatic encode step after Slingbox capture using an existing kmttg encoding profile? I can't decide if it would add value to the tool or not, as there may be cropping/trimming necessary before encode. Just wondering if it's something you'd considered.
     
  5. dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    A weird problem started happening tonight, although it's been a few days since I've used the slingbox capture. I'm now getting the following error. Is it maybe something I've screwed up in config somewhere? The error line in the perl script is the unpack of the data header. Thanks for any help!

    Code:
    >> CAPTURING SLINGBOX TO f:\temp\sling\slingbox_2014_01_27_22_39_26.mkv ...
    "c:\Perl\bin\perl.exe" "C:\Documents and Settings\Compaq_Administrator\My Documents\Downloads\kmttg\slingbox\rec2.pl" -stdout -ip 192.168.15.254 -port 5001 -pass <removed> -vbw 4000 -vs 5 -dur 60.0 | "C:\Documents and Settings\Compaq_Administrator\My Documents\Downloads\kmttg\ffmpeg\ffmpeg.exe" -fflags +genpts -i - -vcodec copy -acodec ac3 -ab 224k -y -f matroska "f:\temp\sling\slingbox_2014_01_27_22_39_26.mkv"
    Capture to file failed: f:\temp\sling\slingbox_2014_01_27_22_39_26.mkv
    Exit code: 1
    ffmpeg version N-53033-g56ba331 Copyright (c) 2000-2013 the FFmpeg developers
      built on May 13 2013 22:18:29 with gcc 4.7.3 (GCC)
      configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
      libavutil      52. 31.100 / 52. 31.100
      libavcodec     55.  9.100 / 55.  9.100
      libavformat    55.  7.100 / 55.  7.100
      libavdevice    55.  0.100 / 55.  0.100
      libavfilter     3. 65.100 /  3. 65.100
      libswscale      2.  3.100 /  2.  3.100
      libswresample   0. 17.102 /  0. 17.102
      libpostproc    52.  3.100 / 52.  3.100
    Died at C:\Documents and Settings\Compaq_Administrator\My Documents\Downloads\kmttg\slingbox\rec2.pl line 80.
    pipe:: Invalid data found when processing input
    
     
  6. moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Power cycle the Slingbox?
     
  7. dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    Yeah. I tried that. I'm getting the same error when I run the perl script from DOS, so I'm sure it has nothing to do with kmttg. I'll need to look into wherever you got that script from for more details I think.


    Update: On a whim, I tried using Solo instead of the Pro-HD in the "Slingbox Model" option and it captures now, even though I'm connecting to a Pro-HD. It only captures at 640x480 even when I choose the 1920x1080 resolution option, but it's a start.

    Maybe something changed in the slingbox recently. It's running Firmware 2.1.420, released 10/29/1013, so not sure what might have done.
     
  8. moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    The resolution and bit rate selectors are only relevant for 350/500 models as indicated in tooltips.

    NOTE: In your kmttg installation if you rename rec2.pl to rec2.orig.pl and rec2a.pl to rec2.pl and then pick Slingbox Pro as model I suspect it will work as it was before. Let me know if that works. In recent kmttg releases I use rec2.pl for Pro models and rec2a.pl for Solo models. Perhaps what really needs to happen is to use rec2a.pl for both.
     
  9. dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    Works great, Thanks.

    Framerate of the mkv is still 1000, but I'm going to try to change the ffmpeg command built in slingbox.java to specify the framerate of 29.97 later and see if that doesn't break anything. I'll let you know how that goes.
     
  10. dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    Adding "-r 29.97" before the -f on line 159 of slingbox.java (ffmpeg command) did the trick. I can now open the .mkv file in VRD and save it directly without having to rebuild the stream in MKVTool first.

    I can't see that it had any effect on the MPEGTS output option, as the recorded .ts file still plays in VLC and I don't see the framerate set in it at all.
     
  11. moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    OK, latest changes to slingbox.java are all checked in including adding -r 29.97 to ffmpeg for non 350/500 models, so if you build kmttg.jar from source (and put rec2.pl and rec2a.pl back to how they were since now kmttg uses rec2a.pl for all models except 350/500) it should function properly for you now.
     
  12. dearing

    dearing New Member

    23
    0
    Jan 31, 2007
    What is the framerate for mkv video coming out of the 300/500 models, out of curiosity?
     
  13. moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Mediainfo shows 29.97 as framerate and VRD is able to edit my .mkv captures without needing to add -r 29.97 to ffmpeg command. Both VLC and VRD show 30.33 for some odd reason but otherwise seem to play it back fine. But given that discrepancy I decided it's best to add the -r 29.97 for 350/500 captures as well.
     
  14. ciarpame

    ciarpame New Member

    1
    0
    Feb 17, 2014
    Thank you for this thread! I decided to buy a refurbished slingbox solo and now I'm able to record the slingbox streaming using kmttg.
    Now I have a few questions for you.

    Even if the kmttg tooltip and in this forum it's stated otherwise, the bitrate control is working for Solo, file size changes when the bitrate is changed. I also tried to use bitrate lower that 4000 (by forcing a different birate directly in rec2a.pl) and it seems to me that a lower bitrate than can be used without visibile quality losses.
    I would like to know about you bitrate experiences, which value do you suggests for recording with Solo (it's limited to 640x480). It seems to me that 4000 or higher for a h264 codec at such resolution could be overkill but maybe I'm wrong.
    Also, anyone tried to change the smoothness in rec2a.pl to a value different from the default one?
    Is it possibile to have a different audio sampling rate and bitrate different from the default one (32000Hz at 224kbps)?

    I must confess I'm not a tivo user but an european mysky hd user even if it seems to me it does not matter to much to be a tivo user to post in this specific thread.

    Thank you again to moyekj and to script contributors.
     
  15. moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    You can capture the raw Slingbox feed and then use ffmpeg or similar to remux and/or transcode audio of that capture to your liking. The current remux + audio conversion to ac3 built into kmttg is hard coded with no user options other than mpegts or matroska container.
     
  16. Mar 3, 2014 #116 of 155
    hshsrva

    hshsrva New Member

    3
    0
    Mar 3, 2014
    when i am recording from slingbox 350 it suddenly stops. i may set it for 60 mins and it will stop. no error.


    >> CAPTURING SLINGBOX TO C:\Users\Brandin\videos\slingbox_2014_03_03_17_43_54.ts ...
    "C:\Perl64\bin\perl.exe" "C:\Users\Brandin\Downloads\kmttg_v1p0p\slingbox\rec350.pl" -stdout -ip 192.168.1.4 -port 5212 -pass Vp2Et85O7KuPTXR -vbw 4000 -vs 16 -dur 3900.0 | "C:\Users\Brandin\Downloads\kmttg_v1p0p\ffmpeg\ffmpeg.exe" -fflags +genpts -i - -vcodec copy -acodec ac3 -ab 224k -r 29.97 -y -f mpegts "C:\Users\Brandin\videos\slingbox_2014_03_03_17_43_54.ts"
    C:\Users\Brandin\videos\slingbox_2014_03_03_17_43_54.ts: size=4.88 MB elapsed=0:00:21
    ---DONE--- job=slingbox output=C:\Users\Brandin\videos\slingbox_2014_03_03_17_43_54.ts
     
  17. Mar 3, 2014 #117 of 155
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Next time you run via kmttg, double-click on the job in the job monitor table to see stdout/stderr messages and see if anything suspicious shows up there.
     
  18. Mar 4, 2014 #118 of 155
    hshsrva

    hshsrva New Member

    3
    0
    Mar 3, 2014
    frame= 1852 fps= 33 q=-1.0 size= 17900kB time=00:01:01.86 bitrate=2370.3kbits/s
    frame= 1870 fps= 33 q=-1.0 size= 18231kB time=00:01:02.48 bitrate=2390.1kbits/s
    frame= 1888 fps= 33 q=-1.0 size= 18566kB time=00:01:03.06 bitrate=2411.7kbits/s
    frame= 1908 fps= 33 q=-1.0 size= 18944kB time=00:01:03.73 bitrate=2434.9kbits/s
    frame= 1920 fps= 33 q=-1.0 size= 19169kB time=00:01:04.12 bitrate=2449.0kbits/s
    frame= 1938 fps= 33 q=-1.0 size= 19497kB time=00:01:04.74 bitrate=2466.9kbits/s
    frame= 1953 fps= 33 q=-1.0 size= 19784kB time=00:01:05.22 bitrate=2484.9kbits/s
    frame= 1970 fps= 33 q=-1.0 size= 20098kB time=00:01:05.80 bitrate=2502.1kbits/s
    frame= 1984 fps= 33 q=-1.0 size= 20368kB time=00:01:06.28 bitrate=2517.5kbits/s
    frame= 2002 fps= 33 q=-1.0 size= 20695kB time=00:01:06.85 bitrate=2535.7kbits/s

    00:01:06 pkts:6000frame= 2020 fps= 33 q=-1.0 size= 21028kB time=00:01:07.48 bitrate=2552.7kbits/s
    frame= 2035 fps= 33 q=-1.0 size= 21303kB time=00:01:07.96 bitrate=2567.9kbits/s
    frame= 2049 fps= 33 q=-1.0 size= 21574kB time=00:01:08.44 bitrate=2582.3kbits/s
    frame= 2067 fps= 33 q=-1.0 size= 21894kB time=00:01:09.01 bitrate=2598.8kbits/s
    frame= 2085 fps= 33 q=-1.0 size= 22243kB time=00:01:09.64 bitrate=2616.6kbits/s
    frame= 2102 fps= 33 q=-1.0 size= 22569kB time=00:01:10.21 bitrate=2633.0kbits/s
    frame= 2116 fps= 33 q=-1.0 size= 22813kB time=00:01:10.64 bitrate=2645.3kbits/s
    frame= 2131 fps= 33 q=-1.0 size= 23106kB time=00:01:11.17 bitrate=2659.4kbits/s
    frame= 2148 fps= 33 q=-1.0 size= 23427kB time=00:01:11.75 bitrate=2674.7kbits/s
    frame= 2163 fps= 33 q=-1.0 size= 23713kB time=00:01:12.23 bitrate=2689.4kbits/s
    ff asf bad header 30 at:21265131
    [asf @ 025a2860] invalid padsize 36469 at:21265133
    [asf @ 025a2860] ff asf bad header 0 at:21265141
    [asf @ 025a2860] packet_obj_size invalid
    [asf @ 025a2860] invalid packet_length 1138798642 at:21267751
    frame= 2167 fps= 32 q=-1.0 size= 23781kB time=00:01:12.37 bitrate=2691.7kbits/s
    frame= 2168 fps= 32 q=-1.0 Lsize= 23804kB time=00:01:12.38 bitrate=2694.1kbits/s

    video:19814kB audio:1979kB subtitle:0 global headers:0kB muxing overhead 9.224176%
     
  19. Mar 4, 2014 #119 of 155
    moyekj

    moyekj Well-Known Member

    11,151
    34
    Jan 23, 2006
    Mission...
    Try the "Capture raw file" option in kmttg which will bypass use of ffmpeg to see if it is the Sling capture that is causing capture to stop, or ffmpeg.
     
  20. HarperVision

    HarperVision TiVo's Italian Cuz!

    5,275
    3
    May 14, 2007
    Paradise...
    I keep getting this error when I try to capture from my remotely located (in PA) Pro-HD:


    Capture to file failed: D:\Recorded TV\slingbox_2014_03_17_09_20_07.ts
    Exit code: 1
    ffmpeg version N-53033-g56ba331 Copyright (c) 2000-2013 the FFmpeg developers
    built on May 13 2013 22:18:29 with gcc 4.7.3 (GCC)
    configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
    libavutil 52. 31.100 / 52. 31.100
    libavcodec 55. 9.100 / 55. 9.100
    libavformat 55. 7.100 / 55. 7.100
    libavdevice 55. 0.100 / 55. 0.100
    libavfilter 3. 65.100 / 3. 65.100
    libswscale 2. 3.100 / 2. 3.100
    libswresample 0. 17.102 / 0. 17.102
    libpostproc 52. 3.100 / 52. 3.100
    missing or bad response header at C:\Users\Dave\Desktop\slingbox\rec2a.pl line 168.
    pipe:: Invalid data found when processing input
     

Share This Page