1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can not get auto push to work

Discussion in 'TiVo Home Media Features & TiVoToGo' started by caddyroger, May 17, 2013.

  1. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    I am trying to get auto push to work. I got it set up but I get a

    java lang null pointer exception error.
    at java util arrays$arraylist<init>(unknown source)
    at java util arrays aslist (unknown source)
    at net java auto_push main.file.getfilelistingNoSort(file java 83)
    at net java auto_push main.file.getfilelistingNoSort(file java 89)
    at net java auto_push main.file.getallfiles(file. java:63)
    at net java auto_push main.auto-push. main_push.one_loop(auto_push.java:172)
    at net java'gui.monitor$1autothreadrun(monitor.java:42)
    at java. thread.run(unknown source)
    Edited to add this

    error: can not run program "c\pytivo\bin\ffmpeg.exe"creatprocess eroor=2, The system cannot find the file specified
     
  2. moyekj

    moyekj Well-Known Member

    11,140
    28
    Jan 23, 2006
    Mission...
    Path to ffmpeg looks wrong (missing a colon after volume name). Perhaps should be (also check for upper/lowercase):
    c:\pytivo\bin\ffmpeg.exe
     
  3. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    oops I did not put the colon in place. The correct one reads

    c:\pytivo\bin\ffmpeg.exe"creatprocess error=2, The system cannot find the file specified

    Every thing is in small letters
     
  4. moyekj

    moyekj Well-Known Member

    11,140
    28
    Jan 23, 2006
    Mission...
    Something doesn't look right still with that extra quote there. Check the case on pyTivo as usually uppercase is used for the T. From the error it seems pretty obvious the full path to the ffmpeg.exe file is still not correct.
     
  5. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    Maybe I should quit trying I can copy any thing right. It does have 2 quotes.
    This taken off the log file.


    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified
    2013_05_17_16:18:48 ERROR: Cannot run program "C:\pyTivo\bin\ffmpeg.exe": CreateProcess error=2, The system cannot find the file specified

    Here is my pyTivo.conf file

    [Server]
    tivo_username =xxxxxxxxxxxx
    tivo_password = xxxxxxxxxx
    tivo_mak = xxxxxxxxxx
    ffmpeg = C:\pyTivo\bin\ffmpeg.exe
    tivodecode = C:\pyTivo\bin\tivodecode.exe
    tdcat = C:\pyTivo\bin\tdcat.exe
    beacon = 192.168.1.10
    togo_path = D:\
    port = 9032

    [my videos]
    type = video
    path = e:\TEST
     
  6. moyekj

    moyekj Well-Known Member

    11,140
    28
    Jan 23, 2006
    Mission...
    Right, so did you check that C:\pyTivo\bin\ffmpeg.exe actually exists and runs? How about permissions on the file? If you open a cmd window and execute it does it run?
     
  7. caddyroger

    caddyroger New Member

    1,730
    0
    Mar 14, 2005
    Some where...
    Thanks for the helping this dumd ass out. I opened up a cmd window and entered the path to the ffmpeg file and came back file not found. My pytivo folder is in my programs folder. In stead of this C:\pyTivo\bin\ffmpeg.exe it was supposed to be this C:\program files\pyTivo\bin\ffmpeg.exe. It working now. Without the program files in it still pulled and i could manually push programs
     

Share This Page