1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can i Download Shows outside home network with Ctivo?

Discussion in 'TiVo Home Media Features & TiVoToGo' started by thekidran, Jul 1, 2014.

  1. Jul 1, 2014 #1 of 41
    thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    Can you download shows outside the home network using Ctivo with a Roamio?

    If so could you give me some direction on how to do so?

    Thanks guys!
     
  2. Jul 2, 2014 #2 of 41
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    If you know how to setup port forwarding with your router you can download away from home with kmttg.
     
  3. Jul 2, 2014 #3 of 41
    thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    are their any other settings i should know about?
     
  4. Jul 2, 2014 #4 of 41
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
  5. Jul 2, 2014 #5 of 41
    thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    So i got the program and i am forwarding the two ports 80 and 443. If I go to the external web address https://(external ip) I get a error message resource not found when i use the standard login credentials tivo and media access key as the password. When i setup KTMMG i get the same error below:

    > Getting Now Playing List from Living Room ...
    /usr/bin/curl --anyauth --globoff --user tivo:MAK --insecure --cookie-jar /tmp/cookie6808919321978244324.tmp --url https://176.72.117.79/TiVoConnect?C...tainer=/NowPlaying&Recurse=Yes&AnchorOffset=0 --output /tmp/NPL62404322174019296.tmp
    <h2>Resource Not Found</h2>
    Failed to retrieve Now Playing List from Living Room
    Exit code: 0
    Check YOUR MAK & IP settings
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed

    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 31 100 31 0 0 57 0 --:--:-- --:--:-- --:--:-- 57
    100 31 100 31 0 0 57 0 --:--:-- --:--:-- --:--:-- 57

    100 28 100 28 0 0 37 0 --:--:-- --:--:-- --:--:-- 37


    Any suggestions?
     
  6. Jul 2, 2014 #6 of 41
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    I don't see a port # listed in URL you posted above (but maybe you removed it). Make sure in kmttg config->TiVos tab that you set "wan http port" and "wan https port" to be the WAN side ports you are forwarding in your router setup. kmttg will then add the :# after IP # accordingly.
     
  7. Jul 3, 2014 #7 of 41
    thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    So they are setup as Port 80 and 443

    I get the same error my info is there give it a try yourself..

    Getting Now Playing List from Living Room ...
    /usr/bin/curl --anyauth --globoff --user tivo:MAK --insecure --cookie-jar /tmp/cookie7073927636105077120.tmp --url https://173.72.117.79:443/TiVoConne...tainer=/NowPlaying&Recurse=Yes&AnchorOffset=0 --output /tmp/NPL8205935512680052017.tmp
    <h2>Resource Not Found</h2>
    Failed to retrieve Now Playing List from Living Room
    Exit code: 0
    Check YOUR MAK & IP settings
    % Total % Received % Xferd Average Speed Time Time Time Current
    Dload Upload Total Spent Left Speed

    0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
    100 31 100 31 0 0 59 0 --:--:-- --:--:-- --:--:-- 59
    100 31 100 31 0 0 59 0 --:--:-- --:--:-- --:--:-- 59

    100 28 100 28 0 0 37 0 --:--:-- --:--:-- --:--:-- 37
     
  8. Jul 3, 2014 #8 of 41
    moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    WAN side ports 80 & 443 won't work as your ISP likely blocks those. You have to choose other ports such as 1080 & 1443 for WAN side, and 1080 should map to TiVo LAN IP & port 80, 1443 should map to TiVo LAN IP & port 443 in your router port forwarding setup.
     
  9. Jul 3, 2014 #9 of 41
    ThAbtO

    ThAbtO TiVoholic by the bay

    6,738
    8
    Apr 6, 2000
    SF Bay Area
    Usually this means the MAK is not set or is incorrect.

    Try this in your browser:

    Code:
    https://173.72.117.79:443/nowplaying/index.html
    
    When it ask you to sign in, use "tivo" and for password is your MAK (Media Access Key)

    If it works, you should be seeing your playlist.

    If you are using Firefox, you might see:

    [​IMG]
    Click on "I Understand the Risks"
    [​IMG]
    Click "Add Exception"
    [​IMG]
    Click "Confirm Security Exception"

    Then it will ask for the Tivo sign in as above.
     

    Attached Files:

  10. thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    just so i have this clear

    for my internal ip forward 1080 and 1443 in two seperate logs in my router.

    you still mention port 80 and port 443 does something separate have to be done with these somewhere else?

    Thabto I have tried that in my browser and i am getting "resource not found"

    Thanks for the patience i am sure i can get it working with your assistance.
     
  11. ThAbtO

    ThAbtO TiVoholic by the bay

    6,738
    8
    Apr 6, 2000
    SF Bay Area
    I tried it on his IP address and got to the Tivo sign-in on my browser, so it works now..
     
  12. thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    once i put the info in i also get the sign in page, but once i put in the tivo as the username and my media access key i get the Resource not found error.
     
  13. ThAbtO

    ThAbtO TiVoholic by the bay

    6,738
    8
    Apr 6, 2000
    SF Bay Area
    If you did port forwarding as above, your browser should go to:

    Code:
    https://173.72.117.79:1443/nowplaying/index.html 
    
    Default for "HTTPS:" is port 443, and "HTTP:" is 80. Port forwarding would set the right path when it needs to be redirected.
     
  14. ThAbtO

    ThAbtO TiVoholic by the bay

    6,738
    8
    Apr 6, 2000
    SF Bay Area
    Do you have your tivo.com preferences enabled in your account? Is your MAK shown in the Tivo System/Media Access Key?

    Just making sure this is not the problem.
     
  15. moyekj

    moyekj Well-Known Member

    11,150
    33
    Jan 23, 2006
    Mission...
    Every router is different, so I can't give exact steps, but the gist of it is, assuming in this example that your TiVo LAN IP is 192.168.192.110:

    TCP WAN PORT = 1443 needs to map to 192.168.192.110:443
    TCP WAN PORT = 1080 needs to map to 192.168.192.110:80

    As it is right now it looks like you have WAN PORT = 443 mapping to TIVOIP:443 and that one is working, but your port 80 map is not (blocked by ISP most likely). I wouldn't use 443 either even if that is working.

    If you do the above as intended then in a browser:
    Code:
    http://173.72.117.79:1080
    will give you "Congratulations" TiVo page.

    and:
    Code:
    https://173.72.117.79:1443
    will give prompt you for username & password (or an untrusted page as posted above)

    Then in kmttg config-TiVos tab for the TiVo:
    Code:
    TiVo Name = whatever
    TiVo IP# = 173.72.117.79
    wan http port = 1080
    wan https port = 1443
    
    (and you should also turn off "Look for Tivos on network")

    If you do get above working and you have series 4 or later TiVo, you can also use "wan ipad port" forwarding (which is a poor name for it) to get all Remote tabs working as well.
     
  16. ThAbtO

    ThAbtO TiVoholic by the bay

    6,738
    8
    Apr 6, 2000
    SF Bay Area
    The same goes if there are multiple Tivos.

    For example:
    The first Tivo can be port forwarded to 1080 and 1443.
    The second forwarded to 2080 and 2443.
    And so on.

    This makes sure the info gets to/from the right Tivo.
     
  17. thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
  18. ThAbtO

    ThAbtO TiVoholic by the bay

    6,738
    8
    Apr 6, 2000
    SF Bay Area
    Almost.

    Remove the old ones to the Tivo, the 80 and 443.

    Make your port forward, 1080 with destination 80, and 1443 with destination 443.

    With the way you have it, any traffic going to port 1443 and 1080 will go to the same 1443 and 1080, but you need 1443 to go to 443 and 1080 to go to 80 since Tivo use ports 80 and 443 not 1080 and 1443.

    Don't forget to set a static IP to your Tivo, so if it relogs to your network, it will be the same IP and not change, which will also make the port forward stop working.
     
  19. thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    how do you make the port forward have a destination? sorry :) but we are close
     
  20. thekidran

    thekidran New Member

    22
    0
    Jun 24, 2014
    btw its funny you are from san fran as when i was talking to you last night i was flying home from their to nj..
     

Share This Page