1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Awful wireless transfer speeds from PC to Roamio basic

Discussion in 'TiVo Roamio DVRs' started by cbr929rrguy, Jun 13, 2014.

  1. cbr929rrguy

    cbr929rrguy New Member

    2
    0
    Apr 8, 2014
    I ditched my cable DVR a few months ago for a Roamio and overall I've been happy with it. However, my biggest gripe is the abysmal transfer speeds. I have a very current 802.11N wireless router capable of 300Mb/s. (http://www.amazon.com/gp/product/B002RYYZZS/ref=oh_details_o05_s00_i00?ie=UTF8&psc=1)

    In the roamio settings it says the wireless connection is excellent (>80%) but transferring files from PC to the Tivo is painfully slow. Its impossible to watch a program as its transferring and in the completed transfers log it says ~5Mb/s! On the PC side I'm using the Tivo Desktop app. Tried both auto and manual downloads and both are slow.

    My phone on the same wifi connection can do a speed test out over my cable modem and it's 15Mb/s. So, it's a little ridiculous that this transfer speed within my network is so slow.

    Any ideas for things I can check for settings or tests I can perform to debug this?:(

    Edit: More Info on this (see attachment for detail):
    Router admin panel shows the Tivo is connecting around 130Mb/s so my wireless connection speed is solid.

    However, check out what Tivo Desktop shows me. I started transferring a 3412MB video file to my Tivo. At 100Mb/s, that should take under 4.5 minutes to transfer ((3412MB*8)/100Mb/s) / 60. Tivo desktop shows that 4 minutes of a 57 minute show have been transferred and that took 25 minutes.

    My wireless N router is set to auto channel select.
     

    Attached Files:

  2. ThAbtO

    ThAbtO TiVoholic by the bay

    6,719
    7
    Apr 6, 2000
    SF Bay Area
    Try to keep cordless phones (landline), and microwaves at least 2-3 feet away from your wireless router, and other wireless network adapters/devices. They can cause interference which could slow down and even interrupt network traffic.

    You can also use a set wireless channel to 1, 6 or 11and never use the Auto (which almost always chooses a channel with the most interference).
     
  3. cbr929rrguy

    cbr929rrguy New Member

    2
    0
    Apr 8, 2014
    No other wireless interferors close to the Tivo or the router. Logs confirm a solid connection and link rate. Router was set to auto but I've now forced it to use a different channel. I'm at a loss as to what the problem is...
     
  4. worachj

    worachj Active Member

    1,137
    2
    Oct 13, 2006
    Eagan, MN
    Just throwing out ideas, some things you could try...

    Update the firmware on your router to the latest version.

    Check page 88 for optimizing wireless performance.
    http://documentation.netgear.com/wnr3500l/enu/202-10545-01/usermanual.pdf

    You may need to play around with the Maximum Transmission Unit (MTU) size.

    Play around with the quality of service settings (QoS) and give your TiVo a higher priority.
     
  5. spaldingclan

    spaldingclan Member

    388
    0
    Aug 22, 2012
    i switched to ethernet over my powerline...took care of it for me
     
  6. aaronwt

    aaronwt UHD Addict

    19,162
    21
    Jan 31, 2002
    Northern...
    An excellent wireless connection on the Roamio Basic should see up to 95Mb/s transfer rates. The same speeds as the wired connection. That is what I get from my Roamio Basic.
     
  7. lgnad

    lgnad Pantless Mofo

    691
    0
    Feb 14, 2013
    Massachusetts
    how is the pc connected? also wirelessly?
    have you benchmarked your pc's xfer speeds? (speedtest.net)
    Do you have a network "loop"? e.g. both Moca and wireless active on the tivo and a moca bridge active. ...this can cause havoc and kill speeds

    reboot ALL of your networking equipment
     

Share This Page