1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Automatic soft padding running on the TiVo

Discussion in 'TiVo Series 1 - UK' started by sanderton, Oct 8, 2003.

Thread Status:
Not open for further replies.
  1. Mar 24, 2004 #721 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    I can see the problem.

    I'll work on a fix over the weekend.
     
  2. Mar 24, 2004 #722 of 1197
    Fletch

    Fletch New Member

    189
    0
    May 27, 2001
    Huntington...
    Cool, thanks. Let me know if I can provide additional data. In the meantime, do you have any hints on how to avoid this?
     
  3. Mar 24, 2004 #723 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    Switching suggestions off?
     
  4. Mar 26, 2004 #724 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    New version of EndPad is in the top post.

    Changes:
    • Fixed bug which did not pad if a suggestion immediately followed a show on some US TiVos
    • Back to back suggestions on same channel no longer cancels the second one
    • You can now prevent suggestions cancelling other suggestions with a command line switch
    • You can change the recording quality used by suggestions with a command line switch
    • EndPad can now be placed anywhere, not just /var/hack
    • Code tidied and speeded up a little
    • Logfile tidied up with clearer info
    The syntax to launch EndPad has been regularised to allow future additions - this means that if you install the new version and you have EndPad launched from a startup script you will need to edit that script for the new commands.

    Has run for 24hrs on my two TiVos with no problems, but please report bugs etc.
     
  5. Mar 26, 2004 #725 of 1197
    ddub

    ddub New Member

    50
    0
    May 6, 2002
    West Yorkshire
    Seems to work fine here Stuart. Thanks !

    - had to delete the pid file from /var/run/ before I could run it though, got "endpad is already running". Even though I'd killed the process.

    good work!
    Darren
     
  6. Mar 26, 2004 #726 of 1197
    russellg

    russellg New Member

    8
    0
    Mar 10, 2004
    Hi, thanks for the update. Sorry to nitpick, but I wonder if this also fixes the problem I mentioned, which is that if a show immediately follows a suggestion, the suggestion was padded, thus cancelling the show (on a US Tivo). I believe the problem you mention above is the opposite, where a suggestion comes after a show, and the show wasn't padded.

    Here's the relative URL to my original post:
    /tivo-vb/showthread.php?postid=1798463#post1798463

    Thanks,

    Russell
     
  7. Mar 26, 2004 #727 of 1197
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    Good work Stuart. Thanks.
     
  8. Mar 26, 2004 #728 of 1197
    Fletch

    Fletch New Member

    189
    0
    May 27, 2001
    Huntington...
    What does "-sugqual 0" do?
     
  9. Mar 26, 2004 #729 of 1197
    Fozzie

    Fozzie New Member

    837
    0
    Sep 3, 2001
    Alton,...
    Hmmm, you did read the first post? ;)

    "Note 3: EndPad has the ability to alter the recording quality of any suggestions, allowing you to, say record suggestions at Medium while leaving the default at Best, making setting up SPs faster. Use the optional -sugqual switch with values of 0 (Basic), 40 (Medium), 75 (High) or 100 (Best)"
     
  10. Mar 26, 2004 #730 of 1197
    Fletch

    Fletch New Member

    189
    0
    May 27, 2001
    Huntington...
    Thanks. Somehow I confused myself into thinking there were only three recording qualities...
     
  11. Mar 26, 2004 #731 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    Did you stop it with endpad.tcl -stop or just kill it?
     
  12. Mar 26, 2004 #732 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    Yes, it will (I hope, not having a US TiVo to test it on). It wasn't correctly identifying some shows as suggestions under 3.x - it should now.
     
  13. Mar 27, 2004 #733 of 1197
    ddub

    ddub New Member

    50
    0
    May 6, 2002
    West Yorkshire
    Yes, i tried that, It told me that it might take a minute. I also noticed a new file in var/hack called endpad.kill

    I waited a few more mins, and tried starting endpad again, and got the same message "endpad is already running".

    so sweat anyway, once I'd deleted the PID file, it started anyway.

    thanks
    DArren
     
  14. Mar 28, 2004 #734 of 1197
    orange

    orange New Member

    8
    0
    Jun 7, 2002
    Just to let you know I had the same issue with getting the still running message and also had to delete the PID file.

    My TiVo was restarted which caused this problem, so endpad.tcl -stop was not used. I was just testing to see if it would came back to life after a power failure or tivo provoked reboot. As I found the answer appears to be no.

    I am running version 2.5.5a-01-1-023 of the software. If you need any more help please contact me. Apart from that top work!
     
  15. Mar 28, 2004 #735 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    What command line is in your start up script?

    You need to have the -auto flag in it to run it at startup.
     
  16. Mar 29, 2004 #736 of 1197
    mark.stringer

    mark.stringer New Member

    54
    0
    Jun 7, 2002
    Belfast
    My endpad.log is showing all times as GMT so everything is actually one hour less than it should be. For instance, for Holiday which is on at 19:00 BST this evening I get:

    Monday 17:30:06 : endpad.tcl 1.4.0 log file, starting up
    Monday 17:30:06 : Start padding set to 60 seconds
    Monday 17:30:06 : End padding set to 180 seconds
    Monday 17:30:06 : Suggestions will not be padded if another suggestion immediately follows them
    Monday 17:30:06 : Detected TiVo software version 2.5.5-01-1-023
    Monday 17:30:06 : Suggestions will be recorded in High
    Monday 17:30:06 : Woken up
    Monday 17:30:07 : No recording in progress
    Monday 17:30:07 : Next recording is Holiday on BBC1NI at 18:00
    Monday 17:30:07 : No end padding required:
    Monday 17:30:07 : No recording in progress
    Monday 17:30:07 : Next end padding setting due 18:25
    Monday 17:30:07 : Not time to add start padding yet
    Monday 17:30:07 : Next start padding setting due 17:58
    Monday 17:30:07 : Next wake up will be 17:58
    Sleeping, checking every minute for kill signal.........................


    When I type date on the Tivo I also get the GMT time.

    Does endpad need a fix for this or is there something up with my Tivo? The time on the Tivo screens and on the TivoWeb info page shows correctly with the +1 hour for BST added.

    Thanks,
    Mark.
     
  17. Mar 29, 2004 #737 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    This is "as designed". TiVo's internal clock runs on GMT. I left the log in GMT partly for ease of debugging as the other log files in /var/log are also in GMT; but mainly because I couldn't be arsed to write the code to make it local time.
     
  18. Mar 29, 2004 #738 of 1197
    mark.stringer

    mark.stringer New Member

    54
    0
    Jun 7, 2002
    Belfast
    OK Stuart, thanks, as long as I know it is as designed. Whilst I have your attention can I be cheeky enough to ask how the tracker module is going? Or is your development time limited/on other projects at the moment?

    Thanks,
    Mark.
     
  19. Mar 29, 2004 #739 of 1197
    sanderton

    sanderton TiVoer since 11/2000

    6,341
    0
    Jan 4, 2002
    Development time is spouse-limited at thet the moment!
     
  20. Mar 30, 2004 #740 of 1197
    SteveJones

    SteveJones New Member

    3
    0
    Jan 12, 2003
    I've been running endpad since about the first version with little problem. What an excelent utility!

    However I am having problems with the latest version 1.4.0 running from rc.sysinit.author.

    It starts, and stops, fine from a Telnet session and all the parameters work as they should, but try as I might I can't get this version to run from a reboot.

    The line in my rc.sysinit.author file is:
    /var/hack/endpad.tcl -s 1 -e 5 -sugqual 40 -sugeq -auto >> dev/null &

    All the other progs in rc.sysinit.author start up OK as did previous versions of endpad.

    Any ideas what's wrong?

    Steve
     
Thread Status:
Not open for further replies.

Share This Page