1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Audio Format Question

Discussion in 'TiVo Home Media Features & TiVoToGo' started by mustanz, Jul 27, 2013.

  1. mustanz

    mustanz New Member

    10
    0
    Feb 12, 2003
    Okay, let me say up front that I am lost when it comes to this. I have MKV files, some with AC-3 (6 Channel), some either with a standalone stream or second stream of AAC. I am using MKVtoMP4 to convert these files as they are not playing correctly on TiVo (Premier). I try to keep the AC-3 (6 Channel) and no sound. I have to convert it to AAC (LC) 2 Channel and it works.

    I am transferring through the Tivo software. I am aware and have used pytivo and streambaby. I am just trying to understand this audio situation better.

    I have the Tivo connected to an Onkyo 616 via HDMI. The audio comes from the Tivo as PCM, which I also don't understand. My goal is to output is as 7.1 at the end of the day...

    Any insight would be greatly appreciated.
     
  2. jcthorne

    jcthorne Active Member

    2,718
    2
    Jan 28, 2002
    Houston
    MP4 files with AC3 5.1 audio should push and play fline on the Tivo. Make sure your Tivo is set to output Dolby Digital and not PCM sound. All AAC sound tracks will come out of the TiVo as PCM though and the TiVo only handles stereo AAC, not 5.1.

    The AC3 track should be limited to 640kbps for the Premiere. Not sure if Tivo Desktop handles files with AC3 audio or not as I don't use it. Pytivo pushes them fine (pulls too).
     
  3. mustanz

    mustanz New Member

    10
    0
    Feb 12, 2003
    My Tivo is set to Dolby Digital, but still will output some sources as PCM. The software doesn't tell me if the AC3 is 5.1, it says "AC3 pass-through". when I have done that I don't have audio. I wish there was one program to get the job done with the optimal tivo settings built in.

    I have updated pytivo to the latest version. It appears in Tivo, but at some point it disappears forcing me to restart the service..very irritating.
     

Share This Page