1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Amazon Videos on Roamio, but not the Mini?

Discussion in 'TiVo Mini' started by TheWizz, Sep 25, 2013.

  1. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,454
    166
    Apr 17, 2000
    Nevada
    You have to make sure the Mini is selected for the app, not the host TiVo, then select the Amazon program and pick Watch On TV.
     
  2. megpeg

    megpeg New Member

    6
    0
    Oct 20, 2003
    plymouth,mi
    I did all that, but it crashes my mini- a total freeze, it goes blank, and then I have to reboot. Specifically, it tries to queue the show but then it does nothing. When I hit live TV and give up, it crashes. After multiple attempts I'm afraid it just doesn't work for me and my mini.

    I should mention I queued another show not from Amazon, just a regular TV show, and it worked fine. It's just the Amazon downloads that crash it.

    Update: I asked Tivo why this happens, and they told me today it's because the mini isn't a supported device. I guess if I tell them it crashes when I attempt it, they are saying "don't do that".
     
  3. eboydog

    eboydog Just TiVo'ing.....

    904
    0
    Mar 23, 2006
    Might have something wrong with your Mini, someone else mentioned they couldn't get the Apple Amazon play trick so I thought I might try mine again since the only different was the recent early spring update but mine even after the update still works.

    Are you using MoCa or ethernet with your Mini? Are your working with Amazon purchase or rentals and are the Amazon download complete and not still transfering when you try to view them?
     
  4. megpeg

    megpeg New Member

    6
    0
    Oct 20, 2003
    plymouth,mi
    Thanks for the reply. I have the Mini connected via MoCa, and I purchased from Amazon some TV shows. The shows are completely downloaded on the Roamio. Does this give you any ideas why it doesn't work for me? Like I said, I can start up regular saved Tivo shows using the iPad to watch on the TV with the Mini. I just tried again- it says on the screen "There was a problem playing the video, please try again". Trying again fails again. I was able to play another normal tv show after that, and when I hit Live TV, it was OK. If I don't successfully play a video and hit Live TV, it crashes.

    Another update: I tried doing a 3 thumbs down total reset, and it still doesn't help.
     

Share This Page