1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Amazon HD Instant Video download problems

Discussion in 'TiVo Series3 HDTV DVRs' started by dlfl, Aug 27, 2013.

  1. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    I can't get purchased HD Instant Video rentals to download and play correctly on my Tivo HD (model 652). I rent and initiate from the Amazon web site.

    SD videos download and play fine. HD videos start downloading but either the download speed is ridiculously slow or it stalls completely, although in one case a 2-hr movie downloaded in 4 hrs -- but it stalled during playback just 15 mins into the video and there was no way to play the rest of it. This same movie, on a retry, was still downloading after 12 hrs upon which it quit and the message in the To Do Recording History said someone at my end cancelled it (not true).
    I've tried several HD downloads and they all exhibit the same issues.

    I've unregistered and re-registered my Tivo -- no change. My TiVo is on wired ethernet that tests greater than 10 Mbps download speeds. I have a BR player that can stream these same videos even over WiFi with no problem.

    I've restarted the TiVo. I have 11.0m software now and the problem was the same with 11.0k.

    Amazon wants me to reboot my router and then call them (again) if I still have problems. They claim to have great diagnostic tools they can apply to this problem -- but not til I reboot the router. So I'll do that ..... then test their great diagnostic powers. :rolleyes:
     
  2. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    Update:
    I power-cycled my router and started another HD download. Same problem, e.g., 10 mins of video downloaded in 53 minutes. I called Amazon support and the rep said that definitely wasn't right and said he was documenting it and submitting it to their techies. He said he saw other people were having the same problem but if that were true I would think there would be recent posts on this forum.
     
  3. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    Another update:
    Last night I downloaded a 52 minute HD video, Rome Season 1, Episode 1.
    It took 3.5 hours to download :eek: and playback would freeze at the 22 minute point with no way to access video beyond that point.

    Can anyone else using a TivoHD (model 652) confirm either:
    1. Successful download and playback of Amazon Instant Video HD videos.
    (or)
    2. Unable to do so like me ?
     
  4. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    Yet another update:
    This morning I downloaded and viewed the SD version of Rome, Season 1, Episode 1. The video has big black borders on all sides but the zoom setting makes it fill the screen and the PQ is pretty decent on my "little" 40" screen. I suspect it would not satisfy on larger screens though.

    The SD version downloads at about real time rates and allows viewing to start just a few minutes after download starts -- significant advantages.

    SD versions will probably be the compromise solution for me but I'm going to continue to pester Amazon -- they say my Tivo model supports their HD downloads and they should make it so, or stop saying that.

    BTW, they didn't exploit sex and nudity much in that series did they? :rolleyes:
     
  5. HerronScott

    HerronScott Active Member

    2,748
    19
    Jan 1, 2002
    Staunton, VA
    Since it's free, I just started the download on my S3 OLED and will let you know how it goes. I'll repeat it on my son's S3 HD when I get a chance as well (it's upstairs so harder to monitor the download time).

    Scott
     
  6. HerronScott

    HerronScott Active Member

    2,748
    19
    Jan 1, 2002
    Staunton, VA
    It took 28 minutes to download and was 1.98GB in size on my S3 OLED. I let it play from 20-25 minutes with no problems.

    I'll go repeat this on my son's HD and let you know the results.

    Scott
     
  7. HerronScott

    HerronScott Active Member

    2,748
    19
    Jan 1, 2002
    Staunton, VA
    OK test completed on an HD. It took 37 minutes to download and same size was reported (1.98GB) on my son's HD. This is on an 802.11G wireless bridge connection just FYI. I heard my son on a Skype call with his girlfriend when I went to check on the download near the end so this may have accounted for the slightly longer download time. No issues with playback at 22 minutes or beyond.

    Given the really really long download time I would guess some kind of corruption in the download?

    Scott
     
  8. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    Thanks Scott. What kind of download speeds does your internet test at?
     
  9. HerronScott

    HerronScott Active Member

    2,748
    19
    Jan 1, 2002
    Staunton, VA
    We've got Comcast's normal package (Performance with Powerboost). Right now it's measuring 27mbps down and 4.5mbps up. Shaperprobe shows 23mbps down without shaping and 4.5mbps up with no shaping detected.

    Scott
     
  10. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    1.98 GB in 37 mins is around 7.3 Mbps, which seems reasonable, about 70% of what model 652's are good for on TTG transfers. Your internet is a lot faster than mine but I usually test above 10 Mbps down, 1 Mbps up, so my slow Amazon downloads are not explained by that.
     
  11. HerronScott

    HerronScott Active Member

    2,748
    19
    Jan 1, 2002
    Staunton, VA
    Is that DSL or a lower tier with your cable provider?

    Any chance you could take your TiVo to a friend's house to test the same download (preferably with a different Internet provider)?

    Scott
     
  12. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    It's medium speed TWC (Roadrunner) cable spec'ed at 10 Mbps down, and my Tivo is hardwired to the router. My internet rarely tests less than 10 Mbps and never below 5 Mbps. I have a number of internet connected devices on my network including several that stream video. Nary a problem with those. When I TTG from my Tivo to PC I see the maximum rate that a TivoHD can sustain, i.e, about 11 Mbps.

    Having a hard time believing it's my network or internet that is the problem.

    As of yesterday I could not even get Instant Video downloads, including non-HD videos, to even start, so am working with their support again.
     
  13. edubbrulez

    edubbrulez Member

    431
    0
    Mar 4, 2004
    SE, PA
    Interesting.

    I'm experiencing the same problem on my TiVo HD. Tried twice to download and play Jack Reacher in HD. The video downloaded - but when I tried to play it playback paused around the 1hr 30 min mark the first time. The second time around the 30 min mark.

    When I say paused - the last frame of the video from the playback is shown - and that's it. I thought it might have been related to a botched download - but I checked my router's wireless activity and I see that it downloaded the entire movie (5GB) twice.

    Very strange.
     
  14. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    Are you also experiencing the Tivo Search problem?

    My Amazon problem got progressively worse over the last week or so. At first it was just that HD videos would not download or downloaded at ridiculously slow speeds, then had defects. In the next phase, only non-HD videos would download. Finally (as of yesterday) when I rent a video on the Amazon website, the button, or link, to download isn't even displayed. I've talked to Amazon Instant Video support several times and have un-linked then re-linked my Tivo several times.

    Just now I tested YouTube and Netflix and they work fine -- but they aren't downloads, rather they are streaming.

    Today I noticed that pyTivo pushes no longer work while pulls do work. I think the pushes depend of the same download handshake with the TiVo mind server (mind.tivo.com) as the Amazon downloads. I suspect the Tivo Search unavailability and these download problems are all related.
     
  15. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
  16. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    The Tivo Search problem and, simultaneously, pyTivo push failures have been fixed. My amazon instant video download problems continue. Their support says the techies are working on it and it affects more than just my account. Strange since no one else is posting about it here.
     
  17. JLCKJC

    JLCKJC New Member

    2
    0
    Sep 6, 2013
    I am also experiencing what appear to be corrupt video down loads from Amazon. All other functions and features of my Tivo Premiere XL function perfectly. I have a firm 802.11n network connection at 5GHz.

    The videos usually download as expected but when played they will run for some time and then freeze with some video corruption at the top of screen. I can't view beyond that point. If I restart the video it will play to the same point and fail in the same way. The problem is random, sometimes I get a good download other times not. Usually the downloads are fast but I have seen situations where they seem to take much more time than is usually the case. I've also seen the Tivo reboot during a download and restart the download all over again. All symptoms of the same problem I think.
     
  18. fishbate

    fishbate New Member

    10
    0
    Sep 18, 2005
    I've had same problem. Was able to download episodes of Breaking Bad in HD to my Premiere XL, but it freezes up about 30 minutes into show. Ended up streaming it through my kid's Wii, which played just fine. I've downloaded several SD videos which played without problems. Has anyone been able to download and play Amazon HD videos successfully?
     
  19. dlfl

    dlfl Cranky old novice

    6,991
    16
    Jul 6, 2006
    Near...
    Last night my Tivo downloaded 7 shows that I had tried to download several days ago. All of them were free "shorts" except one 52 Min HD video (Rome, Pilot). All the short videos were fine. The Rome episode looks OK just scanning through it from start to finish, but I haven't watched every second of it.

    So I was encouraged to think things were fixed. I went to the Amazon site and tried to start downloads on two more HD shorts. One of them went fine. On the other one, when I would click the "1-click purchase" button I would get the rotating wait symbol for a long time then finally a message would pop up saying the purchase was taking too long to complete. And the video would not download, nor was it in my Video Library. I gave them a nasty-gram feedback on that one -- actually it was the Ironsides trailer or sneak preview. Maybe it was a problem with just that video.

    I would like to test a 2 hr HD movie download, but actually there are none that I want to see bad enough to pay for. ;) I'm in the fortunate position of having other ways to get video content. So my pursuit of this issue is based more on principle than on practical need.

    I did note I was getting 4 to 5 Mbps transfer rates on the transfers, much faster than last week.
     
  20. westtown73

    westtown73 New Member

    31
    0
    Nov 11, 2007
    I am experiencing this as well on my Tivo HD. Two weeks ago and tonight I ordered HD movies from Amazon and the download proceeded at a snail's pace. The first one eventually completed, but we got about half way through, and the file was corrupted. The one tonight won't be watchable according to the Tivo, for another 8 hours. Was there ever any resolution to this issue?
     

Share This Page