1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A better /nowplaying/index.html

Discussion in 'TiVo Home Media Features & TiVoToGo' started by gman622, Mar 28, 2005.

  1. May 5, 2005 #81 of 168
    ebf

    ebf New Member

    542
    0
    Mar 21, 2005

    Well, I just tried a known bad MAK and I get the same thing. It must be something else... :confused:
     
  2. May 5, 2005 #82 of 168
    ebf

    ebf New Member

    542
    0
    Mar 21, 2005
    WTF?!?OK, so I changed the <title> to be EBF TiVo and removed what seemed to be unneeded returns in (my) line 2 and 4 (<!--save and <!DOCTYPE both were running to two lines) and now it is working! Weird. It must have been the extra returns as my "custom" title is not showing.

    EBF :)
     
  3. May 7, 2005 #83 of 168
    Kristo

    Kristo TiVoAddict

    159
    0
    Dec 6, 2002
    Nashville, TN
    First off - great job on this! I'm amazed at what some of you guys are able to do - wish I could code as well.

    BOSCODEGAMA: Could you share your mod with us? I've got two different sized TiVos & would like the ability to have the total sizes specific for each. (better yet - can we just add his mod into the file?)
     
  4. May 8, 2005 #84 of 168
    gman622

    gman622 New Member

    111
    0
    Feb 17, 2005
    if i were you i'd just make two copies of the file (with two appropiately named bookmarks). then you can just have each tivo in it's own tab.
     
  5. May 11, 2005 #85 of 168
    philbb

    philbb New Member

    5
    0
    Apr 23, 2005

    That's what I'm doing now, but I'd like to have them both on one page.

    BTW, thanks for a great app!
     
  6. May 13, 2005 #86 of 168
    gman622

    gman622 New Member

    111
    0
    Feb 17, 2005
    updated this so you can have up to five tivo's (really as many as you want) each with their own capacity.
    also added the time left at all 4 recording qualities.

    *my version still won't work with >128 shows but if someone wants to donate to me a 140 hour tivo, i'll gladly rewite this from scratch to 'natively' support it ;)
     
  7. May 14, 2005 #87 of 168
    philbb

    philbb New Member

    5
    0
    Apr 23, 2005
    Thank you so much for your work on this. I think it's great!
     
  8. May 31, 2005 #88 of 168
    juanian

    juanian Member

    483
    0
    Oct 1, 2002
    Chandler, AZ
    A great looking script, but if only I could get it to work. Someone (? AnteL0pe) seemed to indicate that the script worked in Safari, but I can't get it to work (Safari 1.3 v312 running OS X 10.3.9).

    I get errors like the following on all of the lines with the non-breaking space (&nbsp;):
    error on line 429 at column 106: Entity 'nbsp' not defined

    Just for giggles, I changed them all to some other character and the errors went away, but then no output occurred (and the title remained 'Loading...').

    I also tried running it in the old Mac IE, and it gave the "<![CDATA[" error (no surprise), and it did show a page with nothing filled in (which was more than Safari did).

    Sniffing the line, it doesn't appear that Safari performed any network I/O. Java and JavaScript are enabled. I'm not sure how to check to see if any JavaScript errors occurred (nothing odd shows in the system or console logs).

    The file does have the .xhtml suffix, and 'Hide Extension' is not checked. The IP address and the MAK is correct. Any thoughts? Am I SOL unless I go to FireFox?

    (EDIT: I've tried the script from gman622 and morac - same results.)

    Thanks
     
  9. May 31, 2005 #89 of 168
    juanian

    juanian Member

    483
    0
    Oct 1, 2002
    Chandler, AZ
    I tried the Pie Chart, and poking around in the script showed that it stopped at the 'new XSLTProcessor()' line.

    I searched the web, and I find conflicting info on Safari support for XSLT. My version of Safari with my OS version is listed as supporting XSLT, but other places say that Safari will not support XSLT in JavaScript in this version (1.3) or a future version (2.0) anytime soon. My knowledge of XSLT is nil, so I don't know what is up.
     
  10. Jun 25, 2005 #90 of 168
    f20clove

    f20clove New Member

    5
    0
    Apr 19, 2005
    TO FIND RECORDING SIZE USE FORMULA:
    (MINUTES USED UP / 60 + HOURS USED UP) * CONSTANT OF QUALITY (BELOW)=X
    TO FIND DISK SIZE USE FORMULA:
    ANY RECORDING QUALITY HOURS AVAILABLE (FROM RECORDING QUALITY SETTING SCREEN) * CORRESPONDING CONSTANT OF QUALITY (BELOW)=X

    CONSTANT OF QUALITY (GBs/HRs)

    BASIC - 0.71492708454976447936942556673686
    MEDEUM - 1.2133195698873329489129168247665
    HIGH - 1.5934930351186972729056307631933
    BEST - 2.5603296056503825779870512065921
    :D
     
  11. Jun 25, 2005 #91 of 168
    f20clove

    f20clove New Member

    5
    0
    Apr 19, 2005
    FOR HRs/GB USE FORMULA:
    1 / CONSTANT OF QUALITY (ABOVE)=X
    ;)
     
  12. Jul 20, 2005 #92 of 168
    cgt1z

    cgt1z New Member

    4
    0
    Jun 20, 2005
    When I click on the file, it prompts me for a username and password.
    itried to Use 'tivo' as the username and my MAK as the password.
    It does not work it still prompts, any other possibility? :(
    -------------------------
    OK I figured out what I did. I entered the 14 digit tivo machine ID not the 10 digit media access key. One of the posts said the 14 digit nu and so I used the 14 digit number.

    This is a very cool app/ thanks for the work! :)
     
  13. Sep 15, 2005 #93 of 168
    drosoph

    drosoph Distinguished Member

    493
    0
    Mar 21, 2000
    Allen, TX, USA
    Is this possible to run on a server, and access OUTSIDE a home network ?
    I can currently access my tivo's from outside my home network ... Just did some port redirects/whatnot ... but I cannot get the xhtml page to server via IIS6.

    EDIT: I forgot to enable .xhtml file types on IIS. Now I cannot get the info to come up, but the page load .. with a shell. Only way I can get it to run is to put in file://c:/inetpub/yaddayadda ... I cant get http://localhost/yaddayadda to even work!
     
  14. Dec 22, 2005 #94 of 168
    cmarrin

    cmarrin New Member

    4
    0
    Dec 15, 2005
    I'm glad I found this thread late! I downloaded the file, added my info (for 2 tivos) and it worked without a hitch! Thanks a lot. This is just what I have been looking for.

    I have been playing with a lot of solutions to using my Linux home server as the media server for TiVo. I find TivoDesktop running on my PC to be an abomination with crashes, hangs, and generally slowing down my Windows PC. So I tried Galleon to move all this to my Linux server and found that to be just as bad. I am admittedly prejudiced against Java, but I found Galleon to be hard to use and inscrutible. Plus I don't need all that stuff.

    I need to download video from my Tivos. This script is GREAT for that! I also need to server photos. I don't need to serve Music because I have a Squeezebox, which is a better solution for that, IMHO. I got the example Apache server from the Tivo site working pretty well.

    So now all I need is to serve the videos I download BACK to the Tivos. I can do this using TivoDesktop. The shows I download to my PC show up in the Tivo Now Playing list under my server's name. Now I'd like to use the TiVoConnect.pm script to do that, but have not found anything on the web.

    Anyone here trying to serve the videos downloaded to the PC back to the TiVos?
     
  15. Dec 22, 2005 #95 of 168
    windracer

    windracer joined the 10k club

    11,607
    4
    Jan 3, 2003
    St. Pete, FL
    You didn't like Galleon? :confused:

    It works great on my Linux box for doing everything you've described, including serving recordings back to the TiVo boxes on the network via TTCB. Since ComeBack transfers are initiated from the TiVo itself, I'm not there's a scripted way to kick off those transfers (at least not until TiVo opens up more of their HME SDK).

    Let me know if you want any assistance with Galleon on Linux, or check out the other Galleon-related threads around here.
     
  16. Dec 22, 2005 #96 of 168
    Fraser+Dief

    Fraser+Dief New Member

    261
    0
    Nov 18, 2005
    Otttawa, Canada
    Anybody using this on Firefox 1.5? I just go the script warnings, then nothing but a blank page. The Javascript console shows (along with hundreds of errors from the boards here):

    Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.focus]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/tabbrowser.xml :: setFocus :: line 744" data: no]

    Error: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIXSLTProcessor.transformToFragment]" nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)" location: "JS frame :: file:///F:/Downloads/nowPlaying.xhtml :: anonymous :: line 78" data: no]
    Source File: file:///F:/Downloads/nowPlaying.xhtml
    Line: 78
     
  17. Dec 22, 2005 #97 of 168
    windracer

    windracer joined the 10k club

    11,607
    4
    Jan 3, 2003
    St. Pete, FL
    I'm using Firefox, but I'm not actually executing the php script through Firefox. I run the script via php on my Linux box and then just use Firefox to view the resulting files.
     
  18. Dec 23, 2005 #98 of 168
    bonnie_raitt

    bonnie_raitt New Member

    122
    0
    Sep 14, 2001
    Seattle, WA
    I've tried this several times over the last two days, but get nothing but a blank screen. I am using Firefox 1.0.7. The Javascript console says

    Error: totalCountMatch has no properties
    Source File: file:///c:/TEMP/nowPlaying.xhtml
    Line: 93

    I have changed the IP address to that of my TiVo and the MAK to match mine. Any ideas?
     
  19. Dec 23, 2005 #99 of 168
    bonnie_raitt

    bonnie_raitt New Member

    122
    0
    Sep 14, 2001
    Seattle, WA
    Doh!

    I had the IP of the TiVo wrong. It now shows 23 shows playing. Thanks. Pretty Cool
     
  20. TiVo Steve

    TiVo Steve New Member

    326
    0
    Nov 8, 2005
    Seattle WA.
    Well done!!!
    A quick question. I am new to the Series 2 units, how do you get the "extended" information (like guest actors) to display on the TiVo unit itself? I have not tried any "backdoors" codes on the Series 2 box yet! I do use them on my old Series 1.
    Again, thank you, a very cool script!
     

Share This Page