1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

4TB Roamio Image community edition

Discussion in 'TiVo Upgrade Center' started by telemark, May 26, 2014.

  1. May 26, 2014 #1 of 376
    telemark

    telemark New Member

    1,544
    1
    Nov 12, 2013
    Status:
    Unix: Works
    Mac: Works (but most mac's don't have SATA ports which then requires a modern USB-Sata adapter.)
    Windows: VHD available...Testing new cloning software...

    Requires:
    4TB hard drive
    Tivo Roamio
    Computer with a free Sata or eSata port
    USB docks may work, but not recommended
    (many older USB docks have bugs that don't go up 4TB)

    UNIX (Linux*/BSD/Mac) Command Line Installers
    The autoinstaller will search for drives for one with a Tivo signature**,
    download the image from the Net, and overwrite the drive with the image.

    * If needing a liveCD, knoppix has been tested
    ** If the drive is missing a signature, booting it in a Roamio will add a signature, or you can manually add one with a hex editor [0x1492]

    PC / Mac side:
    1) Connect Hard Drive to Computer (disconnect other HD's with important data)

    2) on PC: Boot from linux CD or USB stick on PC's.
    on Mac: boot normally into OS X. When asked to "Initialize" an unknown drive, just say No / Ignore / Cancel.

    3) Open Terminal, by clicking Terminal icon
    [​IMG][​IMG]
    4) Download Auto Installer, by typing at prompt:
    wget "http://tiny.cc/c6r5gxA/autoinstall.pl"
    ( or wget --no-check-certificate "http://tiny.cc/c6r5gxA/autoinstall.pl" )
    Another option is:
    curl -L http://tiny.cc/c6r5gxA/autoinstall.pl -o autoinstall.pl

    Enable execution by typing:
    chmod +x autoinstall.pl

    5) Start installer.

    On PC Linux or Apple Mac run:
    sudo ./autoinstall.pl

    This will ask for the account password.

    Lots of text will fly by, just follow along a best you can.
    The most important thing is to
    Check that it chooses the right drive.
    (you did already disconnect all your important drives, right?)

    It'll ask before making permanent changes, then
    when it starts writing...

    6) Take a break to let it finish
    ~20mins on USB2
    Less on USB3 or Sata
    More on USB1

    Alternate 4) Image + Basic Installer:
    wget --no-check-certificate "http://tiny.cc/c6r5gxB/4TBr1.tgz"
    bypasses safety mechanisms, so know what you're doing or
    don't use..

    Tivo Roamio side:
    7) Connect drive
    8) Turn on Power to Tivo
    9) Wait until Guided Setup (takes about 4 mins for first boot)
    10) Celebrate and Donate what you think it's worth.

    Known limitations:
    No data is migrated over (pytivo/kmttg backups should work)
    Cable Card will likely need to be re-paired, but in a smaller number of cases, this did not apply
    Not supersized
    Found Tivo bug, variance in fsck mount frequency, should be inconsequential

    Donations here:
    paypal or amazon-e-gift-card: marked @ gmail.com
    bitcoin:1Hvpf8qV8UJ8SS33QJ6VskggAStQQDnYp6

    Credits and Thank You to
    jmbach - for extensive testing and lots of direction
    ggieske - for tricky MFS answers and
    eboydog - for initial motivation

    Terms:
    Image and Installer Copyright 2014.
    License granted for personal use within a household.
    No commercial use or redistribution without prior permission.
    No warranty provided.
     
  2. Jun 1, 2014 #2 of 376
    compubob

    compubob New Member

    17
    0
    Apr 12, 2013
    I do not see a link to download anything and beta test
     
  3. Jun 1, 2014 #3 of 376
    darkstar757

    darkstar757 New Member

    8
    0
    Nov 14, 2007
  4. Jun 1, 2014 #4 of 376
    darkstar757

    darkstar757 New Member

    8
    0
    Nov 14, 2007
    Can you pm me the link?
     
  5. Jun 2, 2014 #5 of 376
    unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    Did you see the part where you're supposed to PM him first with some info?
     
  6. Jun 3, 2014 #6 of 376
    telemark

    telemark New Member

    1,544
    1
    Nov 12, 2013
    I clarified that after they posted, but I PM-ed everyone and never heard back. Is this a new account PM restriction thing?
     
  7. Jun 3, 2014 #7 of 376
    eboydog

    eboydog Just TiVo'ing.....

    904
    0
    Mar 23, 2006
    Might be, I don't recall the nature of the restriction but I know a couple users who were interested in a few things I listed for sale had to email directly as they weren't able to PM yet.

    I might be interested but I down to a single Roamio which is a Pro at 3tb right now but I'm tempted to try your project except I'm missing a 4tb drive, but perhaps in a couple weeks....
     
  8. Jun 3, 2014 #8 of 376
    byeams

    byeams New Member

    12
    0
    May 31, 2014
    I am unable to PM, but would love to test. I have a new Roamio base model (for OTA) and a shiny new WD 4 TB WD40EZRX along with a Windows 7 computer and SATA capability (I think I answered all the questions). Would be happy to test.
     
  9. Jun 3, 2014 #9 of 376
    byeams

    byeams New Member

    12
    0
    May 31, 2014
    And I didn't PM you because I don't have 10 posts yet. Sorry.
     
  10. Jun 9, 2014 #10 of 376
    jmbach

    jmbach der Neuerer

    1,553
    9
    Jan 1, 2009
    I have tested telemark's image in a Roamio Plus and have not found any operational issues or problems with it yet. It will give you 637 hours of HD. Haven't found any missing gui elements and all the menus appear functional. I have a Motorola MCard and I lost pairing of the cableCARD. (Had to call Charter 3 times before I got someone who could re-pair the cableCARD to the TiVo). You do not have to do a C&DE after you boot the image to sync it to the TiVo, it works with first boot.

    Major test not done on the image yet is to try to fill it up completely and see how it performs.

    Telemark did a great job in developing this image. :up::up:
     
  11. Jun 18, 2014 #11 of 376
    Heretic

    Heretic New Member

    13
    0
    Jun 18, 2014
    Hi, I tried this upgrade. I powered down my utility computer used to image the drive before I grabbed the pastebin URL of the run, but it all seemed to apply fine.

    However, after I put the HD back in the TiVo Roamio, it gets an initial boot screen but soon after it seems to lose HDMI output now. It doesn't come back. I have the original drive, I'm gonna verify it works fine with it.

    This is a 4-tuner Roamio. Any suggestions?
     
  12. Jun 18, 2014 #12 of 376
    eboydog

    eboydog Just TiVo'ing.....

    904
    0
    Mar 23, 2006
    Could it be trying to output a video format your TV can't handle? On the plus and Pro you can press the format button on the front panel however I forget if the basic Roamio has that same function? I can't recall if the basic has any external button function on the box, might try giving a few minutes to come up, press live TV then the clear buttons on the remote then the zoom button to see if the screen resolution changes but it should by default come up in a resolution that works.
     
  13. Jun 18, 2014 #13 of 376
    telemark

    telemark New Member

    1,544
    1
    Nov 12, 2013
    What OS did you run the install from? What kind of Hard Drive?

    You can always run the install again, it doesn't matter whether you did it before.

    There is a moment when a Roamio is booting the screen goes black, but it shouldn't be that way for longer than something like 20 seconds, unless somehow the box froze at that stage.
     
  14. Jun 18, 2014 #14 of 376
    jmbach

    jmbach der Neuerer

    1,553
    9
    Jan 1, 2009
    Consider checking if the boot partitions are the same for the original image and the 4TB image.
     
  15. Jun 18, 2014 #15 of 376
    Heretic

    Heretic New Member

    13
    0
    Jun 18, 2014
    I left it there all night, it comes up with an initial TiVo "Welcome" screen and then it loses signal after 10-20 seconds. Left it there all night no change.

    Doubtful it is an unsupported resolution, Samsung 8-series TV.
     
  16. Jun 18, 2014 #16 of 376
    Heretic

    Heretic New Member

    13
    0
    Jun 18, 2014
    Knoppix 7.2 Boot DVD on an old 2008-Dell Precision Tower.

    The harddrive is: WD AV-GP WD40EURX 4TB

    I booted the Roamio up before doing the upgrade and played around. There was never more than a half-second flicker switching between 480p and 1080i/p or whatever it went to next. Specifically, as it's booting, when the green light is on and begins to quickly blink back and forth between the green light and the yellowish light next to it, it immediately goes out after that quick sequence (which is typically when you can hit Pause for 2 seconds and hit the kickstart options per a Weakness page I don't have enough posts to link to). But basically right after the moment you can hit pause for 2 seconds to go into kickstart, that's when it loses output signal.

    Maybe there are some differences with the smaller Roamio? I'm guessing this was only tested on Plus and Pro versions? I'll run the upgrade on the HD again and make sure I don't lose the Pastebin of the output again.
     
  17. Jun 18, 2014 #17 of 376
    Heretic

    Heretic New Member

    13
    0
    Jun 18, 2014
    Ahhh so, that's interesting. How exactly should I check them? After I ran the utility, I couldn't even display the partition table with like parted or fdisk, it didn't seem to have a valid partition setup. Maybe I needed to do a partprobe first, I forgot to do that first. I'll try again.
     
  18. Jun 18, 2014 #18 of 376
    Heretic

    Heretic New Member

    13
    0
    Jun 18, 2014
    I have both original and new HDs plugged into my test computer booted into Knoppix. I am unsure how to check the partition setup to compare:
    Code:
    knoppix@Microknoppix:~$ parted -l
    Error: /dev/sda: unrecognised disk label                                  
    
    Error: /dev/sdb: unrecognised disk label                                  
    
    Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
    has been opened read-only.
    Error: /dev/sr0: unrecognised disk label                                  
    
    Error: /dev/zram0: unrecognised disk label                                
    
    Warning: Unable to open /dev/cloop0 read-write (Read-only file system).   
    /dev/cloop0 has been opened read-only.
    Error: /dev/cloop0: unrecognised disk label                               
    
    knoppix@Microknoppix:~$ fdisk -l
    
    Disk /dev/sda: 4000.8 GB, 4000787030016 bytes
    255 heads, 63 sectors/track, 486401 cylinders, total 7814037168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disk identifier: 0x00000000
    
    Disk /dev/sda doesn't contain a valid partition table
    
    Disk /dev/sdb: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x00000000
    
    Disk /dev/sdb doesn't contain a valid partition table
    
    I'm pretty new to TiVo upgrading, not sure if there is some TiVo specific command to pull the table.
     
  19. Jun 18, 2014 #19 of 376
    Heretic

    Heretic New Member

    13
    0
    Jun 18, 2014
    Here's the output of the scripts when I run again (removed original HD first):
    Code:
    knoppix@Microknoppix:~$ wget "http://tiny.cc/c6r5gxA/autoinstall.pl"
    --2014-06-18 10:17:52--  http://tiny.cc/c6r5gxA/autoinstall.pl
    Resolving tiny.cc (tiny.cc)... 192.241.240.89
    Connecting to tiny.cc (tiny.cc)|192.241.240.89|:80... connected.
    HTTP request sent, awaiting response... 301 Moved Permanently
    Location: http://dl.dropboxusercontent.com/u/51278/Tivo/4TB/autoinstall.pl [following]
    --2014-06-18 10:17:52--  http://dl.dropboxusercontent.com/u/51278/Tivo/4TB/autoinstall.pl
    Resolving dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 54.243.118.205, 107.21.115.150, 23.21.154.121, ...
    Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|54.243.118.205|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 4275 (4.2K) [text/x-perl]
    Saving to: `autoinstall.pl'
    
    100%[======================================>] 4,275       --.-K/s   in 0s      
    
    2014-06-18 10:17:52 (278 MB/s) - `autoinstall.pl' saved [4275/4275]
    
    knoppix@Microknoppix:~$ less autoinstall.pl 
    knoppix@Microknoppix:~$ chmod +x autoinstall.pl 
    knoppix@Microknoppix:~$ ./autoinstall.pl 
    ls: cannot access /dev/hd?: No such file or directory
    sda:
    [    1.784950] sd 0:0:0:0: [sda] 7814037168 512-byte logical blocks: (4.00 TB/3.63 TiB)
    [    1.784955] sd 0:0:0:0: [sda] 4096-byte physical blocks
    [    1.785062] sd 0:0:0:0: [sda] Write Protect is off
    [    1.785067] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
    [    1.785113] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
    [    1.796521]  sda: unknown partition table
    [    1.796902] sd 0:0:0:0: [sda] Attached SCSI disk
    4096 bytes received - [ Roamio ] - 
    
    sdc:
    0 bytes received - rejected - 
    
    sdd:
    0 bytes received - rejected - 
    
    sde:
    0 bytes received - rejected - 
    
    sdf:
    0 bytes received - rejected - 
    
    sdg:
    0 bytes received - rejected - 
    
    sdh:
    [    1.540445] sdhci: Secure Digital Host Controller Interface driver
    [    1.540447] sdhci: Copyright(c) Pierre Ossman
    [    1.540915] sdhci-pltfm: SDHCI platform and OF driver helper
    0 bytes received - rejected - 
    
    Target Drive /dev/sda found
    
    Testing /dev/sda
    Reading mid sector 488377323
    dd if=/dev/sda bs=4096 count=1 skip=488377323 of=/dev/null 
    1+0 records in
    1+0 records out
    4096 bytes (4.1 kB) copied, 0.0198814 s, 206 kB/s
     - PASSED - 
    Backing up mid sector 488377323
    dd if=/dev/sda bs=4096 count=1 skip=488377323 of=/tmp/dd-test.bin 
    1+0 records in
    1+0 records out
    4096 bytes (4.1 kB) copied, 0.000167767 s, 24.4 MB/s
     - PASSED - 
    Writing mid sector 488377323
    dd of=/dev/sda bs=4096 count=1 seek=488377323 if=/tmp/dd-test.bin 
    1+0 records in
    1+0 records out
    4096 bytes (4.1 kB) copied, 0.00681929 s, 601 kB/s
     - PASSED - 
    Reading last sector 976754645
    dd if=/dev/sda bs=4096 count=1 skip=976754645 of=/dev/null 
    1+0 records in
    1+0 records out
    4096 bytes (4.1 kB) copied, 0.000143868 s, 28.5 MB/s
     - PASSED - 
    Backing up last sector 976754645
    dd if=/dev/sda bs=4096 count=1 skip=976754645 of=/tmp/dd-test.bin 
    1+0 records in
    1+0 records out
    4096 bytes (4.1 kB) copied, 0.000659207 s, 6.2 MB/s
     - PASSED - 
    Writing last sector 976754645
    dd of=/dev/sda bs=4096 count=1 seek=976754645 if=/tmp/dd-test.bin 
    1+0 records in
    1+0 records out
    4096 bytes (4.1 kB) copied, 1.7071e-05 s, 240 MB/s
     - PASSED - 
    
    Downloading image
    --2014-06-18 10:19:10--  http://tiny.cc/y8r5gx
    Resolving tiny.cc (tiny.cc)... 192.241.240.89
    Connecting to tiny.cc (tiny.cc)|192.241.240.89|:80... connected.
    HTTP request sent, awaiting response... 301 Moved Permanently
    Location: http://dl.dropboxusercontent.com/u/51278/Tivo/4TB/4TBr1.tgz [following]
    --2014-06-18 10:19:11--  http://dl.dropboxusercontent.com/u/51278/Tivo/4TB/4TBr1.tgz
    Resolving dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 107.22.234.0, 184.73.187.123, 184.73.202.105, ...
    Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|107.22.234.0|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 41443 (40K) [application/x-gtar]
    Saving to: `4TBr1.tgz'
    
    100%[======================================>] 41,443      --.-K/s   in 0.04s   
    
    2014-06-18 10:19:11 (1.06 MB/s) - `4TBr1.tgz' saved [41443/41443]
    
    --2014-06-18 10:19:11--  http://tiny.cc/y8r5gxH
    Resolving tiny.cc (tiny.cc)... 192.241.240.89
    Connecting to tiny.cc (tiny.cc)|192.241.240.89|:80... connected.
    HTTP request sent, awaiting response... 301 Moved Permanently
    Location: http://dl.dropboxusercontent.com/u/51278/Tivo/4TB/HASHES.txt [following]
    --2014-06-18 10:19:11--  http://dl.dropboxusercontent.com/u/51278/Tivo/4TB/HASHES.txt
    Resolving dl.dropboxusercontent.com (dl.dropboxusercontent.com)... 184.73.187.123, 184.73.202.105, 184.73.234.37, ...
    Connecting to dl.dropboxusercontent.com (dl.dropboxusercontent.com)|184.73.187.123|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 135 [text/plain]
    Saving to: `HASHES.txt'
    
    100%[======================================>] 135         --.-K/s   in 0s      
    
    2014-06-18 10:19:11 (15.2 MB/s) - `HASHES.txt' saved [135/135]
    
    
    Locating verifier
    /usr/bin/md5sum
    Checking hash
    3b0b8870d20d329a190423fd152da20d ? 3b0b8870d20d329a190423fd152da20d  /tmp/roamio-img/4TBr1.tgz
     - PASSED - 
    
    Extracting
    4TBr1/
    4TBr1/README.txt
    4TBr1/mid_3900907584.bin.gz
    4TBr1/bin/
    4TBr1/beg_0.bin.gz
    4TBr1/install.sh
    4TBr1/INSTALL.txt
    4TBr1/end_7814016688.bin.gz
    4TBr1/bin/bpatch
    4TBr1/bin/random16r1
     - PASSED - 
    
    Viewing License Terms:
    Image and Installer, Copyright 2014, telemark of tivocommunity.com
    License granted for personal use within a single household.
    Commercial use or redistribution prohibited, without prior permission and license.
    
    Image has been tested by some community members, but
    NO warranty is provided.
    Some support may be found on the forums.
    
    To support future projects:
    Financial or Hardware donations encouraged.
    
    Version r1, June 7th, 2014
    
    Proceed to permanently overwrite /dev/sda ( yes / no ) ?
    yes
    Starting install.sh /dev/sda 4096
    Countdown to Erasing /dev/sda
    20 19 18 17 16 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 
    16 @ 304
    Trying 'gunzip -c end_7814016688.bin.gz | dd bs=4096 seek=976752086 of=/dev/sda'
    2560+0 records in
    2560+0 records out
    10485760 bytes (10 MB) copied, 0.197528 s, 53.1 MB/s
    Trying 'gunzip -c mid_3900907584.bin.gz | dd bs=4096 seek=487613448 of=/dev/sda'
    1527758+0 records in
    1527758+0 records out
    6257696768 bytes (6.3 GB) copied, 53.8071 s, 116 MB/s
    Trying 'cat    beg_0.bin             | dd bs=4096 seek=0 of=/dev/sda'
    8+0 records in
    8+0 records out
    32768 bytes (33 kB) copied, 0.00876268 s, 3.7 MB/s
    No Errors Reported
    
    OK, I just figured out the problem. I reproduced the issue with factory drive. It turned out the HDMI cable went bad, probably when I was pulling it out further to work on the TiVo. Go figure. I plugged it into the HDMI cable on one of the game consoles that I knew worked, and Viola. I put the 4TB back in, and it change resolution. It's at the "Almost there..." screen now.

    Problem solved, the 4TB upgrade works great! Thanks guys.
     
  20. Jun 18, 2014 #20 of 376
    telemark

    telemark New Member

    1,544
    1
    Nov 12, 2013
    N, I used the smaller basic Roamio, and jmbach used a Pro, so we have those bases well covered.

    Looks correct.

    Well that's an odd one, I wonder why the 1st screen would come up but not the others. I noticed with the base model, it's so light it's tricky to get the HDMI and eSata cable all the way in.

    But glad it was resolved.
     

Share This Page