1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.4a Photos 2.0 - Application Error popup

Discussion in 'TiVo Home Media Features & TiVoToGo' started by miller890, May 20, 2007.

  1. miller890

    miller890 Member

    351
    0
    Feb 15, 2002
    On TivoDesktop 2.4a (same with 2.4) when I enable Photos 2.0 for HD series-3 I receive an application error on startup. I running Java v 1.6.0 (build 1.6.0_01-b06) and I have uninstalled and reinstalled both Java the Tivo desktop a number of time. The strange thing is that it will work just after the Tivo Desktop install, but after a reboot the following error is shown in a Java popup window and Photos 2.0 no longer works.

     
  2. miller890

    miller890 Member

    351
    0
    Feb 15, 2002
    I am running out of ideas...

    So far I have tried a clean install of both Desktop 2.4 & 2.4a and Java 1.6 a few times on XP w/SP2. I have disabled ZoneAlert and anti-virus software when installing and later when attempting to start Photos 2.0; HD photos again will only work just after install - reboot and I get the error above. At one time I had Tivo Desktop 2.4 beta w/photos and an older Java version working fine; maybe something that was left behind that needs to be removed. Maybe the problem is the newer and only version of java that java.com offers.

    Does anyone know if "Could not load file/URL specified: hdphotos.jnlp" is local or remote file?

    Any suggestions/ideas would be appreciated. Thanks.
     
  3. miller890

    miller890 Member

    351
    0
    Feb 15, 2002
    bump
     
  4. miller890

    miller890 Member

    351
    0
    Feb 15, 2002
    bump
     
  5. Dennis Wilkinson

    Dennis Wilkinson New Member

    2,064
    0
    Sep 24, 2001
    East...
    hdphotos.jnlp is a local file, and should be in C:\Program Files\TiVo\Desktop\Hme\

    While the .jnlp file is local, it loads some remote resources. I suppose that could play into it. Some JNLP downloads are cached; it could be that your cached versions aren't behaving, I suppose, although I don't recall where those live under the WinXP JVM.
     
  6. tannebil

    tannebil Member

    78
    1
    Mar 9, 2006
    I had the same problem until I uninstalled 2.4a and reinstalled. The non-working install was on D: while the working install is using the default location on C:. I chalked it up to a hard coded path name someplace but don't really know for certain.
     
  7. dw_penn

    dw_penn New Member

    2
    0
    Feb 10, 2007
    My hat's off to everyone I read as I sought a solution for myself. Everyone I read was clearly operating from a higher level of understanding than I myself. I decided there was one way to handle this and that was to stop hdphotos.jnlp from starting in the first place since it doesn't interfere with my particular use of the TiVo Desktop Server. I used Task-Watcher (made by the same producer as Win-Patrol, it stops anything listed that you don't want started).

    Still from the banter I did glean something worth a try. In my perusal I found a thread that suggested prior versions of Java didn't have the problem, but that Oracle removed them from download access. Knowing that last part to be incorrect I un-installed my up-to-date Java and selected an older version from the archives and that eliminated the error and conflict with TiVo and O.S. security. I can still use Task-Watcher to keep Java from annoying me with later version announcements. At some future point I can give a newer version a try and either they or TiVo may have worked out the issue by then. DP
     

Share This Page